aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2007-08-20 15:26:17 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2007-08-20 15:26:17 +0000
commit939623febfeb2f5288cbe6a54d3f02995620cbda (patch)
treef28bbd6df8d6b9f0b1e067f7d02a803007f5dc59 /sci-libs/lapackpp/lapackpp-2.5.2.ebuild
parent{blas,lapack}-atlas: updated patch (diff)
downloadsci-939623febfeb2f5288cbe6a54d3f02995620cbda.tar.gz
sci-939623febfeb2f5288cbe6a54d3f02995620cbda.tar.bz2
sci-939623febfeb2f5288cbe6a54d3f02995620cbda.zip
lapackpp: initial import
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@701 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-libs/lapackpp/lapackpp-2.5.2.ebuild')
-rw-r--r--sci-libs/lapackpp/lapackpp-2.5.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/lapackpp/lapackpp-2.5.2.ebuild b/sci-libs/lapackpp/lapackpp-2.5.2.ebuild
new file mode 100644
index 000000000..19f915775
--- /dev/null
+++ b/sci-libs/lapackpp/lapackpp-2.5.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="C++ wrapper for LAPACK"
+HOMEPAGE="http://lapackpp.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE=""
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/blas
+ virtual/lapack"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf \
+ --with-blas="$(pkg-config --libs blas)" \
+ --with-lapack="$(pkg-config --libs lapack)" \
+ || die "econf failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "emake srcdoc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS README ChangeLog AUTHORS || die "dodoc failed"
+ if use doc; then
+ dohtml api-doc/html || die "dohtml failed"
+ fi
+}