aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-03-17 16:21:32 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-03-17 16:21:32 +0000
commit76ffb781ed7a917f23b67454e9f950e5e3b83527 (patch)
tree94fa8e1ddc7cb9ef80b78ea7896a5845f074f95b /sci-libs/lapackpp
parentmove stuff to root (diff)
downloadsci-76ffb781ed7a917f23b67454e9f950e5e3b83527.tar.gz
sci-76ffb781ed7a917f23b67454e9f950e5e3b83527.tar.bz2
sci-76ffb781ed7a917f23b67454e9f950e5e3b83527.zip
moved overlay to new directory
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@979 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-libs/lapackpp')
-rw-r--r--sci-libs/lapackpp/ChangeLog8
-rw-r--r--sci-libs/lapackpp/Manifest4
-rw-r--r--sci-libs/lapackpp/lapackpp-2.5.2.ebuild38
-rw-r--r--sci-libs/lapackpp/metadata.xml18
4 files changed, 68 insertions, 0 deletions
diff --git a/sci-libs/lapackpp/ChangeLog b/sci-libs/lapackpp/ChangeLog
new file mode 100644
index 000000000..0ad3c5d2d
--- /dev/null
+++ b/sci-libs/lapackpp/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sci-libs/lapackpp
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 20 Aug 2007; SĂ©bastien Fabbro <bicatali@gentoo.org>
+ +lapackpp-2.5.2.ebuild, +metadata.xml:
+ Initial import
+
diff --git a/sci-libs/lapackpp/Manifest b/sci-libs/lapackpp/Manifest
new file mode 100644
index 000000000..c3985bd5d
--- /dev/null
+++ b/sci-libs/lapackpp/Manifest
@@ -0,0 +1,4 @@
+DIST lapackpp-2.5.2.tar.gz 571096 RMD160 4afe2d18d78450b8ad11ed350b597a2eab09ad38 SHA1 24a5867cf5cea4c3505597beb85121f71a342561 SHA256 f79c985801e1de9d8b5165894c60fd3b08818e9b0a406ff29fe48783a5134a9c
+EBUILD lapackpp-2.5.2.ebuild 880 RMD160 a5380e010266bfb732f49cc31f2bdb9f8d90d075 SHA1 2ea1ddda89a0282cb9cdc0981a1ef2eec97b5ed6 SHA256 59558a056a86d829d80aa2bae9b6c68f252cd51c22beb41b88910a473b033f72
+MISC ChangeLog 232 RMD160 ff2edbb4039e144655f8660d53849b8a4cc543a7 SHA1 44c84bc527ef81be0b34dc71c440d2d66dafb04a SHA256 c09db4778ce957cfdc5c5eb956cc22580198a0bcdb674119c097e4280de9add4
+MISC metadata.xml 843 RMD160 6ae5c4725768374a0d9b1b511230693c2056e005 SHA1 74da47532a68ad6a64e515d8793c7e4d08fda448 SHA256 91ec444b6dd8603a84b473e8272d4b7b0c10bd6641b12506627fcf86cecf4ed8
diff --git a/sci-libs/lapackpp/lapackpp-2.5.2.ebuild b/sci-libs/lapackpp/lapackpp-2.5.2.ebuild
new file mode 100644
index 000000000..7446b1229
--- /dev/null
+++ b/sci-libs/lapackpp/lapackpp-2.5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="C++ wrapper for LAPACK"
+HOMEPAGE="http://lapackpp.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/blas
+ virtual/lapack"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf \
+ --disable-atlas \
+ --with-blas="$(pkg-config --libs blas)" \
+ --with-lapack="$(pkg-config --libs lapack)" \
+ || die "econf failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "emake srcdoc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS README ChangeLog AUTHORS || die "dodoc failed"
+ if use doc; then
+ dohtml api-doc/html || die "dohtml failed"
+ fi
+}
diff --git a/sci-libs/lapackpp/metadata.xml b/sci-libs/lapackpp/metadata.xml
new file mode 100644
index 000000000..96625413a
--- /dev/null
+++ b/sci-libs/lapackpp/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+LAPACK++ (Linear Algebra PACKage in C++) is a software library for
+numerical linear algebra that solves systems of linear equations and eigenvalue
+problems on high performance computer architectures.
+
+Computational support is provided for supports various matrix classes
+for vectors, non-symmetric matrices, SPD matrices, symmetric matrices,
+banded, triangular, and tridiagonal matrices; however, it does not include all
+of the capabilities of original f77 LAPACK. Emphasis is given to
+routines for solving linear systems consisting of non-symmetric matrices,
+symmetric positive definite systems, and solving linear least-square
+systems.
+</longdescription>
+</pkgmetadata>