aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schäfer <gentryx@gmx.de>2013-02-07 23:49:05 +0100
committerAndreas Schäfer <gentryx@gmx.de>2013-02-07 23:49:05 +0100
commit6ce22ac599ba6f07c09d040ff4649df36ccad3bb (patch)
tree8cff172aa40f7195b3752114a7e5464455deefd3 /sci-libs/libgeodecomp/libgeodecomp-0.1.0.ebuild
parentMerge ../sci.bitbucket (diff)
downloadsci-6ce22ac599ba6f07c09d040ff4649df36ccad3bb.tar.gz
sci-6ce22ac599ba6f07c09d040ff4649df36ccad3bb.tar.bz2
sci-6ce22ac599ba6f07c09d040ff4649df36ccad3bb.zip
resolved various warnings reported by repoman for LibGeoDecomp and HPX, also fixed shortcomings as requested by jlec in https://github.com/gentoo-science/sci/pull/49/files#r2931081
Diffstat (limited to 'sci-libs/libgeodecomp/libgeodecomp-0.1.0.ebuild')
-rw-r--r--sci-libs/libgeodecomp/libgeodecomp-0.1.0.ebuild43
1 files changed, 20 insertions, 23 deletions
diff --git a/sci-libs/libgeodecomp/libgeodecomp-0.1.0.ebuild b/sci-libs/libgeodecomp/libgeodecomp-0.1.0.ebuild
index 117f06b77..87888911d 100644
--- a/sci-libs/libgeodecomp/libgeodecomp-0.1.0.ebuild
+++ b/sci-libs/libgeodecomp/libgeodecomp-0.1.0.ebuild
@@ -1,50 +1,47 @@
-# Copyright 2013-2013 Andreas Schäfer
+# Copyright 2013-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=4
-inherit versionator
-
-if [[ ${PV} == "9999" ]] ; then
- _SCM=mercurial
- EHG_REPO_URI="http://bitbucket.org/gentryx/libgeodecomp"
- SRC_URI=""
- KEYWORDS=""
- CMAKE_USE_DIR="${S}/src"
+if [ ${PV} == "9999" ] ; then
+ _SCM=mercurial
+ EHG_REPO_URI="http://bitbucket.org/gentryx/libgeodecomp"
+ SRC_URI=""
+ KEYWORDS=""
+ CMAKE_USE_DIR="${S}/src"
else
- SRC_URI="http://www.libgeodecomp.org/archive/${P}.tar.bz2"
- KEYWORDS="~amd64 ~ppc ~x86"
- S="${WORKDIR}/${P}/src"
+ SRC_URI="http://www.libgeodecomp.org/archive/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/${P}/src"
fi
-inherit cmake-utils vcs-snapshot ${_SCM}
+inherit cmake-utils vcs-snapshot ${_SCM}
-DESCRIPTION="LibGeoDecomp is an auto-parallelizing library to speed up your stencil code based computer simulations. It runs on virtually all current architectures, be it multi-cores, GPUs, or large scale MPI clusters. "
+DESCRIPTION="An auto-parallelizing library to speed up computer simulations."
HOMEPAGE="http://www.libgeodecomp.org"
-LICENSE="LGPL-3.0"
+LICENSE="LGPL-3"
SLOT="0"
-IUSE="mpi"
RDEPEND=">=dev-libs/boost-1.48"
DEPEND="${RDEPEND}"
src_prepare() {
- epatch "${FILESDIR}/cmake.patch"
+ epatch "${FILESDIR}/cmake.patch"
}
src_compile() {
- cmake-utils_src_compile
- if ( use doc); then
- cmake-utils_src_compile doc
- fi
+ cmake-utils_src_compile
+ if use doc; then
+ cmake-utils_src_compile doc
+ fi
}
src_install() {
- cmake-utils_src_install
+ cmake-utils_src_install
}
src_test() {
- cmake-utils_src_compile test
+ cmake-utils_src_compile test
}