aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-12-30 16:20:32 +0100
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-12-30 16:20:32 +0100
commit08a272766f1feb9206762a4c51839c55a9c7637d (patch)
tree42addb7c18cefac81f01407823cb11d3c3755511 /sci-libs/libmaus2
parentsci-libs/libmaus2: update the ebuild for gitlab.com site (diff)
downloadsci-08a272766f1feb9206762a4c51839c55a9c7637d.tar.gz
sci-08a272766f1feb9206762a4c51839c55a9c7637d.tar.bz2
sci-08a272766f1feb9206762a4c51839c55a9c7637d.zip
sci-libs/libmaus2: version bump to 2.0.689
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
Diffstat (limited to 'sci-libs/libmaus2')
-rw-r--r--sci-libs/libmaus2/Manifest1
-rw-r--r--sci-libs/libmaus2/libmaus2-2.0.689.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sci-libs/libmaus2/Manifest b/sci-libs/libmaus2/Manifest
index b1dff8dc9..7cb51d3bb 100644
--- a/sci-libs/libmaus2/Manifest
+++ b/sci-libs/libmaus2/Manifest
@@ -1 +1,2 @@
DIST libmaus2-2.0.587.tar.gz 3673092 BLAKE2B 94c56fa4141a0e7f5f9f60ceb57d1b73252c05397bf0914eb15ce73d4fb7cb37e053f1de12cd2d93f5d50280ce46718bc02223c4b97fad70f2d172bdf7101712 SHA512 8e1e3046c6b9b2abf013fa16d7eab6173d32dc31c4f429f8161df2da0a41c972beb3fdffe85091429d6f6920ddafeb4e84e1626dc56f8fec6ef1d76742385572
+DIST libmaus2-2.0.689.tar.gz 3479996 BLAKE2B 30aa0b43ba247e7724d1d8120a13a040f168d5eef1cd74d00a0ff5daa29f05d8991afddbfab8ab2dee0c0040f6c90331f12180a5ee26ab08b92581d63311a55b SHA512 8aedc71b29e8852b46f0eda4bcedbf746c1fbc7685fd96db91f7a66c77521c8af4f98a47ccf0f00672795b8573033bd2cd612cd4c188ed4354024ef717869b79
diff --git a/sci-libs/libmaus2/libmaus2-2.0.689.ebuild b/sci-libs/libmaus2/libmaus2-2.0.689.ebuild
new file mode 100644
index 000000000..50b82d5aa
--- /dev/null
+++ b/sci-libs/libmaus2/libmaus2-2.0.689.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+release_data="20191120141844"
+DESCRIPTION="Library for biobambam2"
+HOMEPAGE="https://github.com/gt1/libmaus"
+SRC_URI="https://gitlab.com/german.tischler/${PN}/-/archive/${PV}-release-${release_data}/${P}-release-${release_data}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2 GPL-3 MIT ZLIB" # BUG: incomplete list of licenses, see AUTHORS
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2"
+
+DEPEND="
+ !sci-libs/libmaus
+ >=sci-libs/io_lib-1.14.11
+ app-arch/snappy
+ sci-libs/fftw
+ sci-libs/hdf5
+ net-libs/gnutls
+ dev-libs/nettle"
+# --with-daligner
+# --with-irods
+# old github.com release tarballs
+# S="${WORKDIR}"/libmaus2-master-27828cd78121d5e4b19c263c5527e462360f5901
+# current gitlab.com release tarballs
+S="${WORKDIR}/${P}-release-${release_data}"
+
+src_configure(){
+ local CONFIG_OPTS
+ use cpu_flags_x86_ssse3 && CONFIG_OPTS+=( --enable-ssse3 )
+ ( use cpu_flags_x86_sse4_1 || use cpu_flags_x86_sse4_2 ) && CONFIG_OPTS+=( --enable-sse4 )
+ econf --with-snappy --with-io_lib $CONFIG_OPTS \
+ --with-lzma --with-gnutls --with-nettle --with-hdf5 --with-gmp --with-fftw
+}
+
+pkg_postinst(){
+ einfo "The io_lib, snappy dependencies are not strictly needed"
+ einfo "but were forced for optimal libmaus2 performance."
+ einfo "igzip is only used if gzip level is set to 11."
+}