aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-04-18 14:09:06 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-04-18 14:09:06 +0200
commit51fe11a3b2a3519a325f9cb86f1b27ea0cf9ec62 (patch)
tree11f67931619f5003eb9f7c3ef02e31fe3824e772 /sci-libs/libmaus2
parentsci-biology/flexbar: version bump, added KEYWORDS (diff)
downloadsci-51fe11a3b2a3519a325f9cb86f1b27ea0cf9ec62.tar.gz
sci-51fe11a3b2a3519a325f9cb86f1b27ea0cf9ec62.tar.bz2
sci-51fe11a3b2a3519a325f9cb86f1b27ea0cf9ec62.zip
sci-libs/libmaus2: make configure to enable optional but highly wanted features
The configure by default has a number of features disables, and does not enable the option. It somehow does not even try to look for headers and libs from say snappy unless --enable-snappy was passed. Try to blindly enable most of the features although it is not clear whether say gnutls should be preferred over nettle, likewise when --enable-sse4 is any better --enable-sse3 (and should not be enabled concurrently with it). Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sci-libs/libmaus2')
-rw-r--r--sci-libs/libmaus2/libmaus2-9999.ebuild20
1 files changed, 17 insertions, 3 deletions
diff --git a/sci-libs/libmaus2/libmaus2-9999.ebuild b/sci-libs/libmaus2/libmaus2-9999.ebuild
index ab60eeb60..fcf29886d 100644
--- a/sci-libs/libmaus2/libmaus2-9999.ebuild
+++ b/sci-libs/libmaus2/libmaus2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,19 +12,33 @@ EGIT_REPO_URI="https://github.com/gt1/libmaus2.git"
LICENSE="GPL-3" # BUG: a mix of licenses, see AUTHORS
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2"
DEPEND="
!sci-libs/libmaus
sci-libs/io_lib
app-arch/snappy
- sci-biology/seqan"
+ sci-biology/seqan
+ sci-libs/fftw
+ sci-libs/hdf5
+ net-libs/gnutls
+ dev-libs/nettle"
+# --with-daligner
+# --with-irods
src_prepare() {
eautoreconf
eapply_user
}
+src_configure(){
+ local CONFIG_OPTS
+ use cpu_flags_x86_ssse3 && CONFIG_OPTS+=( --enable-ssse3 )
+ ( use cpu_flags_x86_sse4_1 || use cpu_flags_x86_sse4_2 ) && CONFIG_OPTS+=( --enable-sse4 )
+ econf --with-snappy --with-seqan --with-io_lib $CONFIG_OPTS \
+ --with-lzma --with-gnutls --with-nettle --with-hdf5 --with-gmp --with-fftw
+}
+
pkg_postinst(){
einfo "The io_lib, snappy and seqan dependencies are not strictly needed"
einfo "but were forced for optimal libmaus2 performance."