aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2011-07-31 21:19:57 -0400
committerAndrey Kislyuk <weaver@gentoo.org>2011-07-31 21:19:57 -0400
commitbd5a3128bbf99d0f61a4091e17ea498e79710879 (patch)
treed1f7ac5df1cfe0d5edfe7bb0b72897a27d9d0f1b /sci-libs/libspatialindex/libspatialindex-1.6.1.ebuild
parentRevert "New package" (diff)
downloadsci-bd5a3128bbf99d0f61a4091e17ea498e79710879.tar.gz
sci-bd5a3128bbf99d0f61a4091e17ea498e79710879.tar.bz2
sci-bd5a3128bbf99d0f61a4091e17ea498e79710879.zip
New package
Diffstat (limited to 'sci-libs/libspatialindex/libspatialindex-1.6.1.ebuild')
-rw-r--r--sci-libs/libspatialindex/libspatialindex-1.6.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/libspatialindex/libspatialindex-1.6.1.ebuild b/sci-libs/libspatialindex/libspatialindex-1.6.1.ebuild
new file mode 100644
index 000000000..9286f0250
--- /dev/null
+++ b/sci-libs/libspatialindex/libspatialindex-1.6.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+EAPI=4
+
+MY_PN="spatialindex-src"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="General framework for developing spatial indices"
+HOMEPAGE="http://trac.gispython.org/spatialindex/wiki"
+SRC_URI="http://download.osgeo.org/libspatialindex/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "einstall failed"
+}