aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2008-05-02 21:33:48 +0000
committergrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2008-05-02 21:33:48 +0000
commite45632ac2697bc4fec9fd0475ac72d5d9dd51554 (patch)
treec73a1b4c52f56a8bdcb557bdbbdfe18380a8478e /sci-libs/mathgl/files
parentDon't spit out errors if people aren't using empi (diff)
downloadsci-e45632ac2697bc4fec9fd0475ac72d5d9dd51554.tar.gz
sci-e45632ac2697bc4fec9fd0475ac72d5d9dd51554.tar.bz2
sci-e45632ac2697bc4fec9fd0475ac72d5d9dd51554.zip
mathgl-1.6.2 cleanup and improvements
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1035 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-libs/mathgl/files')
-rw-r--r--sci-libs/mathgl/files/mathgl-fltk.patch10
-rw-r--r--sci-libs/mathgl/files/mathgl-no-cp1251.patch12
2 files changed, 17 insertions, 5 deletions
diff --git a/sci-libs/mathgl/files/mathgl-fltk.patch b/sci-libs/mathgl/files/mathgl-fltk.patch
index afd034b79..69039df00 100644
--- a/sci-libs/mathgl/files/mathgl-fltk.patch
+++ b/sci-libs/mathgl/files/mathgl-fltk.patch
@@ -1,24 +1,24 @@
diff -U2 --recursive mathgl-1.6.2.orig/configure.ac mathgl-1.6.2/configure.ac
--- mathgl-1.6.2.orig/configure.ac 2008-04-03 01:24:42.000000000 +0700
-+++ mathgl-1.6.2/configure.ac 2008-04-30 12:35:25.000000000 +0700
++++ mathgl-1.6.2/configure.ac 2008-05-03 11:36:42.000000000 +0700
@@ -144,8 +144,8 @@
*) AC_MSG_ERROR(bad value ${enableval} for --enable-fltk) ;;
esac],[fltk=false])
-AC_CHECK_HEADER(FL/Fl_Export.H,[(test x$all = xtrue || test x$fltk = xtrue) && FLTK_FLAGS=-DHAVE_FLTK AC_SUBST(FLTK_FLAGS)],
-+AC_CHECK_HEADER(fltk-1.1/FL/Fl_Export.H,[(test x$all = xtrue || test x$fltk = xtrue) && FLTK_FLAGS="-DHAVE_FLTK -I/usr/include/fltk-1.1" AC_SUBST(FLTK_FLAGS)],
++AC_CHECK_HEADER(@FLTK_H@FL/Fl_Export.H,[(test x$all = xtrue || test x$fltk = xtrue) && FLTK_FLAGS="-DHAVE_FLTK @FLTK_FLAGS@" AC_SUBST(FLTK_FLAGS)],
[(test x$all = xtrue || test x$fltk = xtrue) && echo "Please install fltk headers" && exit])
-AC_CHECK_LIB([fltk], [main], [(test x$all = xtrue || test x$fltk = xtrue) && FLTK_LIBS="-lfltk -lfltk_images" AC_SUBST(FLTK_LIBS)],
-+AC_CHECK_LIB([fltk], [main], [(test x$all = xtrue || test x$fltk = xtrue) && FLTK_LIBS="-L/usr/lib/fltk-1.1 -lfltk -lfltk_images -lXft" AC_SUBST(FLTK_LIBS)],
++AC_CHECK_LIB([fltk], [main], [(test x$all = xtrue || test x$fltk = xtrue) && FLTK_LIBS="@FLTK_LIBS@" AC_SUBST(FLTK_LIBS)],
[(test x$all = xtrue || test x$fltk = xtrue) && echo "Please install fltk library" && exit])
AM_CONDITIONAL(USE_FLTK, (test x$all = xtrue || test x$fltk = xtrue))
diff -U2 --recursive mathgl-1.6.2.orig/examples/Makefile.am mathgl-1.6.2/examples/Makefile.am
--- mathgl-1.6.2.orig/examples/Makefile.am 2008-04-03 01:24:42.000000000 +0700
-+++ mathgl-1.6.2/examples/Makefile.am 2008-04-30 13:01:09.000000000 +0700
++++ mathgl-1.6.2/examples/Makefile.am 2008-05-03 11:37:28.000000000 +0700
@@ -19,5 +19,5 @@
mgl_fltk_example_SOURCES = fltk_example.cpp
mgl_fltk_example_LDADD = $(top_builddir)/mgl/libmgl-fltk.la
-mgl_fltk_example_CFLAGS = -O2
-+mgl_fltk_example_CFLAGS = -I/usr/include/fltk-1.1
++mgl_fltk_example_CFLAGS = -O2 @FLTK_FLAGS@
mgl_fltk_example_CPPFLAGS = $(mgl_fltk_example_CFLAGS)
endif
diff --git a/sci-libs/mathgl/files/mathgl-no-cp1251.patch b/sci-libs/mathgl/files/mathgl-no-cp1251.patch
new file mode 100644
index 000000000..089d1890d
--- /dev/null
+++ b/sci-libs/mathgl/files/mathgl-no-cp1251.patch
@@ -0,0 +1,12 @@
+diff -U2 --recursive mathgl-1.6.2.orig/examples/full_test.cpp mathgl-1.6.2/examples/full_test.cpp
+--- mathgl-1.6.2.orig/examples/full_test.cpp 2008-04-04 22:21:20.000000000 +0700
++++ mathgl-1.6.2/examples/full_test.cpp 2008-05-03 10:57:37.000000000 +0700
+@@ -253,6 +253,6 @@
+ int sample_a4(mglGraph *gr, const void *) // font features
+ {
+- setlocale(LC_CTYPE, "ru_RU.cp1251");
+- gr->Puts(mglPoint(0,1),"Text can be in english и на русском");
++ //setlocale(LC_CTYPE, "ru_RU.cp1251");
++ gr->Puts(mglPoint(0,1),"Text can be in english or russian");
+ gr->Puts(mglPoint(0,0.6),"It can be \\wire{wire} and \\big{big}");
+ gr->Puts(mglPoint(0,0.2),"One can change style in string: "