aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-01-25 10:01:19 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-01-25 10:01:19 +0100
commit6b76c450fd2c03f574524e3d01b54de20b7dcb20 (patch)
tree32e1813cf52a31e184b2e89ff17fcd7c013c9c40 /sci-libs/mpiblacs/mpiblacs-1.1-r1.ebuild
parentsys-cluster/htcondor: Clean patches according to the CLEAN PATCH HOWTO (diff)
downloadsci-6b76c450fd2c03f574524e3d01b54de20b7dcb20.tar.gz
sci-6b76c450fd2c03f574524e3d01b54de20b7dcb20.tar.bz2
sci-6b76c450fd2c03f574524e3d01b54de20b7dcb20.zip
sci-libs/mpiblacs: Move to EAPI=5; Add missing dies
Diffstat (limited to 'sci-libs/mpiblacs/mpiblacs-1.1-r1.ebuild')
-rw-r--r--sci-libs/mpiblacs/mpiblacs-1.1-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sci-libs/mpiblacs/mpiblacs-1.1-r1.ebuild b/sci-libs/mpiblacs/mpiblacs-1.1-r1.ebuild
index 3d512cf29..833380a56 100644
--- a/sci-libs/mpiblacs/mpiblacs-1.1-r1.ebuild
+++ b/sci-libs/mpiblacs/mpiblacs-1.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
inherit eutils toolchain-funcs versionator alternatives-2 multilib
DESCRIPTION="Basic Linear Algebra Communication Subprograms with MPI"
@@ -42,13 +42,13 @@ static_to_shared() {
-Wl,--whole-archive ${libstatic} -Wl,--no-whole-archive \
"$@" -o ${libdir}/${soname} || die "${soname} failed"
[[ $(get_version_component_count) -gt 1 ]] && \
- ln -s ${soname} ${libdir}/${libname}$(get_libname $(get_major_version))
- ln -s ${soname} ${libdir}/${libname}$(get_libname)
+ ln -s ${soname} ${libdir}/${libname}$(get_libname $(get_major_version)) || die
+ ln -s ${soname} ${libdir}/${libname}$(get_libname) || die
fi
}
src_prepare() {
- find . -name Makefile -exec sed -i -e 's:make:$(MAKE):g' '{}' \;
+ find . -name Makefile -exec sed -i -e 's:make:$(MAKE):g' '{}' \; || die
sed -e "s:\(SHELL\s*=\).*:\1$(type -P sh):" \
-e "s:\(BTOPdir\s*=\).*:\1${S}:" \