aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-07-11 14:32:17 -0400
committerHorea Christian <chr@chymera.eu>2022-07-11 14:32:17 -0400
commit0c07f1c2cc4caec9042ea446d13ed857139f8caf (patch)
tree043232ded380e19ca5e64739e70d48b4413ec414 /sci-libs/nipype/nipype-1.5.0.ebuild
parentdev-vcs/datalad: version bump (diff)
downloadsci-0c07f1c2cc4caec9042ea446d13ed857139f8caf.tar.gz
sci-0c07f1c2cc4caec9042ea446d13ed857139f8caf.tar.bz2
sci-0c07f1c2cc4caec9042ea446d13ed857139f8caf.zip
sci-libs/nipype: EAPI and PYTHON_COMPAT bump, test fix
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-libs/nipype/nipype-1.5.0.ebuild')
-rw-r--r--sci-libs/nipype/nipype-1.5.0.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/sci-libs/nipype/nipype-1.5.0.ebuild b/sci-libs/nipype/nipype-1.5.0.ebuild
index 35792adbc..67e244049 100644
--- a/sci-libs/nipype/nipype-1.5.0.ebuild
+++ b/sci-libs/nipype/nipype-1.5.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+),sqlite"
inherit distutils-r1
@@ -47,6 +47,7 @@ RDEPEND="
PATCHES=(
"${FILESDIR}/${P}"-version_check.patch
+ "${FILESDIR}/${P}"-collections.patch
)
src_prepare() {
@@ -68,10 +69,18 @@ python_install_all() {
doenvd "${FILESDIR}/98nipype"
}
+EPYTEST_DESELECT=(
+ nipype/algorithms/tests/test_CompCor.py::TestCompCor::test_compcor
+ nipype/algorithms/tests/test_CompCor.py::TestCompCor::test_compcor_variance_threshold_and_metadata
+ nipype/algorithms/tests/test_CompCor.py::TestCompCor::test_tcompcor
+ nipype/interfaces/tests/test_io.py::test_s3datagrabber_communication
+ nipype/utils/tests/test_cmd.py::TestNipypeCMD::test_main_returns_0_on_help
+)
+
python_test() {
# Setting environment variable to disable etelemetry version check:
# https://github.com/nipy/nipype/issues/3196#issuecomment-605980044
- NIPYPE_NO_ET=1 pytest -vv\
+ NIPYPE_NO_ET=1 epytest -vv\
|| die
# Upstream test configuration fails
#-c nipype/pytest.ini\