aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-08-10 03:47:24 +0200
committerHorea Christian <horea.christ@yandex.com>2018-08-10 03:47:24 +0200
commit81bed4e668e2ee6425cc555524189ceb2198a04f (patch)
tree7f948f020ee5bf06821c3a0a50b162e234ecb217 /sci-libs/nipype
parentsci-libs/nipype: version bump (diff)
downloadsci-81bed4e668e2ee6425cc555524189ceb2198a04f.tar.gz
sci-81bed4e668e2ee6425cc555524189ceb2198a04f.tar.bz2
sci-81bed4e668e2ee6425cc555524189ceb2198a04f.zip
sci-libs/nipype: version bump
Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'sci-libs/nipype')
-rw-r--r--sci-libs/nipype/Manifest1
-rw-r--r--sci-libs/nipype/nipype-1.1.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-libs/nipype/Manifest b/sci-libs/nipype/Manifest
index dbc13a1ef..1af7ffa2a 100644
--- a/sci-libs/nipype/Manifest
+++ b/sci-libs/nipype/Manifest
@@ -3,3 +3,4 @@ DIST nipype-0.12.0.tar.gz 3088339 BLAKE2B 640ef5192c5502aa0eb12354547ac701de150f
DIST nipype-0.12.1.tar.gz 3092631 BLAKE2B 2081274ba8e5aaa993f29ffc46421e0910759861513f5445a3960298446e7f69d3d482fe5c4569dd2313a0c933b80ff2f66e2b2121325389fa13f3942bc96df0 SHA512 feab0f71c1274a19f6861d73e7c94cd2d35858404c8ef1bf62a35da030ad5fc96ad86370043f018e919c90574b70d56051c3894709c139cecae5117cb2681527
DIST nipype-0.14.0_pre20170830.tar.gz 3290267 BLAKE2B ef5ca5000e4d0d6d0079dd39e9f798aae5bff9de4ac58c8418bd46e2425ac3ec0d8cc9038a6cff9987b9b7c3e702f29c16d00e4896c2218afac03376fa0978a5 SHA512 0280312e6c80b10ee5463991baeff12cef5ff46c05ea294cdb889594b74cf92bdd5d5d93a9c8facbf888d11d60cdd549df82f262356ae1c59b6eb1bfff813b5e
DIST nipype-1.1.0.tar.gz 3352721 BLAKE2B a30b8100b79bc16d9113a8ff48812e8a2a0081790400a2d1491ac528afe4aabef9d5d923ecaf1d93a827c0b3c186635095dbc836b6cfb4a8ec5283d32cb1596b SHA512 24066c7f3cf1c6dee366790800545eb1e7975c22986c819926c3b5e18bf0c4b97aab6f58bdbbba66f71495ba43677d8e59d6c02ec200cc609674b8945b2c65e1
+DIST nipype-1.1.1.tar.gz 3353518 BLAKE2B 509b6c2b18aab8c8ddfad3ca4ac87401caf0608ee566edecaa20a4329a3bfd9d67dae730ac45342600b4026b66c5043d753d09e5230269d3fc4b946d049ad11e SHA512 dba749ff3b53dfe19992a27f9ad9aedcd360b51b3bf7233bf4b83387ae7181425b27ef43d23747553e9f8eb368b6769d6bec62650e1303ec353dde4de84f1769
diff --git a/sci-libs/nipype/nipype-1.1.1.ebuild b/sci-libs/nipype/nipype-1.1.1.ebuild
new file mode 100644
index 000000000..8c2713712
--- /dev/null
+++ b/sci-libs/nipype/nipype-1.1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Neuroimaging in Python: Pipelines and Interfaces"
+HOMEPAGE="http://nipy.sourceforge.net/nipype/"
+SRC_URI="https://github.com/nipy/nipype/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ~dev-python/prov-1.5.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+ $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' python2_7)
+ "
+RDEPEND="
+ >=dev-python/click-6.6[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pydotplus[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]
+ "
+
+python_test() {
+ py.test -v --cov nipype\
+ --cov-config .coveragerc\
+ --cov-report xml:cov.xml\
+ -c nipype/pytest.ini\
+ --doctest-modules nipype\
+ || die
+}