aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-07-11 09:14:32 -0400
committerHorea Christian <chr@chymera.eu>2022-07-11 09:14:32 -0400
commit40be0afedeb9322b8a7cef8c93315efbab71f334 (patch)
treee3d0d72f79202a39082284c7ee73d1eafe1d0fa1 /sci-libs/pybids
parentdev-python/pynrrd: version bump (diff)
downloadsci-40be0afedeb9322b8a7cef8c93315efbab71f334.tar.gz
sci-40be0afedeb9322b8a7cef8c93315efbab71f334.tar.bz2
sci-40be0afedeb9322b8a7cef8c93315efbab71f334.zip
sci-libs/pybids: EAPI and PYTHON_COMPAT bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-libs/pybids')
-rw-r--r--sci-libs/pybids/pybids-0.10.2.ebuild16
-rw-r--r--sci-libs/pybids/pybids-0.11.1.ebuild10
-rw-r--r--sci-libs/pybids/pybids-0.12.4.ebuild12
-rw-r--r--sci-libs/pybids/pybids-0.6.5.ebuild6
4 files changed, 15 insertions, 29 deletions
diff --git a/sci-libs/pybids/pybids-0.10.2.ebuild b/sci-libs/pybids/pybids-0.10.2.ebuild
index 062cad939..1143655d7 100644
--- a/sci-libs/pybids/pybids-0.10.2.ebuild
+++ b/sci-libs/pybids/pybids-0.10.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -29,12 +29,4 @@ RDEPEND="
dev-python/scipy[${PYTHON_USEDEP}]
"
-#RESTRICT="test"
-# Fails because fixtures are called directly
-# https://github.com/bids-standard/pybids/issues/289#issuecomment-476853673
-
-python_test() {
- #rm bids/tests/test_config.py || die
- distutils_install_for_testing
- pytest -vv || die
-}
+distutils_enable_tests pytest
diff --git a/sci-libs/pybids/pybids-0.11.1.ebuild b/sci-libs/pybids/pybids-0.11.1.ebuild
index 062cad939..ef3534954 100644
--- a/sci-libs/pybids/pybids-0.11.1.ebuild
+++ b/sci-libs/pybids/pybids-0.11.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -29,10 +29,6 @@ RDEPEND="
dev-python/scipy[${PYTHON_USEDEP}]
"
-#RESTRICT="test"
-# Fails because fixtures are called directly
-# https://github.com/bids-standard/pybids/issues/289#issuecomment-476853673
-
python_test() {
#rm bids/tests/test_config.py || die
distutils_install_for_testing
diff --git a/sci-libs/pybids/pybids-0.12.4.ebuild b/sci-libs/pybids/pybids-0.12.4.ebuild
index 40a8adc17..ace1712ce 100644
--- a/sci-libs/pybids/pybids-0.12.4.ebuild
+++ b/sci-libs/pybids/pybids-0.12.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -16,9 +16,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-BDEPEND="dev-python/versioneer[${PYTHON_USEDEP}]
- test? ( dev-python/mock[${PYTHON_USEDEP}] )
-"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
RDEPEND="
dev-python/click[${PYTHON_USEDEP}]
@@ -32,4 +30,4 @@ RDEPEND="
dev-python/scipy[${PYTHON_USEDEP}]
"
-distutils_enable_tests --install pytest
+distutils_enable_tests pytest
diff --git a/sci-libs/pybids/pybids-0.6.5.ebuild b/sci-libs/pybids/pybids-0.6.5.ebuild
index 521ef9947..ceb6784d1 100644
--- a/sci-libs/pybids/pybids-0.6.5.ebuild
+++ b/sci-libs/pybids/pybids-0.6.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1