aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-09-19 20:42:17 -0400
committerHorea Christian <chr@chymera.eu>2020-09-19 20:42:17 -0400
commit9495e0d02bb06635fdff3fdc4aa92cd2bbca77ba (patch)
tree6e2cb8c3145e6e89e9a5220b2d64eba8c5fe04ae /sci-libs/pybids
parentChanges for fsl CUDA support (diff)
downloadsci-9495e0d02bb06635fdff3fdc4aa92cd2bbca77ba.tar.gz
sci-9495e0d02bb06635fdff3fdc4aa92cd2bbca77ba.tar.bz2
sci-9495e0d02bb06635fdff3fdc4aa92cd2bbca77ba.zip
sci-libs/pybids: version bump 0.11.1
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-libs/pybids')
-rw-r--r--sci-libs/pybids/Manifest1
-rw-r--r--sci-libs/pybids/pybids-0.11.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/pybids/Manifest b/sci-libs/pybids/Manifest
index 3492b17aa..8b448dc52 100644
--- a/sci-libs/pybids/Manifest
+++ b/sci-libs/pybids/Manifest
@@ -1,3 +1,4 @@
DIST pybids-0.10.2.tar.gz 3013772 BLAKE2B 70255fbca7a7d5a51efa454ee20d30a9527703d6028a965b51da883aa10f8b63d180f72fd127e12b27249c3f388825a9bb2ba4604680c57f3a512ec7093c01c4 SHA512 c90b7e471d73b070e86452ca5d03639d0263e74c3c79386b52ed2c5fc49576f985bc923f2327882ee56bc4691631105c831ebe40f78aade5b9943be83909ba16
+DIST pybids-0.11.1.tar.gz 3026079 BLAKE2B 9ca7d1299a074f4b7ae51e7d6ff29a55664b6c32c85511913fb69459bd66a0c09b63dddfef2c433c5cccf47c4e358720cbd101f85e7794e22a9935bd6a36ac65 SHA512 bcc1cc3a06b6921e8336990e83e820439c217cfdce6aee3b4b93f2c1ee04acf0bf9009fa2fc80fd50cd59bd9b1a2a3ceb934589b5fd590612de386e91e4f7340
DIST pybids-0.5.0.tar.gz 2814050 BLAKE2B b4bd548989d09e6f49d94c9262fb225a25a37bd5797fe33d2296943808a8dbebeaf17b81e4ea0513c620bcf4c4b4cbae394123fabe7244363205c73328f00e8b SHA512 7d39198fa321535a2f1761348069c18e7ba113174b8d034dd20e5ea3ac11013840da89b5b7bbe6d9b0458c46a5bc07200a97c5efa1a6ff716c524390bd0a3a65
DIST pybids-0.6.5.tar.gz 2915557 BLAKE2B d7765b872917bbffcd2706488d7c789976be5bbb1eb5d112cb0b7bcedb483236643f8bf7c177f4a64a44a4d50787a4df1d39fbec8e826bfffd2e2e6f891b3ef3 SHA512 9eef42f00440dddf0147d91f90e07db81f9f95a650f0e47c04304771173ca8691cdb366bd0df1d752c0444f102a4aa010c2343ba75df96528cceb9a98f9d8a0e
diff --git a/sci-libs/pybids/pybids-0.11.1.ebuild b/sci-libs/pybids/pybids-0.11.1.ebuild
new file mode 100644
index 000000000..8b30eeb0d
--- /dev/null
+++ b/sci-libs/pybids/pybids-0.11.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to access BIDS datasets"
+HOMEPAGE="https://github.com/INCF/pybids"
+SRC_URI="https://github.com/INCF/pybids/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="
+ dev-python/num2words[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ sci-libs/bids-validator[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ "
+
+#RESTRICT="test"
+# Fails because fixtures are called directly
+# https://github.com/bids-standard/pybids/issues/289#issuecomment-476853673
+
+python_test() {
+ #rm bids/tests/test_config.py || die
+ distutils_install_for_testing
+ pytest -vv || die
+}