aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-01-10 14:29:06 +0100
committerHorea Christian <chr@chymera.eu>2020-01-10 14:29:06 +0100
commitc939a6bdec9371a7e75811188895ea2ed70a4d54 (patch)
tree02dcc7ccb606794e58176281a13b5b4969683619 /sci-libs/pybids
parentsci-libs/pybids: deprecated PYTHON_COMPAT (diff)
downloadsci-c939a6bdec9371a7e75811188895ea2ed70a4d54.tar.gz
sci-c939a6bdec9371a7e75811188895ea2ed70a4d54.tar.bz2
sci-c939a6bdec9371a7e75811188895ea2ed70a4d54.zip
sci-libs/pybids: version bump 0.6.5
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-libs/pybids')
-rw-r--r--sci-libs/pybids/Manifest1
-rw-r--r--sci-libs/pybids/pybids-0.6.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/pybids/Manifest b/sci-libs/pybids/Manifest
index e3e63b7cf..def9e08d0 100644
--- a/sci-libs/pybids/Manifest
+++ b/sci-libs/pybids/Manifest
@@ -1 +1,2 @@
DIST pybids-0.5.0.tar.gz 2814050 BLAKE2B b4bd548989d09e6f49d94c9262fb225a25a37bd5797fe33d2296943808a8dbebeaf17b81e4ea0513c620bcf4c4b4cbae394123fabe7244363205c73328f00e8b SHA512 7d39198fa321535a2f1761348069c18e7ba113174b8d034dd20e5ea3ac11013840da89b5b7bbe6d9b0458c46a5bc07200a97c5efa1a6ff716c524390bd0a3a65
+DIST pybids-0.6.5.tar.gz 2915557 BLAKE2B d7765b872917bbffcd2706488d7c789976be5bbb1eb5d112cb0b7bcedb483236643f8bf7c177f4a64a44a4d50787a4df1d39fbec8e826bfffd2e2e6f891b3ef3 SHA512 9eef42f00440dddf0147d91f90e07db81f9f95a650f0e47c04304771173ca8691cdb366bd0df1d752c0444f102a4aa010c2343ba75df96528cceb9a98f9d8a0e
diff --git a/sci-libs/pybids/pybids-0.6.5.ebuild b/sci-libs/pybids/pybids-0.6.5.ebuild
new file mode 100644
index 000000000..1a3e5aa5f
--- /dev/null
+++ b/sci-libs/pybids/pybids-0.6.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to access BIDS datasets"
+HOMEPAGE="https://github.com/INCF/pybids"
+SRC_URI="https://github.com/INCF/pybids/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/grabbit[${PYTHON_USEDEP}]
+ dev-python/num2words[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ "
+
+RESTRICT="test"
+# Fails because fixtures are called directly
+# https://github.com/bids-standard/pybids/issues/289#issuecomment-476853673
+
+python_test() {
+ rm bids/tests/test_config.py || die
+ distutils_install_for_testing
+ pytest -vv || die
+ die
+}