aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-07-31 21:12:04 +0200
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-07-31 21:12:04 +0200
commit8bd00fc9dbf0fbcfedfacb7edb1e23c4c23f7a06 (patch)
treeac6c11cd15fbda1d139053867d90881577adebd1 /sci-libs/starparse/starparse-9999.ebuild
parentnetcdf removed and bug 279817 filed (diff)
downloadsci-8bd00fc9dbf0fbcfedfacb7edb1e23c4c23f7a06.tar.gz
sci-8bd00fc9dbf0fbcfedfacb7edb1e23c4c23f7a06.tar.bz2
sci-8bd00fc9dbf0fbcfedfacb7edb1e23c4c23f7a06.zip
starparse Manifest fix and tree version removed
Diffstat (limited to 'sci-libs/starparse/starparse-9999.ebuild')
-rw-r--r--sci-libs/starparse/starparse-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/starparse/starparse-9999.ebuild b/sci-libs/starparse/starparse-9999.ebuild
new file mode 100644
index 000000000..4b754097e
--- /dev/null
+++ b/sci-libs/starparse/starparse-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EBZR_REPO_URI="http://oregonstate.edu/~benisong/software/projects/starparse/head"
+EBZR_BOOTSTRAP="eautoreconf"
+
+inherit autotools bzr
+
+DESCRIPTION="Library for parsing NMR star files (peak-list format) and CIF files"
+HOMEPAGE="http://burrow-owl.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="guile"
+RDEPEND="guile? ( dev-scheme/guile )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf $(use_enable guile) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}