aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <kleiner_otti@gmx.de>2010-12-04 14:15:47 +0100
committerChristoph Junghans <kleiner_otti@gmx.de>2010-12-04 14:15:47 +0100
commitefebf6768ac3e78bc8b66fb8631a1a9042521464 (patch)
treeb8270d267622305cc7a8ef680f5077219e7be1be /sci-libs/votca-tools
parent[sci-chemistry/gabedit] fix Manifest wrt bug 347697 (diff)
downloadsci-efebf6768ac3e78bc8b66fb8631a1a9042521464.tar.gz
sci-efebf6768ac3e78bc8b66fb8631a1a9042521464.tar.bz2
sci-efebf6768ac3e78bc8b66fb8631a1a9042521464.zip
[sci-libs/votca-tools] version bump
(Portage version: 2.1.9.24/git/Linux i686, signed Manifest commit with key A9ECD7F9)
Diffstat (limited to 'sci-libs/votca-tools')
-rw-r--r--sci-libs/votca-tools/Manifest10
-rw-r--r--sci-libs/votca-tools/votca-tools-1.0.1.ebuild73
l---------sci-libs/votca-tools/votca-tools-9999.ebuild2
3 files changed, 80 insertions, 5 deletions
diff --git a/sci-libs/votca-tools/Manifest b/sci-libs/votca-tools/Manifest
index 0dcb54503..98015e295 100644
--- a/sci-libs/votca-tools/Manifest
+++ b/sci-libs/votca-tools/Manifest
@@ -1,15 +1,17 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
+DIST votca-tools-1.0.1.tar.gz 1614718 RMD160 36ef42dd8893e322359de350d63cda881c11aceb SHA1 b3230914df2f09220d327fcbe25ed2c1a75f4add SHA256 edac008ea67b2cb777f4249a2792ea0135f191b853d9f5b65e4bca9836cc4ec3
DIST votca-tools-1.0.tar.gz 1909096 RMD160 4699a00da4f56934cc0d4d4667a12585f6072481 SHA1 e684965b3c811cc576eb66b791659285d46381a4 SHA256 aeb5c2c7ec8e7a93a558f7b2e42c4c9489bd6c8ffe0536d629499839bda899af
+EBUILD votca-tools-1.0.1.ebuild 1588 RMD160 06beed51379cb4179aa4eb7d4544b9714e7c6a29 SHA1 77019b8e9f10dd67e62fb0e27697ed1417a81a4b SHA256 29738d82a638327e78b98713ce40bb19422c9da739328aba7a53b8f7d93c1e9b
EBUILD votca-tools-1.0.ebuild 1683 RMD160 17d4b1287fc3ff03518288042743747e06052ff0 SHA1 bbf6043e0b47d3c2e4f7e47bd423698a492cd629 SHA256 a87b5243c74a0c39513130cc0b5ef3dba85986d7fd6d4a81f5527e2cb762b175
-EBUILD votca-tools-9999.ebuild 1683 RMD160 17d4b1287fc3ff03518288042743747e06052ff0 SHA1 bbf6043e0b47d3c2e4f7e47bd423698a492cd629 SHA256 a87b5243c74a0c39513130cc0b5ef3dba85986d7fd6d4a81f5527e2cb762b175
+EBUILD votca-tools-9999.ebuild 1588 RMD160 06beed51379cb4179aa4eb7d4544b9714e7c6a29 SHA1 77019b8e9f10dd67e62fb0e27697ed1417a81a4b SHA256 29738d82a638327e78b98713ce40bb19422c9da739328aba7a53b8f7d93c1e9b
MISC ChangeLog 1928 RMD160 7dc7fc5ad5067891a6859a0dd1c1a80f16711f23 SHA1 ef9a735d94bed09d93c83fec1e03bff70d3b97f1 SHA256 76e73b198b7b8f54dbd0d7a992b20ae065edc30e7e2c153eaf04fc732e96ffab
MISC metadata.xml 352 RMD160 f95fd724d61428eea0ad2cec5decb740bd73a6c3 SHA1 f600bc60b3fe946b41ed0a4a8699be09e5a15767 SHA256 4871253ab15b7491693777704d946e7c8c7ef378bdabf8e88e0ac903956c96ed
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.16 (GNU/Linux)
-iEYEARECAAYFAkynNtQACgkQy0OE/ans1/mLOQCgg9W1Us65ExIM1GpQfyxLvVcT
-VgQAn1eYxkXiP1WHoNLSUJ9govrEPvq+
-=5jrE
+iEYEARECAAYFAkz6PwMACgkQy0OE/ans1/k+xwCeLhk0LCSkyXw1rj0lSUpw1NEr
+QLAAniRC8qVIvj+v/CQYt5WM7+sMemQ0
+=BM+t
-----END PGP SIGNATURE-----
diff --git a/sci-libs/votca-tools/votca-tools-1.0.1.ebuild b/sci-libs/votca-tools/votca-tools-1.0.1.ebuild
new file mode 100644
index 000000000..35926c726
--- /dev/null
+++ b/sci-libs/votca-tools/votca-tools-1.0.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit eutils autotools
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="http://votca.googlecode.com/files/${PF}.tar.gz"
+else
+ SRC_URI=""
+ inherit mercurial
+ EHG_REPO_URI="https://tools.votca.googlecode.com/hg"
+ S="${WORKDIR}/${EHG_REPO_URI##*/}"
+fi
+
+DESCRIPTION="Votca tools library"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="-boost doc +fftw +gsl static-libs"
+
+RDEPEND="fftw? ( sci-libs/fftw:3.0 )
+ dev-libs/expat
+ gsl? ( sci-libs/gsl )
+ boost? ( dev-libs/boost )
+ doc? ( >=app-text/txt2tags-2.5 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ use gsl || ewarn "Disabling gsl will lead to reduced functionality"
+ use fftw || ewarn "Disabling fftw will lead to reduced functionality"
+
+ #remove bundled libs
+ rm -rf src/libexpat
+ use boost && rm -rf src/libboost
+
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_configure() {
+ local myconf="--disable-la-files --disable-rc-files"
+
+ use boost \
+ && myconf="${myconf} $(use_with boost) --disable-votca-boost" \
+ || myconf="${myconf} $(use_with boost) --enable-votca-boost"
+
+ myconf="${myconf} $(use_with gsl) $(use_with fftw) $(use_enable static-libs static)"
+
+ econf ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc NOTICE
+ if use doc; then
+ emake CHANGELOG || die "emake CHANGELOG failed"
+ dodoc CHANGELOG
+ fi
+}
+
+pkg_postinst() {
+ env-update
+}
+
+pkg_postrm() {
+ env-update
+}
diff --git a/sci-libs/votca-tools/votca-tools-9999.ebuild b/sci-libs/votca-tools/votca-tools-9999.ebuild
index 27729ec5a..624fc868d 120000
--- a/sci-libs/votca-tools/votca-tools-9999.ebuild
+++ b/sci-libs/votca-tools/votca-tools-9999.ebuild
@@ -1 +1 @@
-votca-tools-1.0.ebuild \ No newline at end of file
+votca-tools-1.0.1.ebuild \ No newline at end of file