aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGert Wollny <gw.fossdev@gmail.com>2013-06-15 01:45:29 +0200
committerGert Wollny <gw.fossdev@gmail.com>2013-06-15 01:45:29 +0200
commite97c7b867b58ab2e683b80b21c664182cece2e96 (patch)
tree5ad8a395a4352d469919b62492e832698d21df39 /sci-libs
parentchange digests (diff)
downloadsci-e97c7b867b58ab2e683b80b21c664182cece2e96.tar.gz
sci-e97c7b867b58ab2e683b80b21c664182cece2e96.tar.bz2
sci-e97c7b867b58ab2e683b80b21c664182cece2e96.zip
update the dependencies and handling of missing varibles
After some more inspection of the build system it turns out that now hdf5 is always required, so I removed the useflag and made the dependency obligarory. In addition, I changed the handling when the environment variables are not set i.e. only if python bindings are requested and only for the *DIMS variable the ebuold will bail out, for the memory size the default fallback "1" will be used if it is not set. I also added the sse2 use flag since VNL can profit from it.
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/itk/Manifest3
-rw-r--r--sci-libs/itk/itk-4.4.0.ebuild58
2 files changed, 37 insertions, 24 deletions
diff --git a/sci-libs/itk/Manifest b/sci-libs/itk/Manifest
index 59db0b065..59c9ce913 100644
--- a/sci-libs/itk/Manifest
+++ b/sci-libs/itk/Manifest
@@ -1 +1,4 @@
+AUX itk-4.4-v3compat_I2VI_const-fix.patch 788 SHA256 c2473ea2576dba5ccbdb784f638c94d4c4120f16ed69b51a5ce97a9807114dfc SHA512 e7c7cdd5dd2ff8e74065f9013ed90c2e7c83d24f510633598d2067964561ed45306ed103d91e16dba635b38f17685d70ffcdc92f53e7c82eea8832271daf0c2b WHIRLPOOL ae5604b4d3827bb7d795ca678e5c3126a0b424af7e856b671a87fe9a2ed355c7944dbc2654b5a77303fe5a9b3ef92605548602df60b7b79062467bfd5d98ee04
DIST InsightToolkit-4.4.0.tar.gz 206144269 SHA256 b489f3e3337f8d2831442ddf541f5c352328c080f2871154543ed37642672f23 SHA512 a1515f396d03a1ae3708b816cd522a1be324b74520550b1d676c22a7054db38217ed3555bf5b5ea84c27a22a57a7db843645d96fc3f49ee47b159d935ee26bb2 WHIRLPOOL ccee2d9953780188b3be06f9658ddff1ad97e83f2f399ed64db5cf169348a8f3711f71ab317e4e87795b0424d05849c8fcff0b0330863af81a974aa07fb596a1
+EBUILD itk-4.4.0.ebuild 4447 SHA256 2cabbc84dac41fd6fc916b414f1cf51d22a524edab9f198dab7dffd2c7ea5da5 SHA512 842ea59ed987e12e7f373d8bc42438bfe6f60d0aa775d346cd002398cd85ead40bec88d357377aad542c5741781532a2580e5b6249b6d01e279da64fdc186a64 WHIRLPOOL b6cec4bf500a4cc7e6f040080d9fa61dc8ad3d94e23aff501062b622fbe95dcf79cb6d2e9fa154a8187a47313eb6a318e8a9503f98f0c742d8bc8ce3f7567422
+MISC metadata.xml 534 SHA256 4110fe80d3b4318d2cb996086da03175d107ce0fd3a9495d2642157e54817454 SHA512 cd8d56df8a2a77c9d67b699ddc64ce4076485d4df692c14729ee1c703642aa36b1f405b58658ada7c9b7f0f1411ad094cb1641e5dfbcc6ed3487c2fde2bfc782 WHIRLPOOL 1c66d5edb94c03ad6f9f0c7665cd8988f5120ecc8e952db3a574542394393576bdae8a49e663125fb2200698f0d382fc11ee435999bd851713deec541bb49e19
diff --git a/sci-libs/itk/itk-4.4.0.ebuild b/sci-libs/itk/itk-4.4.0.ebuild
index e0e87e2d9..3544e4e41 100644
--- a/sci-libs/itk/itk-4.4.0.ebuild
+++ b/sci-libs/itk/itk-4.4.0.ebuild
@@ -16,15 +16,15 @@ RESTRICT="primaryuri"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE="debug examples fftw hdf5 itkv3compat python review test"
+IUSE="debug examples fftw itkv3compat python review sse2 test"
RDEPEND="fftw? ( sci-libs/fftw:3.0 )
- hdf5? ( sci-libs/hdf5[cxx] )
- virtual/jpeg
- media-libs/libpng
- media-libs/tiff:0
- sys-libs/zlib
- "
+ sci-libs/hdf5[cxx]
+ virtual/jpeg
+ media-libs/libpng
+ media-libs/tiff:0
+ sys-libs/zlib
+ "
DEPEND="${RDEPEND}
>=dev-util/cmake-2.8
python? ( ${PYTHON_DEPS} >=dev-lang/swig-2.0 >=dev-cpp/gccxml-0.9.0_pre20120309 )
@@ -38,32 +38,34 @@ PATCHES=(
)
pkg_pretend() {
- bailout=no
+ missing_memsize="no"
if [ "x$ITK_COMPUTER_MEMORY_SIZE" = "x" ]; then
- elog "To tune ITK to make the best use ouf working memory you must set"
+ elog "To tune ITK to make the best use ouf working memory you should set"
elog "ITK_COMPUTER_MEMORY_SIZE in /etc/make.conf to the size of the "
elog "memory installed in your machine. For example for 4GB you do:"
elog ""
elog " echo 'ITK_COMPUTER_MEMORY_SIZE=4' >> /etc/make.conf"
- elog ""
- bailout=yes
+ elog "---"
+ missing_memsize="ITK_COMPUTER_MEMORY_SIZE and"
fi
if use python ; then
+
if [ "x$ITK_WRAP_DIMS" = "x" ]; then
- elog "For Python language bindings it is necessary to "
- elog "define the dimensions you want to create bindings for"
- elog "by setting in ITK_WRAP_DIMS in /etc/make.conf."
- elog "For example, to provide bindings for 2D and 3D data do:"
- elog ""
- elog " echo 'ITK_WRAP_DIMS=2;3' >> /etc/make.conf"
- elog ""
- bailout=yes
+ eerror "For Python language bindings it is necessary to "
+ eerror "define the dimensions you want to create bindings for"
+ eerror "by setting in ITK_WRAP_DIMS in /etc/make.conf."
+ eerror "For example, to provide bindings for 2D and 3D data do:"
+ eerror ""
+ eerror " echo 'ITK_WRAP_DIMS=2;3' >> /etc/make.conf"
+ eerror ""
+ # Compiling with python support takes very long, therefore it is better
+ # to bailout here if one or both of above variables are not set, and ask
+ # the user to provide the values.
+ die "Missing value for ITK_WRAP_DIMS"
+
fi
fi
- if [ "x$bailout" = "xyes" ]; then
- die "Please add the missing variables to /etc/make.conf and then restart emerge"
- fi
}
src_configure() {
@@ -80,14 +82,22 @@ src_configure() {
-DITK_USE_SYSTEM_GCCXML=ON
-DITK_USE_SYSTEM_SWIG=ON
-DBUILD_SHARED_LIBS=ON
- -DITK_COMPUTER_MEMORY_SIZE="$ITK_COMPUTER_MEMORY_SIZE"
+ -DITK_USE_SYSTEM_HDF5=ON
$(cmake-utils_use_build examples)
$(cmake-utils_use_build test TESTING)
- $(cmake-utils_use hdf5 ITK_USE_SYSTEM_HDF5)
$(cmake-utils_use review ITK_USE_REVIEW)
$(cmake-utils_use itkv3compat ITKV3_COMPATIBILITY)
+ $(cmake-utils_use sse2 VNL_CONFIG_ENABLE_SSE2)
)
+ # if this is not set, it defaults to 1GB, should be okay for most people.
+ #
+ if [ "x$ITK_COMPUTER_MEMORY_SIZE" != "x" ]; then
+ mycmakeargs+=(
+ -DITK_COMPUTER_MEMORY_SIZE="$ITK_COMPUTER_MEMORY_SIZE"
+ )
+ fi
+
if use fftw; then
mycmakeargs+=(
-DUSE_FFTWD=ON