aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordjay <djay@32389bae-6d03-0410-99cf-db05cde120eb>2007-01-06 17:39:49 +0000
committerdjay <djay@32389bae-6d03-0410-99cf-db05cde120eb>2007-01-06 17:39:49 +0000
commit0556db59896f30062ac5f96afed8d64ec659e127 (patch)
tree1d81c9035f356ee666b3621d75fcf285daaaf9fc /sci-libs
parentinitial import of the CGAL library (diff)
downloadsci-0556db59896f30062ac5f96afed8d64ec659e127.tar.gz
sci-0556db59896f30062ac5f96afed8d64ec659e127.tar.bz2
sci-0556db59896f30062ac5f96afed8d64ec659e127.zip
Initial cgal-python import
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@456 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cgal-python/Manifest12
-rw-r--r--sci-libs/cgal-python/cgal-python-0.9.1.ebuild43
-rw-r--r--sci-libs/cgal-python/files/digest-cgal-python-0.9.13
3 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/cgal-python/Manifest b/sci-libs/cgal-python/Manifest
new file mode 100644
index 000000000..cfd11e660
--- /dev/null
+++ b/sci-libs/cgal-python/Manifest
@@ -0,0 +1,12 @@
+DIST cgal-python-0.9.1.tar.gz 146703 RMD160 e52f352b359678132db3019ed2d5edec57dd93a3 SHA1 38d08c28ac31eb2f84289a7e2487c49b2575b11f SHA256 507608cf34e6bdee77fdc0aaa753a2d882a8e1f36fb2531bc52a44774bc902e1
+EBUILD cgal-python-0.9.1.ebuild 1080 RMD160 a0dfa065763db29d7508bda7621848a1cb3ceb29 SHA1 ec850fa97e548bc5db0e5e3048e9a0589c225059 SHA256 778c898371455fbd0ee477c001b17bb2396a74d6e5fd43415496751b3c1c7350
+MD5 5cee72a5d4c33fe0a185f2f9849c02ef cgal-python-0.9.1.ebuild 1080
+RMD160 a0dfa065763db29d7508bda7621848a1cb3ceb29 cgal-python-0.9.1.ebuild 1080
+SHA256 778c898371455fbd0ee477c001b17bb2396a74d6e5fd43415496751b3c1c7350 cgal-python-0.9.1.ebuild 1080
+MISC .cgal-python-0.9.1.ebuild.swp 12288 RMD160 9010df930e18274eba4486521fb669c6cc544d64 SHA1 0e6c91b571a94d12e942ed6b5704cdfd0d4290ad SHA256 9ae82bb03db561877cdc0621a56d76417827a91f1fc913be8d04bb7a58c3856d
+MD5 1c80623c18e0be1a0fc9d2a67c729b00 .cgal-python-0.9.1.ebuild.swp 12288
+RMD160 9010df930e18274eba4486521fb669c6cc544d64 .cgal-python-0.9.1.ebuild.swp 12288
+SHA256 9ae82bb03db561877cdc0621a56d76417827a91f1fc913be8d04bb7a58c3856d .cgal-python-0.9.1.ebuild.swp 12288
+MD5 892875192ee722b10dbd56dc7b402378 files/digest-cgal-python-0.9.1 253
+RMD160 f7bd3ed27dbc7bbe7721ff811e0085aa381e7765 files/digest-cgal-python-0.9.1 253
+SHA256 c6b74b654cb72e5f6d0b08bd03627006cb63a503418e2de8862e5d9a9d1bdd2d files/digest-cgal-python-0.9.1 253
diff --git a/sci-libs/cgal-python/cgal-python-0.9.1.ebuild b/sci-libs/cgal-python/cgal-python-0.9.1.ebuild
new file mode 100644
index 000000000..64ee76434
--- /dev/null
+++ b/sci-libs/cgal-python/cgal-python-0.9.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit python toolchain-funcs
+
+DESCRIPTION="Provide Python bindings for the CGAL library"
+HOMEPAGE="http://cgal-python.gforge.inria.fr/"
+SRC_URI="http://gforge.inria.fr/frs/download.php/945/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="examples"
+
+DEPEND="sci-libs/cgal"
+RDEPEND="sci-libs/cgal"
+
+src_unpack(){
+ python_version
+ unpack "${A}"
+ cd "${S}"
+ # include python header needed by boost
+ for i in $(find ./bindings/ -name Makefile); do
+ sed "s:-I../..:-I/usr/include/python${PYVER} -I../..:g" -i $i
+ sed "s:@g++:$(tc-getCXX) -fno-strict-aliasing:g" -i $i
+ done
+}
+
+src_compile(){
+ CGAL_MAKEFILE=/usr/share/CGAL/makefile emake
+}
+
+src_install(){
+ CGAL_MAKEFILE=/usr/share/CGAL/makefile emake package
+ pylibdir="$(${python} -c 'from distutils.sysconfig import get_python_lib;print get_python_lib()')"
+ dodir "${pylibdir}"
+ cp -r cgal_package/CGAL "${D}/${pylibdir}"
+ if use example; then
+ dodir /usr/share/doc/${P}
+ cp -r ./test "${D}/usr/share/doc/${P}"
+ fi
+}
diff --git a/sci-libs/cgal-python/files/digest-cgal-python-0.9.1 b/sci-libs/cgal-python/files/digest-cgal-python-0.9.1
new file mode 100644
index 000000000..ae4b3e943
--- /dev/null
+++ b/sci-libs/cgal-python/files/digest-cgal-python-0.9.1
@@ -0,0 +1,3 @@
+MD5 333243df2f1c7f90cf9d8122a9f56c1a cgal-python-0.9.1.tar.gz 146703
+RMD160 e52f352b359678132db3019ed2d5edec57dd93a3 cgal-python-0.9.1.tar.gz 146703
+SHA256 507608cf34e6bdee77fdc0aaa753a2d882a8e1f36fb2531bc52a44774bc902e1 cgal-python-0.9.1.tar.gz 146703