aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-12-14 12:40:50 +0100
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-12-14 12:40:50 +0100
commit4fdad4d5229ce714a6a2c7e91338be89c14e7fc4 (patch)
tree0e43d4cf4526e07d319586808d2fa2f356807b4f /sci-libs
parentsci-biology/zmap: add einfo mentioning seqtools package (diff)
downloadsci-4fdad4d5229ce714a6a2c7e91338be89c14e7fc4.tar.gz
sci-4fdad4d5229ce714a6a2c7e91338be89c14e7fc4.tar.bz2
sci-4fdad4d5229ce714a6a2c7e91338be89c14e7fc4.zip
sci-libs/libmaus2: bring in a release, add more LICENSEs
The list of licenses is still incomplete and somebody more comfortable with interpretation of them inside *.asm and other files needs to poke over this before unmasking. See AUTHORS file for their listing. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libmaus2/Manifest1
-rw-r--r--sci-libs/libmaus2/libmaus2-2.0.499.ebuild42
-rw-r--r--sci-libs/libmaus2/libmaus2-9999.ebuild6
3 files changed, 46 insertions, 3 deletions
diff --git a/sci-libs/libmaus2/Manifest b/sci-libs/libmaus2/Manifest
new file mode 100644
index 000000000..51c8ba1af
--- /dev/null
+++ b/sci-libs/libmaus2/Manifest
@@ -0,0 +1 @@
+DIST 2.0.499-release-20180606122508.tar.gz 3610083 BLAKE2B 6495ba6eff89331544bb8999728cca0d86eba6dc0b9cf65aad298b0153f3d7d9c521b8eee6351972f10db0ae1de5ec554d4c149f57b9e3c31a376297d2fb0594 SHA512 b8ce37f0d2dc74bca2ee175c533338d86a60cff26219c9f7f050448fc544980e7ed4b7cefa17fb67fb0f42c8b11cae8d832f37bb2afa23379a7ce2e229d4f990
diff --git a/sci-libs/libmaus2/libmaus2-2.0.499.ebuild b/sci-libs/libmaus2/libmaus2-2.0.499.ebuild
new file mode 100644
index 000000000..cebe44161
--- /dev/null
+++ b/sci-libs/libmaus2/libmaus2-2.0.499.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library for biobambam2"
+HOMEPAGE="https://github.com/gt1/libmaus"
+SRC_URI="https://github.com/gt1/libmaus2/archive/2.0.499-release-20180606122508.tar.gz"
+
+LICENSE="BSD-2 GPL-2 GPL-3 MIT ZLIB" # BUG: incomplete list of licenses, see AUTHORS
+SLOT="0"
+KEYWORDS=""
+IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2"
+
+DEPEND="
+ !sci-libs/libmaus
+ sci-libs/io_lib
+ app-arch/snappy
+ sci-biology/seqan
+ sci-libs/fftw
+ sci-libs/hdf5
+ net-libs/gnutls
+ dev-libs/nettle"
+# --with-daligner
+# --with-irods
+S="${WORKDIR}"/libmaus2-2.0.499-release-20180606122508
+
+src_configure(){
+ local CONFIG_OPTS
+ use cpu_flags_x86_ssse3 && CONFIG_OPTS+=( --enable-ssse3 )
+ ( use cpu_flags_x86_sse4_1 || use cpu_flags_x86_sse4_2 ) && CONFIG_OPTS+=( --enable-sse4 )
+ econf --with-snappy --with-seqan --with-io_lib $CONFIG_OPTS \
+ --with-lzma --with-gnutls --with-nettle --with-hdf5 --with-gmp --with-fftw
+}
+
+pkg_postinst(){
+ einfo "The io_lib, snappy and seqan dependencies are not strictly needed"
+ einfo "but were forced for optimal libmaus2 performance."
+ einfo "igzip is only used if gzip level is set to 11."
+}
diff --git a/sci-libs/libmaus2/libmaus2-9999.ebuild b/sci-libs/libmaus2/libmaus2-9999.ebuild
index d68a5d0e0..01aa74a92 100644
--- a/sci-libs/libmaus2/libmaus2-9999.ebuild
+++ b/sci-libs/libmaus2/libmaus2-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools git-r3
@@ -9,7 +9,7 @@ DESCRIPTION="Library for biobambam2"
HOMEPAGE="https://github.com/gt1/libmaus"
EGIT_REPO_URI="https://github.com/gt1/libmaus2.git"
-LICENSE="GPL-3" # BUG: a mix of licenses, see AUTHORS
+LICENSE="BSD-2 GPL-2 GPL-3 MIT ZLIB" # BUG: incomplete list of licenses, see AUTHORS
SLOT="0"
KEYWORDS=""
IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2"