aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-06-06 11:04:34 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-06-06 11:04:34 +0200
commit88f61f96f645a13363bb55fbc3364dc8bddd320b (patch)
treea1be08982e39dee81071e92deebac911f5759355 /sci-libs
parentdev-libs/boost-compute: Update HOMEPAGE, SRC_URI and github remote-id: projec... (diff)
downloadsci-88f61f96f645a13363bb55fbc3364dc8bddd320b.tar.gz
sci-88f61f96f645a13363bb55fbc3364dc8bddd320b.tar.bz2
sci-88f61f96f645a13363bb55fbc3364dc8bddd320b.zip
sci-libs/clblas: Drop old
Package-Manager: portage-2.2.18
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/clblas/ChangeLog5
-rw-r--r--sci-libs/clblas/Manifest1
-rw-r--r--sci-libs/clblas/clblas-2.2.ebuild64
-rw-r--r--sci-libs/clblas/files/clblas-2.2-client_CMakeLists.patch11
-rw-r--r--sci-libs/clblas/files/clblas-2.2-library_tools_tune_CMakeLists.patch14
5 files changed, 5 insertions, 90 deletions
diff --git a/sci-libs/clblas/ChangeLog b/sci-libs/clblas/ChangeLog
index c6ea0b48a..5ebd9c6ca 100644
--- a/sci-libs/clblas/ChangeLog
+++ b/sci-libs/clblas/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 06 Jun 2015; Marius Brehler <marbre@linux.sungazer.de> -clblas-2.2.ebuild,
+ -files/clblas-2.2-client_CMakeLists.patch,
+ -files/clblas-2.2-library_tools_tune_CMakeLists.patch:
+ sci-libs/clblas: Drop old
+
05 Jun 2015; Marius Brehler <marbre@linux.sungazer.de> clblas-2.2.ebuild,
clblas-2.4.ebuild, clblas-9999.ebuild:
sci-libs/clblas: Cleanup ebuilds
diff --git a/sci-libs/clblas/Manifest b/sci-libs/clblas/Manifest
index b54efe1eb..47dd24365 100644
--- a/sci-libs/clblas/Manifest
+++ b/sci-libs/clblas/Manifest
@@ -1,2 +1 @@
-DIST clblas-2.2.tar.gz 794888 SHA256 0563e028485d240f8b6e6efcae61677049627b19e924dcb1ef8014065b6416df SHA512 9f094845d854130d3901d639606069050da10a33b05985757d72188b2d8ef6e7836edc105f5ad8bf2d0922eb19e9a178388260b2a9da34e2fe27dc731233ec85 WHIRLPOOL 2f81de82d584ec4f2158c1165d02221cacf3775cdb9c96617ca2e3ea1fbb7844c833e50cbd8c7b2601585771ddb81a48795dd1534200806b560954a069cf4ec1
DIST clblas-2.4.tar.gz 800848 SHA256 3e9b8e138c465df1daff0235d9c93b0005986a7257a3739aea2d4c8b60b7ed37 SHA512 ae8c1fc1bef7573b12279977fc32f9e97c9b81b9167994ca6f352587a670dcee0f486ab2b7d5191092324f5e8fc00f9a2ea29303a026a0c1201be31d384cafe7 WHIRLPOOL a97537d7390055ad608eeac66679362956db7acfa96cf1165581ff8f9adfe309b8ff8231225bd8ca6247c8f588bff24d6f648e131cec52f8e3093168a3f26f82
diff --git a/sci-libs/clblas/clblas-2.2.ebuild b/sci-libs/clblas/clblas-2.2.ebuild
deleted file mode 100644
index ff407df7f..000000000
--- a/sci-libs/clblas/clblas-2.2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils python-single-r1
-
-MY_PN="clBLAS"
-
-DESCRIPTION="A software library containing BLAS routines for OpenCL"
-HOMEPAGE="https://github.com/clMathLibraries/clBLAS"
-SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-S="${WORKDIR}/${MY_PN}-${PV}/src"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="+client examples +ktest performance test"
-
-RDEPEND="
- >=sys-devel/gcc-4.6:*
- virtual/opencl
- || ( >=dev-util/amdapp-2.9 dev-util/intel-ocl-sdk )
- dev-libs/boost
- performance? ( ${PYTHON_DEPS} )
- "
-DEPEND="${RDEPEND}"
-# test? (
-# >=dev-cpp/gtest-1.6.0
-# >=sci-libs/acml-6.1.0.3
-# )"
-
-# The tests only get compiled to an executable named Test, which is not recogniozed by cmake.
-# Therefore src_test() won't execute any test.
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${P}"-client_CMakeLists.patch
- "${FILESDIR}/${P}"-library_tools_tune_CMakeLists.patch
- "${FILESDIR}"/clblas-samples_CMakeLists.patch
- "${FILESDIR}"/clblas-scripts_perf_CMakeLists.patch
-)
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
- die "Compilation with gcc older than 4.6 is not supported."
- fi
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_build client CLIENT)
- $(cmake-utils_use_build examples SAMPLE)
- $(cmake-utils_use_build ktest KTEST)
- $(cmake-utils_use_build performance PERFORMANCE)
- $(cmake-utils_use_build test TEST)
- )
- cmake-utils_src_configure
-}
diff --git a/sci-libs/clblas/files/clblas-2.2-client_CMakeLists.patch b/sci-libs/clblas/files/clblas-2.2-client_CMakeLists.patch
deleted file mode 100644
index 552e230e3..000000000
--- a/sci-libs/clblas/files/clblas-2.2-client_CMakeLists.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- client/CMakeLists.txt 2014-06-19 22:53:25.000000000 +0200
-+++ client/CMakeLists.txt.new 2015-03-23 16:30:39.164046584 +0100
-@@ -52,7 +52,7 @@ include_directories(
-
- add_executable(client ${CLIENT_SRC} ${CLIENT_HEADER})
- target_link_libraries(client ${Boost_LIBRARIES} ${OPENCL_LIBRARIES} clBLAS)
--set_target_properties( client PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/staging" )
-+set_target_properties( client PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/staging" OUTPUT_NAME clBLAS-client )
-
- add_executable(testPerfWrapper ${WRAPPER_SRC})
- target_link_libraries(testPerfWrapper ${Boost_LIBRARIES})
diff --git a/sci-libs/clblas/files/clblas-2.2-library_tools_tune_CMakeLists.patch b/sci-libs/clblas/files/clblas-2.2-library_tools_tune_CMakeLists.patch
deleted file mode 100644
index 5f1f763fe..000000000
--- a/sci-libs/clblas/files/clblas-2.2-library_tools_tune_CMakeLists.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Install tune as clBLAS-tune.
-
-Patch by Marius Brehler.
---- library/tools/tune/CMakeLists.txt
-+++ library/tools/tune/CMakeLists.txt
-@@ -138,7 +138,7 @@ endif()
- add_executable(tune ${TOOLS_SRC} ${TOOLS_EXTERNAL_SRC})
- add_dependencies(tune GENERATE_CLT)
- target_link_libraries(tune ${OPENCL_LIBRARIES} ${TIME_LIBRARY} ${MATH_LIBRARY})
--set_target_properties( tune PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/staging" )
-+set_target_properties( tune PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/staging" OUTPUT_NAME clBLAS-tune )
-
- # CPack configuration; include the executable into the package
- install( TARGETS tune