aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-05-23 02:24:36 +0200
committerHorea Christian <horea.christ@yandex.com>2018-05-23 02:24:36 +0200
commit8c25ca238bd0d2df7e204f6506d7258a6cdf1615 (patch)
treec975317ca17c313eca6308594125df9e0d53670c /sci-libs
parentdev-python/num2words: new package (pybids dep) (diff)
downloadsci-8c25ca238bd0d2df7e204f6506d7258a6cdf1615.tar.gz
sci-8c25ca238bd0d2df7e204f6506d7258a6cdf1615.tar.bz2
sci-8c25ca238bd0d2df7e204f6506d7258a6cdf1615.zip
sci-libs/pybids: new package
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pybids/Manifest1
-rw-r--r--sci-libs/pybids/metadata.xml20
-rw-r--r--sci-libs/pybids/pybids-0.5.0.ebuild34
-rw-r--r--sci-libs/pybids/pybids-9999.ebuild37
4 files changed, 92 insertions, 0 deletions
diff --git a/sci-libs/pybids/Manifest b/sci-libs/pybids/Manifest
new file mode 100644
index 000000000..e3e63b7cf
--- /dev/null
+++ b/sci-libs/pybids/Manifest
@@ -0,0 +1 @@
+DIST pybids-0.5.0.tar.gz 2814050 BLAKE2B b4bd548989d09e6f49d94c9262fb225a25a37bd5797fe33d2296943808a8dbebeaf17b81e4ea0513c620bcf4c4b4cbae394123fabe7244363205c73328f00e8b SHA512 7d39198fa321535a2f1761348069c18e7ba113174b8d034dd20e5ea3ac11013840da89b5b7bbe6d9b0458c46a5bc07200a97c5efa1a6ff716c524390bd0a3a65
diff --git a/sci-libs/pybids/metadata.xml b/sci-libs/pybids/metadata.xml
new file mode 100644
index 000000000..143b3ea21
--- /dev/null
+++ b/sci-libs/pybids/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ PyBIDS is a Python library to centralize interactions with datasets
+ conforming BIDS (Brain Imaging Data Structure) format. For more
+ information about BIDS visit http://bids.neuroimaging.io.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">INCF/pybids</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/pybids/pybids-0.5.0.ebuild b/sci-libs/pybids/pybids-0.5.0.ebuild
new file mode 100644
index 000000000..2a2ecf29e
--- /dev/null
+++ b/sci-libs/pybids/pybids-0.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to access BIDS datasets"
+HOMEPAGE="https://github.com/INCF/pybids"
+SRC_URI="https://github.com/INCF/pybids/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/grabbit[${PYTHON_USEDEP}]
+ dev-python/num2words[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ "
+
+# Tests are broken: https://github.com/INCF/pybids/issues/138
+RESTRICT="test"
diff --git a/sci-libs/pybids/pybids-9999.ebuild b/sci-libs/pybids/pybids-9999.ebuild
new file mode 100644
index 000000000..397820db4
--- /dev/null
+++ b/sci-libs/pybids/pybids-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python package to access BIDS datasets"
+HOMEPAGE="https://github.com/INCF/pybids"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/INCF/pybids"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+RDEPEND="
+ dev-python/grabbit[${PYTHON_USEDEP}]
+ dev-python/num2words[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ "
+
+python_test() {
+ py.test -v || die
+}