aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-01-30 05:14:31 -0500
committerHorea Christian <chr@chymera.eu>2023-01-30 05:14:31 -0500
commit933f19809917bf0e4b66f7f703c1ee8e546a7b11 (patch)
tree6fafa68a866d8e172a2612eacb2d952ac9ee2eee /sci-libs
parentdev-python/cadquery: masked package, because: (diff)
downloadsci-933f19809917bf0e4b66f7f703c1ee8e546a7b11.tar.gz
sci-933f19809917bf0e4b66f7f703c1ee8e546a7b11.tar.bz2
sci-933f19809917bf0e4b66f7f703c1ee8e546a7b11.zip
sci-libs/nibabel: version bump 4.0.0
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nibabel/Manifest1
-rw-r--r--sci-libs/nibabel/nibabel-4.0.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/nibabel/Manifest b/sci-libs/nibabel/Manifest
index a83d54180..74266d1e3 100644
--- a/sci-libs/nibabel/Manifest
+++ b/sci-libs/nibabel/Manifest
@@ -1 +1,2 @@
DIST nibabel-3.2.1.tar.gz 4442534 BLAKE2B 5a76275c0c3746bbe094789350f4f6d9dc17e332915c9f567660138c44ba50672415272d21d7b0834c77f4f9660950bda8c684f7664d58f0e5784b782384cb2f SHA512 5c5d95313f4b22462ba67c23d52dd34ed5d690c72a3137b21ac0bdbc4d20aa4f0c1d87d23c675f8c2f6e4335dc51fb9ab788ac8c63be56eec8ab8657ed95a6d7
+DIST nibabel-4.0.0.tar.gz 4505565 BLAKE2B 5efee05adbb0ff9204218060f75acdf6b5b77a1a7cc9b884d122f4a95805f6110a0d9433946d4a53d3aa615932012effe35b4ffa9773fb992da8ff273bf3cfd7 SHA512 1b34901e69ff7aaabfb94e49199de761eb7e397a0a7360c2077935d250368cd061cf1fa9c6ef561fa7707e4853c421b039818bfa4b32fc4792555f3d6235eeb7
diff --git a/sci-libs/nibabel/nibabel-4.0.0.ebuild b/sci-libs/nibabel/nibabel-4.0.0.ebuild
new file mode 100644
index 000000000..2de1e6dc9
--- /dev/null
+++ b/sci-libs/nibabel/nibabel-4.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Access a cacophony of neuro-imaging file formats"
+HOMEPAGE="https://nipy.org/nibabel/"
+SRC_URI="https://github.com/nipy/nibabel/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dicom"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dicom? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ sci-libs/pydicom
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Rported upstream:
+ # https://github.com/nipy/nibabel/issues/1191
+ nibabel/tests/test_volumeutils.py::test_a2f_nan2zero_range
+)
+
+distutils_enable_sphinx doc/source dev-python/texext dev-python/numpydoc dev-python/matplotlib
+distutils_enable_tests pytest