aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-06-05 12:02:11 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-06-05 12:02:11 +0200
commitffc8f13593396631802c2b2c4376abf9374a5364 (patch)
tree91d643a427d918d766b121f84ebf89ba114d7f1f /sci-libs
parentsci-physics/pythia-8.2.09-r1: moved to the portage tree after testing (diff)
downloadsci-ffc8f13593396631802c2b2c4376abf9374a5364.tar.gz
sci-ffc8f13593396631802c2b2c4376abf9374a5364.tar.bz2
sci-ffc8f13593396631802c2b2c4376abf9374a5364.zip
Revert "sci-libs/arrayfire: Fetch tarball instead of getting src from git"
This reverts commit 74de59ebeac0640e7a3ff828e33ade5d4825bc51. The tarball does not cointain the git submodules.
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/arrayfire/ChangeLog4
-rw-r--r--sci-libs/arrayfire/Manifest1
-rw-r--r--sci-libs/arrayfire/arrayfire-3.0_beta.ebuild10
3 files changed, 5 insertions, 10 deletions
diff --git a/sci-libs/arrayfire/ChangeLog b/sci-libs/arrayfire/ChangeLog
index 7267d35bd..61231847c 100644
--- a/sci-libs/arrayfire/ChangeLog
+++ b/sci-libs/arrayfire/ChangeLog
@@ -1,10 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
- 31 May 2015; Marius Brehler <marbre@linux.sungazer.de>
- arrayfire-3.0_beta.ebuild:
- Fetch tarball instead of getting src from git
-
23 May 2015; Marius Brehler <marbre@linux.sungazer.de>
+files/FindBoostCompute.cmake,
+files/arrayfire-3.0_beta-FindBoostCompute.patch,
diff --git a/sci-libs/arrayfire/Manifest b/sci-libs/arrayfire/Manifest
index 2f9794931..77f682a16 100644
--- a/sci-libs/arrayfire/Manifest
+++ b/sci-libs/arrayfire/Manifest
@@ -1,2 +1 @@
-DIST arrayfire-3.0_beta.tar.gz 531403 SHA256 3d80bd060b2a03e808757f7c2df3035ea357e3476a2cb69af4a3aeae826dd6af SHA512 feb6857ac65d32603739cefdd7810a0887b96cac6a3cff073aff6ff82b86b396bd94cbd60e5f4a48085813b9dd5049857e30d52d81236541f19bbcf8769db448 WHIRLPOOL 9b87a443724f7b3c77287f12debc4b268a62084895fb6196985ffd2bb184186e1eda240446c88841fe20b845169e8338832919f3cbbee0ca9d5de8e460740846
DIST gtest-1.7.0.zip 1164254 SHA256 247ca18dd83f53deb1328be17e4b1be31514cedfc1e3424f672bf11fd7e0d60d SHA512 8859369f2dd32cbc2ac01aba029aa3ff20a321f40658b9643aff442d34c33468221866b801b28c66a28af47dbcd362d26941fc98db92b6efb7e41ea5b7be1a07 WHIRLPOOL 0c31a385159551859c1afe76480b3fb1b560d666db9a0afc5cbda92bcd53bf129f85a8f902c6ded0779c2b4c49aacec59ba5a4d5ce316a07bf08174f4fc64049
diff --git a/sci-libs/arrayfire/arrayfire-3.0_beta.ebuild b/sci-libs/arrayfire/arrayfire-3.0_beta.ebuild
index 0bc42c902..8a08c8c77 100644
--- a/sci-libs/arrayfire/arrayfire-3.0_beta.ebuild
+++ b/sci-libs/arrayfire/arrayfire-3.0_beta.ebuild
@@ -4,15 +4,16 @@
EAPI=5
-inherit cmake-utils
+inherit cmake-utils git-r3
GTEST_PV="1.7.0"
DESCRIPTION="A general purpose GPU library."
HOMEPAGE="http://www.arrayfire.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV//_/}.tar.gz -> ${P}.tar.gz
- test? ( https://googletest.googlecode.com/files/gtest-${GTEST_PV}.zip )"
+EGIT_REPO_URI="https://github.com/${PN}/${PN}.git git://github.com/${PN}/${PN}.git"
+SRC_URI="test? ( https://googletest.googlecode.com/files/gtest-${GTEST_PV}.zip )"
KEYWORDS="~amd64"
+EGIT_COMMIT="v3.0beta"
LICENSE="BSD"
SLOT="0"
@@ -37,7 +38,6 @@ RDEPEND="
)"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${P//_/}"
BUILD_DIR="${S}/build"
CMAKE_BUILD_TYPE=Release
@@ -60,7 +60,7 @@ pkg_pretend() {
}
src_unpack() {
- default
+ git-r3_src_unpack
if use test; then
mkdir -p "${BUILD_DIR}"/third_party/src/ || die