aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-01-10 10:17:49 +0100
committerThomas Kahle <tomka@gentoo.org>2013-01-10 10:18:13 +0100
commit143d931a0dd74fabff1cf16994ca917044ceeb28 (patch)
tree3c1fea4dc659a0950d8f46c8d872f1bf22a1fb38 /sci-mathematics/Macaulay2
parentsync with gentoo-x86 (diff)
downloadsci-143d931a0dd74fabff1cf16994ca917044ceeb28.tar.gz
sci-143d931a0dd74fabff1cf16994ca917044ceeb28.tar.bz2
sci-143d931a0dd74fabff1cf16994ca917044ceeb28.zip
migrate to git-2 eclass, fix lapack support
Package-Manager: portage-2.1.11.38
Diffstat (limited to 'sci-mathematics/Macaulay2')
-rw-r--r--sci-mathematics/Macaulay2/ChangeLog5
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-9999.ebuild17
2 files changed, 15 insertions, 7 deletions
diff --git a/sci-mathematics/Macaulay2/ChangeLog b/sci-mathematics/Macaulay2/ChangeLog
index 2619c70b3..f97fdc7fd 100644
--- a/sci-mathematics/Macaulay2/ChangeLog
+++ b/sci-mathematics/Macaulay2/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sci-mathematics/Macaulay2
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 10 Jan 2013; Thomas Kahle <tomka@gentoo.org> Macaulay2-9999.ebuild:
+ migrate to git-2 eclass, fix lapack support
+
30 Oct 2012; Thomas Kahle <tomka@gentoo.org> +files/9999-lapack.patch,
Macaulay2-9999.ebuild:
Fix linking against arbitrary lapack implementation
diff --git a/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild b/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild
index a2b112795..008034019 100644
--- a/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild
+++ b/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=4
-inherit autotools elisp-common eutils flag-o-matic python subversion
+inherit autotools elisp-common eutils flag-o-matic git-2 python
IUSE="debug emacs optimization"
-ESVN_REPO_URI="svn://svn.macaulay2.com/Macaulay2/trunk/M2"
+EGIT_REPO_URI="git://github.com/Macaulay2/M2.git"
# Those packages will be built internally.
FACTORY="factory-3-1-4-1"
@@ -65,13 +65,17 @@ RDEPEND="${DEPEND}"
SITEFILE=70Macaulay2-gentoo.el
-S="${WORKDIR}/${PN}-${PV}"
+S="${WORKDIR}/${PN}-${PV}/"
RESTRICT="mirror"
src_unpack (){
unpack "Normaliz2.8.zip"
- subversion_src_unpack
+ git-2_src_unpack
+ # Undo one level of directory until git allows to checkout
+ # subdirectories
+ mv "${S}"/M2/* "${S}" || die
+ rmdir "${S}"/M2 || die
}
pkg_setup () {
@@ -126,7 +130,8 @@ src_configure (){
fi
# configure instead of econf to enable install with --prefix
- ./configure --prefix="${D}/usr" \
+ ./configure LIBS="$(pkg-config --libs lapack)" \
+ --prefix="${D}/usr" \
--disable-encap \
--disable-strip \
$(use_enable optimization optimize) \