aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-27 18:05:10 +0100
committerJustin Lecher <jlec@gentoo.org>2013-02-27 18:05:10 +0100
commit303b4c8da495c7a33795a7b3caff4edcc09d4d55 (patch)
tree34f42fb2bff31187d13633a65e4a7f1ceea9e9f2 /sci-mathematics/Macaulay2
parentsci-chemistry/simpson: Use PKG_CONFIG instead of generic pkg-config (diff)
downloadsci-303b4c8da495c7a33795a7b3caff4edcc09d4d55.tar.gz
sci-303b4c8da495c7a33795a7b3caff4edcc09d4d55.tar.bz2
sci-303b4c8da495c7a33795a7b3caff4edcc09d4d55.zip
sci-mathematics/Macaulay2: Use PKG_CONFIG instead of generic pkg-config
Package-Manager: portage-2.2.0_alpha163
Diffstat (limited to 'sci-mathematics/Macaulay2')
-rw-r--r--sci-mathematics/Macaulay2/ChangeLog4
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-9999.ebuild1
-rw-r--r--sci-mathematics/Macaulay2/files/9999-lapack.patch2
3 files changed, 6 insertions, 1 deletions
diff --git a/sci-mathematics/Macaulay2/ChangeLog b/sci-mathematics/Macaulay2/ChangeLog
index ec1c9afdc..e164ec156 100644
--- a/sci-mathematics/Macaulay2/ChangeLog
+++ b/sci-mathematics/Macaulay2/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 27 Feb 2013; Justin Lecher <jlec@gentoo.org> files/9999-lapack.patch,
+ Macaulay2-9999.ebuild:
+ Use PKG_CONFIG instead of generic pkg-config
+
22 Feb 2013; Justin Lecher <jlec@gentoo.org> Macaulay2-9999.ebuild,
metadata.xml:
Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config#
diff --git a/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild b/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild
index b18264138..b25ac4540 100644
--- a/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild
+++ b/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild
@@ -82,6 +82,7 @@ pkg_setup () {
}
src_prepare() {
+ tc-export PKG_CONFIG
# Put updated Normaliz.m2 in place
cp "${WORKDIR}/Normaliz2.8/Macaulay2/Normaliz.m2" \
"${S}/Macaulay2/packages" || die
diff --git a/sci-mathematics/Macaulay2/files/9999-lapack.patch b/sci-mathematics/Macaulay2/files/9999-lapack.patch
index 3798253dd..e9a434eeb 100644
--- a/sci-mathematics/Macaulay2/files/9999-lapack.patch
+++ b/sci-mathematics/Macaulay2/files/9999-lapack.patch
@@ -44,7 +44,7 @@
- AC_MSG_ERROR(the fortran compiler ($FC) does not support the Fortran 90 language required for compiling lapack),
- AC_MSG_RESULT(yes))
-fi
-+BUILTLIBS="$(pkg-config --libs lapack) $BUILTLIBS"
++BUILTLIBS="$(${PKG_CONFIG} --libs lapack) $BUILTLIBS"
if test $BUILD_memtailor = yes
then BUILTLIBS="-lmemtailor $BUILTLIBS"