aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-11-10 23:21:01 +0100
committerThomas Kahle <tomka@gentoo.org>2010-11-10 23:21:01 +0100
commitc476fef7bcab7e745a2be6c9306d38790641a59c (patch)
tree4353dfc8762e5654c191c8579a79cc85e20a46ec /sci-mathematics/Macaulay2
parentsci-math/topcom -> main tree (diff)
downloadsci-c476fef7bcab7e745a2be6c9306d38790641a59c.tar.gz
sci-c476fef7bcab7e745a2be6c9306d38790641a59c.tar.bz2
sci-c476fef7bcab7e745a2be6c9306d38790641a59c.zip
sci-mathematics/Macualay2 bump to 1.4
(Portage version: 2.1.9.24/git/Linux i686, signed Manifest commit with key 0x914769A1)
Diffstat (limited to 'sci-mathematics/Macaulay2')
-rw-r--r--sci-mathematics/Macaulay2/ChangeLog6
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-1.4.ebuild138
-rw-r--r--sci-mathematics/Macaulay2/Manifest17
-rw-r--r--sci-mathematics/Macaulay2/files/1.4-paths-of-external-programs.patch61
4 files changed, 221 insertions, 1 deletions
diff --git a/sci-mathematics/Macaulay2/ChangeLog b/sci-mathematics/Macaulay2/ChangeLog
index e461f2cd0..a3aab0de1 100644
--- a/sci-mathematics/Macaulay2/ChangeLog
+++ b/sci-mathematics/Macaulay2/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*Macaulay2-1.4 (10 Nov 2010)
+
+ 10 Nov 2010; Thomas Kahle <tomka@gentoo.org>
+ +files/1.4-paths-of-external-programs.patch, +Macaulay2-1.4.ebuild:
+ bump to 1.4
+
16 Oct 2010; Thomas Kahle <tom111@gmx.de> Macaulay2-1.4_pre.ebuild,
Macaulay2-9999.ebuild:
Adjusted dependencies of newer version
diff --git a/sci-mathematics/Macaulay2/Macaulay2-1.4.ebuild b/sci-mathematics/Macaulay2/Macaulay2-1.4.ebuild
new file mode 100644
index 000000000..2e014ffb5
--- /dev/null
+++ b/sci-mathematics/Macaulay2/Macaulay2-1.4.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools elisp-common eutils
+
+IUSE="emacs optimization"
+MY_REV="12617"
+
+FACTORYVER="3-1-1"
+
+DESCRIPTION="research tool for commutative algebra and algebraic geometry"
+SRC_BASE="http://www.math.uiuc.edu/${PN}/Downloads/"
+SRC_URI="${SRC_BASE}/OtherSourceCode/1.4/factory-${FACTORYVER}.tar.gz
+ ${SRC_BASE}/OtherSourceCode/1.4/libfac-${FACTORYVER}.tar.gz
+ http://www.math.uiuc.edu/${PN}/Extra/gc-7.2alpha5-2010-09-03.tar.gz
+ ${SRC_BASE}/SourceCode/${P}-r${MY_REV}-src.tar.bz2"
+
+HOMEPAGE="http://www.math.uiuc.edu/Macaulay2/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/gdbm
+ >=dev-libs/ntl-5.5.2
+ >=sci-mathematics/pari-2.3.4[gmp]
+ >=sys-libs/readline-6.1
+ dev-libs/libxml2
+ sci-mathematics/frobby
+ sci-mathematics/4ti2
+ sci-mathematics/nauty
+ >=sci-mathematics/normaliz-2.5
+ sci-mathematics/gfan
+ >=dev-libs/mpfr-3.0.0
+ >=sci-libs/mpir-2.1.1[cxx]
+ sci-libs/cddlib
+ sci-libs/cdd+
+ sci-libs/lrslib[gmp]
+ virtual/blas
+ virtual/lapack
+ dev-util/ctags
+ sys-libs/ncurses
+ sys-process/time
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+SITEFILE=70Macaulay2-gentoo.el
+
+S="${WORKDIR}/${P}-r${MY_REV}"
+
+pkg_setup () {
+ tc-export CC CPP CXX
+}
+
+src_prepare() {
+ # Patching .m2 files to look for external programs in
+ # /usr/bin
+ epatch "${FILESDIR}"/${PV}-paths-of-external-programs.patch
+
+ # Fixing make warnings about unavailable jobserver:
+ sed -i "s/\$(MAKE)/+ \$(MAKE)/g" "${S}"/distributions/Makefile.in
+
+ # Factory, and libfac are statically linked libraries which (in this flavor)
+ # are not used by any other program. We build them internally and don't install them
+ mkdir "${S}/BUILD/tarfiles" || die "Creation of directory failed"
+ cp "${DISTDIR}/factory-3-1-1.tar.gz" "${S}/BUILD/tarfiles/" \
+ || die "copy failed"
+ cp "${DISTDIR}/libfac-3-1-1.tar.gz" "${S}/BUILD/tarfiles/" \
+ || die "copy failed"
+ # Macaulay 2 in this version insists on a snapshot of boehm-gc that is not available elsewhere
+ # We will let it build its internal version for now.
+ cp "${DISTDIR}/gc-7.2alpha5-2010-09-03.tar.gz" "${S}/BUILD/tarfiles/" \
+ || die "copy failed"
+
+ eautoreconf
+}
+
+src_configure (){
+
+ # Recommended in bug #268064 Possibly unecessary
+ # but should not hurt anybody.
+ if ! use emacs; then
+ tags="ctags"
+ fi
+
+ CPPFLAGS="-I/usr/include/frobby" \
+ ./configure --prefix="${D}/usr" \
+ --disable-encap \
+ --disable-strip \
+ $(use_enable optimization optimize) \
+ --enable-build-libraries="factory libfac" \
+ --with-unbuilt-programs="4ti2 gfan normaliz nauty cddplus lrslib" \
+ || die "failed to configure Macaulay"
+}
+
+src_compile() {
+ # Parallel build not supported yet
+ emake -j1 || die "failed to build Macaulay"
+
+ if use emacs; then
+ cd "${S}/Macaulay2/emacs"
+ elisp-compile *.el || die "elisp-compile failed"
+ fi
+}
+
+src_test() {
+ emake check || die "tests failed"
+}
+
+src_install () {
+ # Parallel install not supported yet
+ emake -j1 install || die "install failed"
+
+ # Remove emacs files and install them in the
+ # correct place if use emacs
+
+ rm -rf "${D}"/usr/share/emacs/site-lisp
+ if use emacs; then
+ cd "${S}/Macaulay2/emacs"
+ elisp-install ${PN} *.elc *.el || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "If you want to set a hot key for Macaulay2 in Emacs add a line similar to"
+ elog "(global-set-key [ f12 ] 'M2)"
+ elog "in order to set it to F12 (or choose a different one)."
+ fi
+}
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/Macaulay2/Manifest b/sci-mathematics/Macaulay2/Manifest
index 7e68d6a78..7eb626448 100644
--- a/sci-mathematics/Macaulay2/Manifest
+++ b/sci-mathematics/Macaulay2/Manifest
@@ -1,9 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+AUX 1.4-paths-of-external-programs.patch 3175 RMD160 ad0f634b52b3fe883e49a53815481ca5b73d93c3 SHA1 4644c4b8c64678ca8205515436666651f467ee58 SHA256 162823069e075d7b7712db841d8c7bb8e1f03f2c33d4ade18e0b7a20543f5230
AUX 1.4_pre-paths-of-external-programs.patch 3175 RMD160 ad0f634b52b3fe883e49a53815481ca5b73d93c3 SHA1 4644c4b8c64678ca8205515436666651f467ee58 SHA256 162823069e075d7b7712db841d8c7bb8e1f03f2c33d4ade18e0b7a20543f5230
AUX 70Macaulay2-gentoo.el 597 RMD160 bdf3a30bb4d15a77e0dff86c866134d06c443fa0 SHA1 d4a4036042ab13bc20d8be90b559e9168bfc0ef5 SHA256 e5583d11e6ab662261abb32e90fcf31ccf6bd56f2b23b691b9255d1b8d8acb2f
AUX 9999-paths-of-external-programs.patch 3175 RMD160 ad0f634b52b3fe883e49a53815481ca5b73d93c3 SHA1 4644c4b8c64678ca8205515436666651f467ee58 SHA256 162823069e075d7b7712db841d8c7bb8e1f03f2c33d4ade18e0b7a20543f5230
AUX paths-of-dependencies.patch 2437 RMD160 9b63baeee97428406bed8bfbf67cf6fead95974a SHA1 cf245ad8bcdbe119e127242119b2b96342100035 SHA256 bffbaaf077f99f1e135fe0eff61be702c6eb138f4b4ae715cec8c5be62ee8046
AUX respect-CFLAGS.patch 410 RMD160 9236f3e777d4b2d9510fa83ba71e8c4f4e114539 SHA1 adce86b7605e1aff654532968f8be7a199d2081e SHA256 13ba84357f79b7a779d3bbabdb4c367beeb08f7878ab8f4ca6d30ba219126349
DIST Macaulay2-1.3.1.tar.bz2 3737431 RMD160 ce29e95d5b1b5409e368054f2edf0e5bd04d0dd3 SHA1 5a0f6b830b7a3a7cf045ac10e64ca2e3cb199600 SHA256 c07104d3a0edb70d61d3a221f7c8b0d23e0cca2d30b27127fe8ec7f763a2b4b1
+DIST Macaulay2-1.4-r12617-src.tar.bz2 4003881 RMD160 cb7958d8a347e45e10d717a8654d04e05a17ff00 SHA1 b88115b748c43a4f306a7b9fe6b47f7554498ec8 SHA256 9ddaf6f7288629647150067f46ca634a9b3c88fedfe3a9e21231531867ad9d91
DIST factory-3-1-0.tar.gz 565374 RMD160 059ed1697f282d309e89d1cc2e0ce8bd94a8b4b3 SHA1 c41ab3cdc6ea51332169645e35c35c3fd6c4d94b SHA256 cb1768ccaaa71557ace880be0e88100bcfd420d3094ffac59d229cd852edc0ff
DIST factory-3-1-1.tar.gz 540431 RMD160 63b5d71c93b1c0f628d758959822f61b0a9c702c SHA1 2b0e087de5ff4d4b63c003e1b6f9926577f17264 SHA256 1f86833248ef2bb5fd7820201d08df864bda2d8be58bc69255ecdca6fdf12c1b
DIST gc-7.2alpha5-2010-09-03.tar.gz 1257818 RMD160 58954216c702add21e24eecb2225274e760faf49 SHA1 1686ccc823376e7e693cae3b3c387c2aa052154b SHA256 adba7f6663d911d4031a1a6a87de6f75d5d8f7870ad362e16f5395449911c1fa
@@ -11,7 +16,17 @@ DIST libfac-3-1-0.tar.gz 91544 RMD160 2500d402328ad532756c677015c1d01f8594e394 S
DIST libfac-3-1-1.tar.gz 90104 RMD160 8ca086ad2dc1dfbf3d8824e244f0b1af087eef62 SHA1 3753363a6f56cfeb0d0be3bdf471d6bd55c14ede SHA256 4c463af2d22375aa62be4fb1f9a32cada6723ca5e3ddbd8a4f5cab72b675e33a
EBUILD Macaulay2-1.3.1-r3.ebuild 2651 RMD160 ca4332c7ccbffd35ea516f968a77dfbc01e9c8eb SHA1 0551b9803cff0ff7993e4ca90d70b12eec628f6c SHA256 6f957b390ffadf97dce4c91ba30376cca016be8c3d93dedc83e4be23a2a96e92
EBUILD Macaulay2-1.3.1-r4.ebuild 3323 RMD160 685a9e92768a913984f4b75e47bebac2c988d9ac SHA1 0247845b210eeb7b4f2e92764a99ca88b570e16e SHA256 07baf8dfcdc3ed2cf92db4f0a2530a3f63269452eab42c7d128f13c23ecf5d04
+EBUILD Macaulay2-1.4.ebuild 3624 RMD160 82bbc4db45bd0dc0f7028a498096eb30189adc15 SHA1 5d9608774210aaa9e1ed66ff2962ba9beeb6820b SHA256 3f9f889310e8a619643db8eeffbd671c35325d0286bdb85bd4be10e68cf0b1f2
EBUILD Macaulay2-1.4_pre.ebuild 3821 RMD160 1134405f8b150e1f60fa69298aada3f23e51aced SHA1 145b671a2d8ce3a08c266ea3abdffe294eefc9fb SHA256 e6d0a8b43cf066d67e59822f6dd55e3839caad45b27d464f17e3076014775f8b
EBUILD Macaulay2-9999.ebuild 4055 RMD160 4195349b5bfc525bef1b399531511bc9441a1200 SHA1 c283f0520eb366dd6c274cd5dcacee903175ed12 SHA256 77b5f66d69613bd245c4c1393aacf1ca9f3d94768a052a3125c8b5781260d2d0
-MISC ChangeLog 3513 RMD160 092e7707cd1e54753d32657f8230997b2778cffc SHA1 780c8b0a4d726462eae471df9c4ba44968f0d809 SHA256 96a487fd789a8e66809e84572a01917bdd63141c800fe0968547c3c35fc8dd6e
+MISC ChangeLog 3675 RMD160 8d5c9a2df0c12ed132ff4e35fbae691e6824fc00 SHA1 d49528703846756e402fe14fa4df31ab01211534 SHA256 79be0a8400a18d2b3a1e70e27ae0301d675a73fb73eeaae9b8babfb72c86fac7
MISC metadata.xml 486 RMD160 0e913360cd4f3dd6b814bf44341c83005739a22b SHA1 83fb4a5ca743b184562281c8f1a5b8f722528514 SHA256 5937610a5ea0ddb9d15953121aa4f512f6ba8c2bcd35882a2dfe401f1dbddaa7
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iJwEAQEIAAYFAkzbGs0ACgkQQYXt1pFHaaHVkQP8CjlEOZwN2+dj82a56ZgvRQdk
+ErIv1fEIqFFy2j1sVZB/p+oaXrhAHs6Rw5njaurPA9NEsM2dECh1cbw4L52BSOSM
+MKWenRkjhDKOBk8eNPK8UOXGPcPZLy9oA/qq7+eOhIgCkoxAwVgpnOjXSXA/ZrG3
+Q2v1S1V1HiH9UC0ELAA=
+=pcLb
+-----END PGP SIGNATURE-----
diff --git a/sci-mathematics/Macaulay2/files/1.4-paths-of-external-programs.patch b/sci-mathematics/Macaulay2/files/1.4-paths-of-external-programs.patch
new file mode 100644
index 000000000..9b16e5a51
--- /dev/null
+++ b/sci-mathematics/Macaulay2/files/1.4-paths-of-external-programs.patch
@@ -0,0 +1,61 @@
+diff -U 3 -dHrN M2source.orig/Macaulay2/packages/FourTiTwo.m2 M2source.patches/Macaulay2/packages/FourTiTwo.m2
+--- M2source.orig/Macaulay2/packages/FourTiTwo.m2 2010-09-19 02:32:45.000000000 +0200
++++ M2source.patches/Macaulay2/packages/FourTiTwo.m2 2010-09-19 02:37:25.000000000 +0200
+@@ -47,7 +47,7 @@
+
+ path'4ti2 = (options FourTiTwo).Configuration#"path"
+ -- NOTE: the absolute path should be put into the .init file for 4ti2 inside the .Macaulay2 directory.
+-if path'4ti2 == "" then path'4ti2 = prefixDirectory | currentLayout#"programs"
++if path'4ti2 == "" then path'4ti2 = "/usr/bin/"
+
+ getFilename = () -> (
+ filename := temporaryFileName();
+diff -U 3 -dHrN M2source.orig/Macaulay2/packages/gfanInterface.m2 M2source.patches/Macaulay2/packages/gfanInterface.m2
+--- M2source.orig/Macaulay2/packages/gfanInterface.m2 2010-09-19 02:32:45.000000000 +0200
++++ M2source.patches/Macaulay2/packages/gfanInterface.m2 2010-09-19 02:38:08.000000000 +0200
+@@ -26,7 +26,7 @@
+ }
+
+ gfan'path = gfanInterface#Options#Configuration#"path"
+-if gfan'path == "" then gfan'path = prefixDirectory | currentLayout#"programs"
++if gfan'path == "" then gfan'path = "/usr/bin/"
+ if instance(gfan'path, String) then gfan'path = {gfan'path}
+ if not instance(gfan'path,List) then error "expected configuration option gfan'path to be a list of strings or a string"
+ gfan'path = join(
+diff -U 3 -dHrN M2source.orig/Macaulay2/packages/Nauty.m2 M2source.patches/Macaulay2/packages/Nauty.m2
+--- M2source.orig/Macaulay2/packages/Nauty.m2 2010-09-19 02:33:04.000000000 +0200
++++ M2source.patches/Macaulay2/packages/Nauty.m2 2010-09-19 02:40:46.000000000 +0200
+@@ -27,7 +27,8 @@
+ -- Check the ~/.Macaulay2/init-Nauty.m2 file for the absolute path.
+ -- If it's not there, then use the M2-Programs directory.
+ nauty'path = (options Nauty).Configuration#"path";
+-if nauty'path == "" then nauty'path = prefixDirectory | currentLayout#"programs";
++if nauty'path == "" then nauty'path = "/usr/bin/";
++
+
+ -------------------
+ -- Exports
+diff -U 3 -dHrN M2source.orig/Macaulay2/packages/Normaliz.m2 M2source.patches/Macaulay2/packages/Normaliz.m2
+--- M2source.orig/Macaulay2/packages/Normaliz.m2 2010-09-19 02:33:04.000000000 +0200
++++ M2source.patches/Macaulay2/packages/Normaliz.m2 2010-09-19 02:39:12.000000000 +0200
+@@ -156,7 +156,7 @@
+ nmzExec="norm64";
+ );
+ -- return nmzExec;
+- return prefixDirectory | currentLayout#"programs" | nmzExec;
++ return "/usr/bin/" | nmzExec;
+ );
+
+
+diff -U 3 -dHrN M2source.orig/Macaulay2/packages/StatePolytope.m2 M2source.patches/Macaulay2/packages/StatePolytope.m2
+--- M2source.orig/Macaulay2/packages/StatePolytope.m2 2010-09-19 02:32:46.000000000 +0200
++++ M2source.patches/Macaulay2/packages/StatePolytope.m2 2010-09-19 02:38:39.000000000 +0200
+@@ -31,7 +31,7 @@
+
+
+ gfanCommand = (options StatePolytope)#Configuration#"gfan command"
+-if gfanCommand === "gfan" then gfanCommand = prefixDirectory | currentLayout#"programs" | gfanCommand
++if gfanCommand === "gfan" then gfanCommand = "/usr/bin/" | gfanCommand
+ gfanCommand = "!" | gfanCommand
+
+ --The next two functions print out the ring and the ideal in the format required by gfan