aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-08-19 11:16:37 +0200
committerThomas Kahle <tomka@gentoo.org>2012-08-19 11:16:58 +0200
commiteaadb67f97fbecd4e23e5b177c82c2c7e9e99b4e (patch)
treec14df9188875fc2f390f02e04ab77749f095fa82 /sci-mathematics/Macaulay2
parentsci-chemistry/usf-tools: Bump to latest release (diff)
downloadsci-eaadb67f97fbecd4e23e5b177c82c2c7e9e99b4e.tar.gz
sci-eaadb67f97fbecd4e23e5b177c82c2c7e9e99b4e.tar.bz2
sci-eaadb67f97fbecd4e23e5b177c82c2c7e9e99b4e.zip
update to EAPI=4, cosmetics, deps
(Portage version: 2.1.11.10/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-mathematics/Macaulay2')
-rw-r--r--sci-mathematics/Macaulay2/ChangeLog3
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-9999.ebuild36
-rw-r--r--sci-mathematics/Macaulay2/Manifest3
3 files changed, 20 insertions, 22 deletions
diff --git a/sci-mathematics/Macaulay2/ChangeLog b/sci-mathematics/Macaulay2/ChangeLog
index 0cd176dcf..16e439c46 100644
--- a/sci-mathematics/Macaulay2/ChangeLog
+++ b/sci-mathematics/Macaulay2/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 19 Aug 2012; Thomas Kahle <tomka@gentoo.org> Macaulay2-9999.ebuild:
+ update to EAPI=4, cosmetics, deps
+
06 Aug 2012; Thomas Kahle <tomka@gentoo.org> Macaulay2-9999.ebuild:
Update live dependencies
diff --git a/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild b/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild
index 0ef50e6a6..6e7dfc18a 100644
--- a/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild
+++ b/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI=4
inherit autotools elisp-common eutils flag-o-matic subversion
@@ -10,10 +10,7 @@ IUSE="emacs optimization"
ESVN_REPO_URI="svn://svn.macaulay2.com/Macaulay2/trunk/M2"
-# Those packages will be built internally, Macaulay2 always wants the
-# latest and greatest (mostly git snapshots)
-GCLIBATOMIC_OPS="gc-libatomic_ops-7.3alpha2"
-GC="gc-20120729"
+# Those packages will be built internally.
FACTORY="factory-3-1-4-1"
LIBFAC="libfac-3-1-4"
@@ -23,8 +20,7 @@ SRC_BASE="http://www.math.uiuc.edu/${PN}/Downloads/"
SRC_URI="ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Libfac/${LIBFAC}.tar.gz
ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Factory/factory-gftables.tar.gz
http://www.math.uiuc.edu/Macaulay2/Downloads/OtherSourceCode/trunk/${FACTORY}.tar.gz
- http://www.math.uiuc.edu/Macaulay2/Extra/${GC}.tar.gz
- http://www.math.uiuc.edu/Macaulay2/Extra/${GCLIBATOMIC_OPS}.tar.gz"
+ http://www.math.uiuc.edu/Macaulay2/Extra/gtest-1.6.0.tar.gz"
SLOT="0"
LICENSE="GPL-2"
@@ -51,6 +47,7 @@ DEPEND="
dev-util/ctags
sys-libs/ncurses
sys-process/time
+ >dev-libs/boehm-gc-7.1
emacs? ( virtual/emacs )"
RDEPEND="${DEPEND}"
@@ -82,12 +79,10 @@ src_prepare() {
|| die "copy failed"
cp "${DISTDIR}/${LIBFAC}.tar.gz" "${S}/BUILD/tarfiles/" \
|| die "copy failed"
- # Macaulay 2 insists on a git snapshot of gc We will let it build
- # its internal version for now. Note: The resulting QA warning is
- # known.
- cp "${DISTDIR}/${GC}.tar.gz" "${S}/BUILD/tarfiles/" \
- || die "copy failed"
- cp "${DISTDIR}/${GCLIBATOMIC_OPS}.tar.gz" "${S}/BUILD/tarfiles/" \
+ # Macaulay2 developers want that gtest is built internally because
+ # the documentation says it may fail if build with options not the
+ # same as the tested program.
+ cp "${DISTDIR}/gtest-1.6.0.tar.gz" "${S}/BUILD/tarfiles/" \
|| die "copy failed"
eautoreconf
@@ -105,38 +100,39 @@ src_configure (){
--disable-encap \
--disable-strip \
$(use_enable optimization optimize) \
- --enable-build-libraries="factory gc libfac" \
+ --enable-build-libraries="factory libfac" \
--with-unbuilt-programs="4ti2 gfan normaliz nauty cddplus lrslib" \
|| die "failed to configure Macaulay"
}
src_compile() {
# Parallel build not supported yet
- # For trunk builds, let's ignore example errors
- emake IgnoreExampleErrors=true -j1 || die "failed to build Macaulay"
+ # emake -j1
+ # For trunk builds we may wish to ignore example errors
+ emake IgnoreExampleErrors=true -j1
if use emacs; then
cd "${S}/Macaulay2/emacs"
- elisp-compile *.el || die "elisp-compile failed"
+ elisp-compile *.el
fi
}
src_test() {
# No parallel tests yet & Need to increase the time
# limit for long running tests in Schubert2 to pass
- emake TLIMIT=550 -j1 check || die "tests failed"
+ emake TLIMIT=550 -j1 check
}
src_install () {
# Parallel install not supported yet
- emake -j1 install || die "install failed"
+ emake -j1 install
# Remove emacs files and install them in the
# correct place if use emacs
rm -rf "${D}"/usr/share/emacs/site-lisp
if use emacs; then
cd "${S}/Macaulay2/emacs"
- elisp-install ${PN} *.elc *.el || die "elisp-install failed"
+ elisp-install ${PN} *.elc *.el
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
}
diff --git a/sci-mathematics/Macaulay2/Manifest b/sci-mathematics/Macaulay2/Manifest
index 8d469acb4..3a1193f97 100644
--- a/sci-mathematics/Macaulay2/Manifest
+++ b/sci-mathematics/Macaulay2/Manifest
@@ -1,5 +1,4 @@
DIST factory-3-1-4-1.tar.gz 707733 SHA256 7691308866a47e405be0f26b15e553850ead6034f76b6bc311e7a84a4c6b3e6a SHA512 404ef7c3afa6c3f868efbd13e5d3e80f7655d6f0615dc6feb21892743d804057344174133497027f5f49ead0d48e792a4a9b0749311092c5883e22a4bba9dd4c WHIRLPOOL 79366c2bc1bec781affdaa36264d4c726f447f8faf2694e9ce7fa5169b2ba3949f26ac6c108579a34ba8aa09f76a5eddc652d14a34de7123ee5d4fe8d9998256
DIST factory-gftables.tar.gz 2961892 SHA256 4cd6b3de2fd5eea694a5d843328ab8f6dba1da05ae93efcd2ca0fa5d7658a6fb SHA512 49dfb52e030f04c0b940ce124eb633bb34dacb7ab2faf7f5fee82b3e1ce5331af600b9b684a53eb766c643e38a45f361028940cfd26b8a699c919cfb63d12535 WHIRLPOOL f5d15ac5dcb8e126ecffb42cde5bf5472dbb81e7cb7b2abc1306ee36ef8d85067d0c13b7fa58b65eb09b69da1409a81ea02c0f7ca0e3d1ac71f5c21d8e8b5f81
-DIST gc-20120729.tar.gz 2285159 SHA256 7ca8190f487c21d28b320680158935cc3f8407940f1f278be83eba078b34e3ae SHA512 0f304516613a1702307c52e3741e31d9005659c64b5b03d6442b4a1dd55876f229a15698c53f916a1544b024e560e2a31c7cc6b1a2e5fcf0e74a2c45d3eedc7c WHIRLPOOL b5d27d95fadeef522c99691ab482de02f3d616f61890115f926ca5a888b95300029f0dffd3f59b89c898d2cef44bae5b887e3bdd04325e7104eea3e2b25fab4f
-DIST gc-libatomic_ops-7.3alpha2.tar.gz 1454218 SHA256 b51ae5de3c43186e6c54d820b5b823acffa497868f70d4bcf43a454cfc0cea05 SHA512 bd7ff73ce275823af8375ca5a0406bfce5c623b142d0ec42d6ec7a9d3849f6e4f6ee5fe60f048d8940b43592dd757bb712d034906138a734fd1b02056199bd4a WHIRLPOOL 5c09dc990138089beccb692c87d2e791e5efb41822ee48d990cbb0e68713e64622d61561b972a0d4a9f5762f2aaf6331e81e35b291a3da2a1e515b37a6e1d6bc
+DIST gtest-1.6.0.tar.gz 956966 SHA256 d2346ad6f3b56763b3e18ffde7e69fd2fac11a434f5b12a70f16fabb133554d9 SHA512 b4926751cc3212eb3d3d567a35fd85ed5c8c8393f5781a302f712c56451bf79e596929e56aae0ddedd26d1de2e7ec706c33dd4ee2cfc77a12eb385f36b1da62c WHIRLPOOL 4209b769117486ad5e156625b051364e768338eb3f750e2dfa9149d6e1debebbb81cf3b8b96805dc4222352852a8f70eea3a9f3345ef3986bfacf2fada98581b
DIST libfac-3-1-4.tar.gz 82499 SHA256 12e83baae591e2d2920d87d5fcbb079e9cdd95fa18d989c47df25fdeab339d50 SHA512 e7c155bd1e5b93a050574532f6630e5954ad9e7f010cd7e5a76b175bdf6b95866ac49f80409f6a0e7b41d8c3b052f89a02e77049211030f04ea8a5b47e669b49 WHIRLPOOL 91682eb69d632ac67a3897f62070b562a95903eba0ea6da01c85c540d5da3e0b645f61d787f7d8f6daee3b1b22de2c7826478016c309f8243a39f41f0dcf95eb