aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2011-02-26 07:52:13 +0100
committerThomas Kahle <tomka@gentoo.org>2011-02-26 07:52:34 +0100
commitf25808fc0d5097d0181544289eb38af6d00447a3 (patch)
tree05b0c6c632abb6ce2cc6e16612c33433162d11e9 /sci-mathematics/Macaulay2
parent[sci-physics] Fix manifests (diff)
downloadsci-f25808fc0d5097d0181544289eb38af6d00447a3.tar.gz
sci-f25808fc0d5097d0181544289eb38af6d00447a3.tar.bz2
sci-f25808fc0d5097d0181544289eb38af6d00447a3.zip
Live ebuild updated
(Portage version: 2.1.9.41/git/Linux i686, signed Manifest commit with key 0x914769A1)
Diffstat (limited to 'sci-mathematics/Macaulay2')
-rw-r--r--sci-mathematics/Macaulay2/ChangeLog5
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-9999.ebuild36
-rw-r--r--sci-mathematics/Macaulay2/Manifest16
3 files changed, 30 insertions, 27 deletions
diff --git a/sci-mathematics/Macaulay2/ChangeLog b/sci-mathematics/Macaulay2/ChangeLog
index 107a4ca99..1e0b14634 100644
--- a/sci-mathematics/Macaulay2/ChangeLog
+++ b/sci-mathematics/Macaulay2/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sci-mathematics/Macaulay2
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 26 Feb 2011; Thomas Kahle <tomka@gentoo.org> Macaulay2-9999.ebuild:
+ Live ebuild updated
+
12 Nov 2010; Thomas Kahle <tomka@gentoo.org>
-files/1.4_pre-paths-of-external-programs.patch,
-Macaulay2-1.3.1-r3.ebuild, -Macaulay2-1.4_pre.ebuild,
diff --git a/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild b/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild
index 80ce6b059..3798d8699 100644
--- a/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild
+++ b/sci-mathematics/Macaulay2/Macaulay2-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="2"
-inherit autotools elisp-common eutils subversion
+inherit autotools elisp-common eutils flag-o-matic subversion
IUSE="emacs optimization"
@@ -53,6 +53,7 @@ RESTRICT="mirror"
pkg_setup () {
tc-export CC CPP CXX
+ append-cppflags "-I/usr/include/frobby"
}
src_prepare() {
@@ -60,31 +61,19 @@ src_prepare() {
# /usr/bin
epatch "${FILESDIR}"/${PV}-paths-of-external-programs.patch
- # This is now a configure option:
-# if ! use optimization ; then
-# epatch "${FILESDIR}"/respect-CFLAGS.patch
-# fi
-
-## fixed in trunk as of 09/28/10
-# # The Posets-Package refers to a non-existent Graphs package.
-# # We dump it for now.
-# rm "${S}"/Macaulay2/packages/Posets.m2
-# sed -i "/ Posets/d" "${S}"/configure.ac
-# sed -i "/Posets/d" "${S}"/Macaulay2/packages/Macaulay2Doc/changes.m2
-
# Fixing make warnings about unavailable jobserver:
sed -i "s/\$(MAKE)/+ \$(MAKE)/g" "${S}"/distributions/Makefile.in
- # Factory, and libfac are statically linked libraries which (in this flavor)
- # are not used by any other program. We build them internally and don't install them
- # Permission was granted to tomka by bicatali on IRC.
- # Macaulay 2 in this version insists on a snapshot of boehm-gc that is not available elsewhere
- # We will let it build its internal version for now.
+ # Factory, and libfac are statically linked libraries which (in this flavor) are not used by any
+ # other program. We build them internally and don't install them
mkdir "${S}/BUILD/tarfiles" || die "Creation of directory failed"
cp "${DISTDIR}/factory-3-1-1.tar.gz" "${S}/BUILD/tarfiles/" \
|| die "copy failed"
cp "${DISTDIR}/libfac-3-1-1.tar.gz" "${S}/BUILD/tarfiles/" \
|| die "copy failed"
+ # Macaulay 2 in this version insists on a snapshot of boehm-gc that is not available elsewhere
+ # We will let it build its internal version until >=boehm-gc-7.2_alpha5 is in in tree. Note:
+ # The resulting QA warning is known.
cp "${DISTDIR}/gc-7.2alpha5-2010-09-03.tar.gz" "${S}/BUILD/tarfiles/" \
|| die "copy failed"
@@ -92,19 +81,18 @@ src_prepare() {
}
src_configure (){
-
# Recommended in bug #268064 Possibly unecessary
# but should not hurt anybody.
if ! use emacs; then
tags="ctags"
fi
- CPPFLAGS="-I/usr/include/frobby" \
- ./configure --prefix="${D}/usr" \
+ # configure instead of econf to enable install with --prefix
+ ./configure --prefix="${D}/usr" \
--disable-encap \
--disable-strip \
$(use_enable optimization optimize) \
- --enable-build-libraries="factory libfac" \
+ --enable-build-libraries="factory gc libfac" \
--with-unbuilt-programs="4ti2 gfan normaliz nauty cddplus lrslib" \
|| die "failed to configure Macaulay"
}
@@ -129,7 +117,6 @@ src_install () {
# Remove emacs files and install them in the
# correct place if use emacs
-
rm -rf "${D}"/usr/share/emacs/site-lisp
if use emacs; then
cd "${S}/Macaulay2/emacs"
@@ -146,6 +133,7 @@ pkg_postinst() {
elog "in order to set it to F12 (or choose a different one)."
fi
}
+
pkg_postrm() {
use emacs && elisp-site-regen
}
diff --git a/sci-mathematics/Macaulay2/Manifest b/sci-mathematics/Macaulay2/Manifest
index 75fe514c2..f94de1693 100644
--- a/sci-mathematics/Macaulay2/Manifest
+++ b/sci-mathematics/Macaulay2/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
AUX 1.4-paths-of-external-programs.patch 3175 RMD160 ad0f634b52b3fe883e49a53815481ca5b73d93c3 SHA1 4644c4b8c64678ca8205515436666651f467ee58 SHA256 162823069e075d7b7712db841d8c7bb8e1f03f2c33d4ade18e0b7a20543f5230
AUX 70Macaulay2-gentoo.el 597 RMD160 bdf3a30bb4d15a77e0dff86c866134d06c443fa0 SHA1 d4a4036042ab13bc20d8be90b559e9168bfc0ef5 SHA256 e5583d11e6ab662261abb32e90fcf31ccf6bd56f2b23b691b9255d1b8d8acb2f
AUX 9999-paths-of-external-programs.patch 3175 RMD160 ad0f634b52b3fe883e49a53815481ca5b73d93c3 SHA1 4644c4b8c64678ca8205515436666651f467ee58 SHA256 162823069e075d7b7712db841d8c7bb8e1f03f2c33d4ade18e0b7a20543f5230
@@ -10,6 +13,15 @@ DIST gc-7.2alpha5-2010-09-03.tar.gz 1257818 RMD160 58954216c702add21e24eecb22252
DIST libfac-3-1-0.tar.gz 91544 RMD160 2500d402328ad532756c677015c1d01f8594e394 SHA1 d005ddd58a180b8a91fe5728b96bde515c5d9cc5 SHA256 fc3dda08f7ec039635f8d7f1629546f4ac7620a69cf9332ca39e29dd822aee7d
DIST libfac-3-1-1.tar.gz 90104 RMD160 8ca086ad2dc1dfbf3d8824e244f0b1af087eef62 SHA1 3753363a6f56cfeb0d0be3bdf471d6bd55c14ede SHA256 4c463af2d22375aa62be4fb1f9a32cada6723ca5e3ddbd8a4f5cab72b675e33a
EBUILD Macaulay2-1.3.1-r4.ebuild 3323 RMD160 685a9e92768a913984f4b75e47bebac2c988d9ac SHA1 0247845b210eeb7b4f2e92764a99ca88b570e16e SHA256 07baf8dfcdc3ed2cf92db4f0a2530a3f63269452eab42c7d128f13c23ecf5d04
-EBUILD Macaulay2-9999.ebuild 4055 RMD160 4195349b5bfc525bef1b399531511bc9441a1200 SHA1 c283f0520eb366dd6c274cd5dcacee903175ed12 SHA256 77b5f66d69613bd245c4c1393aacf1ca9f3d94768a052a3125c8b5781260d2d0
-MISC ChangeLog 3921 RMD160 cee65f0de8e5dce798b04438fa71a9b6e6ecd144 SHA1 ffdac64f8aff6827c3690e9350ed80529c4dcc0a SHA256 0a98bc20860e74e9d53e7087b9fb53470e284403e0d04c19c6561b22256931b5
+EBUILD Macaulay2-9999.ebuild 3759 RMD160 2477b5b00773fb51e1adf82518c9d4c19cd613a8 SHA1 c250ff61a79f392760d8c580018a7e0fbf4d42a3 SHA256 fb12322a4c5b42c0bbed63b71ff9baf278e207981f03d32df76b149e999aa106
+MISC ChangeLog 4014 RMD160 7f696c93e7940bfa66a4d5477977d8246dd20048 SHA1 e67c34dc33a3b5eb9b23d2b114c27bedb7ed7fb6 SHA256 bc5d258c9b0e37a81a214599a1f4d7e63ee713a3752bc79e711681dffaa8bd84
MISC metadata.xml 486 RMD160 0e913360cd4f3dd6b814bf44341c83005739a22b SHA1 83fb4a5ca743b184562281c8f1a5b8f722528514 SHA256 5937610a5ea0ddb9d15953121aa4f512f6ba8c2bcd35882a2dfe401f1dbddaa7
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iJwEAQEIAAYFAk1oox0ACgkQQYXt1pFHaaGmFgQAngjBsje23x01MNzseU2yj4rQ
+WMpPA6owEm/uwOG81yX5Ro7tnwee4mZfmFGEOR58N4ASXHLfgM4weM0DAgrb162P
+5CgFxGmkYKrvQPDKVF0+zy5kH7dV+cj/qpdMT2id+NjjgcOeEGmjOXZxXqhvK3gy
+60hR16p/0yPitRoTGlY=
+=oW0m
+-----END PGP SIGNATURE-----