aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcryos <cryos@32389bae-6d03-0410-99cf-db05cde120eb>2006-01-14 17:29:02 +0000
committercryos <cryos@32389bae-6d03-0410-99cf-db05cde120eb>2006-01-14 17:29:02 +0000
commitb95bde7b797900e94eab367eef0e41e8fd2f5465 (patch)
tree366c5ffa2f180fa02a1dcee39656225a06ed56ab /sci-mathematics/kseg/kseg-0.402.ebuild
parentadded package pygsl (diff)
downloadsci-b95bde7b797900e94eab367eef0e41e8fd2f5465.tar.gz
sci-b95bde7b797900e94eab367eef0e41e8fd2f5465.tar.bz2
sci-b95bde7b797900e94eab367eef0e41e8fd2f5465.zip
Several minor corrections and enhancements.
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@53 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-mathematics/kseg/kseg-0.402.ebuild')
-rw-r--r--sci-mathematics/kseg/kseg-0.402.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/sci-mathematics/kseg/kseg-0.402.ebuild b/sci-mathematics/kseg/kseg-0.402.ebuild
index b83069d6d..62711c73b 100644
--- a/sci-mathematics/kseg/kseg-0.402.ebuild
+++ b/sci-mathematics/kseg/kseg-0.402.ebuild
@@ -1,25 +1,24 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kseg/kseg-0.402.ebuild,v 1.1 2006/01/14 17:14:18 cryos Exp $
-inherit eutils
+inherit eutils qt3
-DESCRIPTION="Interactive geometry program for exploring Euclidean geometry."
+DESCRIPTION="Interactive geometry program for exploring Euclidean geometry"
HOMEPAGE="http://www.mit.edu/~ibaran/kseg.html"
-SRC_URI="http://www.mit.edu/~ibaran/${P}.tar.gz"
+SRC_URI="http://www.mit.edu/~ibaran/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND=">=x11-libs/qt-3.0.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+DEPEND="$(qt_min_version 3.3)"
src_unpack() {
unpack ${A}
cd ${S}
# Fix silly hardcoded help file path and CCFLAGS.
- # The help location has to be changed when changing
- # version. It is allways /usr/share/doc/${PF}/help
- epatch ${FILESDIR}/${PF}-gentoo.patch
+ epatch ${FILESDIR}/${P}-gentoo.patch
+ sed -i -e "s|KSEG_HELP_DIR|${PF}/help|" main.cpp
}
src_install() {
@@ -28,6 +27,8 @@ src_install() {
dodoc AUTHORS ChangeLog README README.translators VERSION
insinto /usr/share/doc/${PF}/help
doins *.html *.qm
- insinto /usr/share/doc/${PF}/examples
- doins examples/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
}