aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2010-02-12 06:11:05 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2010-02-12 06:11:05 +0000
commitc83206b892792fced87b4fb84d8d57763da10931 (patch)
tree99cd47362fa089620b3be9f9f2bc1d0b6c0ae9f4 /sci-mathematics/scilab/files
parentmpi goodness to hdf-java (diff)
downloadsci-c83206b892792fced87b4fb84d8d57763da10931.tar.gz
sci-c83206b892792fced87b4fb84d8d57763da10931.tar.bz2
sci-c83206b892792fced87b4fb84d8d57763da10931.zip
New patches for scilab
Diffstat (limited to 'sci-mathematics/scilab/files')
-rw-r--r--sci-mathematics/scilab/files/ImplicitPointerConversions.diff22
-rw-r--r--sci-mathematics/scilab/files/addchapter.diff16
-rw-r--r--sci-mathematics/scilab/files/adddemo.diff23
-rw-r--r--sci-mathematics/scilab/files/buildDocPT_BR.diff14
-rw-r--r--sci-mathematics/scilab/files/jgraphx-1.2.0.diff347
-rw-r--r--sci-mathematics/scilab/files/jhdf2.6.diff14
-rw-r--r--sci-mathematics/scilab/files/librarypath.diff57
-rw-r--r--sci-mathematics/scilab/files/missingaddchapter.diff25
-rw-r--r--sci-mathematics/scilab/files/modelicac-not-available.diff36
-rw-r--r--sci-mathematics/scilab/files/s390javadetection.diff14
-rw-r--r--sci-mathematics/scilab/files/scilab-5.2.0-java-heap.patch13
-rw-r--r--sci-mathematics/scilab/files/scilab-5.2.0-jeuclid-detect.patch59
12 files changed, 640 insertions, 0 deletions
diff --git a/sci-mathematics/scilab/files/ImplicitPointerConversions.diff b/sci-mathematics/scilab/files/ImplicitPointerConversions.diff
new file mode 100644
index 000000000..d1fc11924
--- /dev/null
+++ b/sci-mathematics/scilab/files/ImplicitPointerConversions.diff
@@ -0,0 +1,22 @@
+diff -Nur -x '*.orig' -x '*~' scilab-5.2.0/modules/fileio/sci_gateway/c/sci_copyfile.c scilab-5.2.0.new/modules/fileio/sci_gateway/c/sci_copyfile.c
+--- scilab-5.2.0/modules/fileio/sci_gateway/c/sci_copyfile.c 2009-12-16 08:24:45.000000000 +0100
++++ scilab-5.2.0.new/modules/fileio/sci_gateway/c/sci_copyfile.c 2010-01-18 13:22:03.360717656 +0100
+@@ -24,6 +24,7 @@
+ #include "isdir.h"
+ #include "splitpath.h"
+ #include "freeArrayOfString.h"
++#include "charEncoding.h"
+ /*--------------------------------------------------------------------------*/
+ static wchar_t* getFilenameWithExtension(wchar_t* wcFullFilename);
+ static void returnCopyFileResultOnStack(int ierr, char *fname);
+diff -Nur -x '*.orig' -x '*~' scilab-5.2.0/modules/fileio/sci_gateway/c/sci_movefile.c scilab-5.2.0.new/modules/fileio/sci_gateway/c/sci_movefile.c
+--- scilab-5.2.0/modules/fileio/sci_gateway/c/sci_movefile.c 2009-12-16 08:24:45.000000000 +0100
++++ scilab-5.2.0.new/modules/fileio/sci_gateway/c/sci_movefile.c 2010-01-18 13:21:09.540737969 +0100
+@@ -24,6 +24,7 @@
+ #include "isdir.h"
+ #include "splitpath.h"
+ #include "freeArrayOfString.h"
++#include "charEncoding.h"
+ /*--------------------------------------------------------------------------*/
+ static wchar_t* getFilenameWithExtensionForMove(wchar_t* wcFullFilename);
+ static void returnMoveFileResultOnStack(int ierr, char *fname);
diff --git a/sci-mathematics/scilab/files/addchapter.diff b/sci-mathematics/scilab/files/addchapter.diff
new file mode 100644
index 000000000..b2d71acd9
--- /dev/null
+++ b/sci-mathematics/scilab/files/addchapter.diff
@@ -0,0 +1,16 @@
+diff -Nur scilab-5.1.1.orig/modules/helptools/macros/add_module_help_chapter.sci scilab-5.1.1/modules/helptools/macros/add_module_help_chapter.sci
+--- scilab-5.1.1.orig/modules/helptools/macros/add_module_help_chapter.sci 2009-04-14 09:30:56.000000000 +0200
++++ scilab-5.1.1/modules/helptools/macros/add_module_help_chapter.sci 2009-04-14 18:07:23.000000000 +0200
+@@ -19,10 +19,8 @@
+ path_addchapter = SCI+"/modules/"+modulename+"/help/"+getdefaultlanguage()+"/addchapter.sce";
+ end
+
+- //try
++ if ( fileinfo(path_addchapter) <> [] ) then
+ exec(path_addchapter);
+- //catch
+- // warning(gettext("Incorrect module path ")+path_addchapter);
+- //end
++ end
+
+ endfunction \ No newline at end of file
diff --git a/sci-mathematics/scilab/files/adddemo.diff b/sci-mathematics/scilab/files/adddemo.diff
new file mode 100644
index 000000000..e8e7f1c55
--- /dev/null
+++ b/sci-mathematics/scilab/files/adddemo.diff
@@ -0,0 +1,23 @@
+diff -Nur scilab-5.1.1.orig/modules/core/macros/add_demo.sci scilab-5.1.1/modules/core/macros/add_demo.sci
+--- scilab-5.1.1.orig/modules/core/macros/add_demo.sci 2009-04-14 09:30:44.000000000 +0200
++++ scilab-5.1.1/modules/core/macros/add_demo.sci 2009-04-14 17:54:41.000000000 +0200
+@@ -17,9 +17,7 @@
+
+ path=pathconvert(path,%f,%t);
+
+- if fileinfo(path)==[] then
+- error(msprintf(gettext("%s: The file %s does not exist.\n"),"add_demo",path));
+- end
++ if fileinfo(path) <> [] then
+
+ if isdir(path) then
+ error(msprintf(gettext("%s: Wrong input argument #%d: Path to a scilab script file expected.\n"),"add_demo",2));
+@@ -33,7 +31,7 @@
+ k1=find(demolist(k,2)==path)
+ if k1==[] then demolist=[demolist;demotitle+" ("+string(size(k,"*"))+")",path],end
+ end
+-
++ end
+ clear demolist
+
+ endfunction \ No newline at end of file
diff --git a/sci-mathematics/scilab/files/buildDocPT_BR.diff b/sci-mathematics/scilab/files/buildDocPT_BR.diff
new file mode 100644
index 000000000..411e9e54a
--- /dev/null
+++ b/sci-mathematics/scilab/files/buildDocPT_BR.diff
@@ -0,0 +1,14 @@
+Index: scilab-5.2.0/Makefile.am
+===================================================================
+--- scilab-5.2.0.orig/Makefile.am 2010-02-03 16:08:18.000000000 +0100
++++ scilab-5.2.0/Makefile.am 2010-02-03 16:09:33.000000000 +0100
+@@ -151,6 +151,9 @@
+ echo "-- Building documentation (French) --"; \
+ echo "SCI_DISABLE_TK=1 SCI_JAVA_ENABLE_HEADLESS=1 DOCBOOK_ROOT=$(DOCBOOK_ROOT) $(top_builddir)/bin/scilab-adv-cli -nb -nouserstartup -e \"xmltojar([],[],'fr_FR');exit;\""; \
+ SCI_DISABLE_TK=1 SCI_JAVA_ENABLE_HEADLESS=1 DOCBOOK_ROOT=$(DOCBOOK_ROOT) $(top_builddir)/bin/scilab-adv-cli -nb -nouserstartup -e "xmltojar([],[],'fr_FR');exit;"; \
++ echo "-- Building documentation (portugues do Brasil) --"; \
++ echo "SCI_DISABLE_TK=1 SCI_JAVA_ENABLE_HEADLESS=1 DOCBOOK_ROOT=$(DOCBOOK_ROOT) $(top_builddir)/bin/scilab-adv-cli -nb -nouserstartup -e \"xmltojar([],[],'pt_BR');exit;\""; \
++ SCI_DISABLE_TK=1 SCI_JAVA_ENABLE_HEADLESS=1 DOCBOOK_ROOT=$(DOCBOOK_ROOT) $(top_builddir)/bin/scilab-adv-cli -nb -nouserstartup -e "xmltojar([],[],'pt_BR');exit;"; \
+ else \
+ echo "Cannot find Scilab-adv-cli binary"; \
+ fi
diff --git a/sci-mathematics/scilab/files/jgraphx-1.2.0.diff b/sci-mathematics/scilab/files/jgraphx-1.2.0.diff
new file mode 100644
index 000000000..311a2dc35
--- /dev/null
+++ b/sci-mathematics/scilab/files/jgraphx-1.2.0.diff
@@ -0,0 +1,347 @@
+Index: scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/graph/ScilabGraph.java
+===================================================================
+--- scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/graph/ScilabGraph.java 2010-01-22 16:43:29.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/graph/ScilabGraph.java 2010-01-22 16:44:22.000000000 +0100
+@@ -75,7 +75,7 @@
+ public void invoke(Object source, mxEventObject evt) {
+
+ if (!redoInAction) {
+- undoManager.undoableEditHappened((mxUndoableEdit) evt.getArgAt(0));
++ undoManager.undoableEditHappened((mxUndoableEdit) evt.getProperty("edit"));
+ incrementUndoCounter();
+ }
+ }
+@@ -86,7 +86,7 @@
+ */
+ mxIEventListener selectionHandler = new mxIEventListener() {
+ public void invoke(Object source, mxEventObject evt) {
+- List<mxUndoableChange> changes = ((mxUndoableEdit) evt.getArgAt(0)).getChanges();
++ List<mxUndoableChange> changes = ((mxUndoableEdit) evt.getProperty("edit")).getChanges();
+ setSelectionCells(getSelectionCellsForChanges(changes));
+ }
+ };
+@@ -209,10 +209,12 @@
+ * com.mxgraph.util.mxUndoManager
+ */
+ public void redo() {
++ if (!redoInAction) {
+ incrementUndoCounter();
+ redoInAction = true;
+ undoManager.redo();
+ redoInAction = false;
++ }
+ }
+
+ /**
+Index: scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/actions/ShowHideShadowAction.java
+===================================================================
+--- scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/actions/ShowHideShadowAction.java 2010-01-22 16:55:10.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/actions/ShowHideShadowAction.java 2010-01-22 16:55:42.000000000 +0100
+@@ -63,11 +63,15 @@
+ if (allCells[i] instanceof BasicBlock) {
+ //((BasicBlock) allCells[i])
+ mxCellState state = getGraph(null).getView().getState(allCells[i]);
+- Hashtable<String, Object> style = (state != null) ? state.getStyle() : getGraph(null).getCellStyle(allCells[i]);
+-
++ Map<String, Object> style;
++ if (state != null) {
++ style = state.getStyle();
++ } else {
++ style = getGraph(null).getCellStyle(allCells[i]);
++ }
+ if (style != null)
+ {
+- String value = (mxUtils.isTrue(style, mxConstants.STYLE_SHADOW, false)) ? "0" : "1";
++ String value = Boolean.toString(mxUtils.isTrue(style, mxConstants.STYLE_SHADOW, false));
+ getGraph(null).setCellStyles(mxConstants.STYLE_SHADOW, value, new Object[] { allCells[i] });
+ }
+ }
+Index: scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/utils/XcosCanvas.java
+===================================================================
+--- scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/utils/XcosCanvas.java 2010-01-22 16:55:52.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/utils/XcosCanvas.java 2010-01-22 16:57:58.000000000 +0100
+@@ -17,7 +17,7 @@
+ public class XcosCanvas extends mxInteractiveCanvas{
+
+ public Object drawVertex(int x, int y, int w, int h,
+- Hashtable<String, Object> style) {
++ Map<String, Object> style) {
+
+ if (g != null)
+ {
+@@ -90,7 +90,7 @@
+ start = (int) Math.round(start * scale);
+
+ // Removes some styles to draw the content area
+- Hashtable<String, Object> cloned = new Hashtable<String, Object>(
++ Map<String, Object> cloned = new Hashtable<String, Object>(
+ style);
+ cloned.remove(mxConstants.STYLE_FILLCOLOR);
+ cloned.remove(mxConstants.STYLE_ROUNDED);
+diff -ur scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/BasicBlock.java scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/BasicBlock.java
+--- scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/BasicBlock.java 2009-12-16 08:25:20.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/BasicBlock.java 2010-01-22 16:45:37.000000000 +0100
+@@ -562,7 +562,7 @@
+ */
+ if (getParentDiagram() instanceof SuperBlockDiagram) {
+ SuperBlock parentBlock = ((SuperBlockDiagram) getParentDiagram()).getContainer();
+- parentBlock.getParentDiagram().fireEvent(XcosEvent.SUPER_BLOCK_UPDATED,new mxEventObject(new Object[] { parentBlock }));
++ parentBlock.getParentDiagram().fireEvent(new mxEventObject(XcosEvent.SUPER_BLOCK_UPDATED, "block", parentBlock));
+ }
+
+ }
+@@ -606,7 +606,7 @@
+ // Now read new Block
+ BasicBlock modifiedBlock = BlockReader.readBlockFromFile(tempInput.getAbsolutePath());
+ updateBlockSettings(modifiedBlock);
+- getParentDiagram().fireEvent(XcosEvent.ADD_PORTS, new mxEventObject(new Object[] {currentBlock}));
++ getParentDiagram().fireEvent(new mxEventObject(XcosEvent.ADD_PORTS, "block", currentBlock));
+ setLocked(false);
+ }
+ };
+Seulement dans scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/: BasicBlock.java.orig
+Seulement dans scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/: BasicBlock.java.rej
+diff -ur scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/EventInBlock.java scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/EventInBlock.java
+--- scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/EventInBlock.java 2009-12-16 08:25:20.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/EventInBlock.java 2010-01-22 16:47:03.000000000 +0100
+@@ -51,7 +51,7 @@
+ double newValue = ((ScilabDouble)getIntegerParameters()).getRealPart()[0][0];
+
+ if(oldValue != newValue){
+- getParentDiagram().fireEvent(XcosEvent.IN_EVENT_VALUE_UPDATED, new mxEventObject(new Object[]{oldValue,newValue}));
++ getParentDiagram().fireEvent(new mxEventObject(XcosEvent.IN_EVENT_VALUE_UPDATED, "old", oldValue, "new", newValue));
+ }
+ }
+
+diff -ur scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/EventOutBlock.java scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/EventOutBlock.java
+--- scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/EventOutBlock.java 2009-12-16 08:25:20.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/EventOutBlock.java 2010-01-22 16:47:19.000000000 +0100
+@@ -51,7 +51,7 @@
+ double newValue = ((ScilabDouble)getIntegerParameters()).getRealPart()[0][0];
+
+ if(oldValue != newValue){
+- getParentDiagram().fireEvent(XcosEvent.OUT_EVENT_VALUE_UPDATED, new mxEventObject(new Object[]{oldValue,newValue}));
++ getParentDiagram().fireEvent(new mxEventObject(XcosEvent.OUT_EVENT_VALUE_UPDATED, "old", oldValue, "new", newValue));
+ }
+ }
+
+diff -ur scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/ExplicitInBlock.java scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/ExplicitInBlock.java
+--- scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/ExplicitInBlock.java 2009-12-16 08:25:20.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/ExplicitInBlock.java 2010-01-22 16:48:57.000000000 +0100
+@@ -50,7 +50,7 @@
+ double newValue = ((ScilabDouble)getIntegerParameters()).getRealPart()[0][0];
+
+ if(oldValue != newValue){
+- getParentDiagram().fireEvent(XcosEvent.IN_EXPLICIT_VALUE_UPDATED, new mxEventObject(new Object[]{oldValue,newValue}));
++ getParentDiagram().fireEvent(new mxEventObject(XcosEvent.IN_EXPLICIT_VALUE_UPDATED, "old", oldValue, "new", newValue));
+ }
+ }
+
+diff -ur scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/ExplicitOutBlock.java scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/ExplicitOutBlock.java
+--- scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/ExplicitOutBlock.java 2009-12-16 08:25:20.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/ExplicitOutBlock.java 2010-01-22 16:49:18.000000000 +0100
+@@ -51,7 +51,7 @@
+ double newValue = ((ScilabDouble)getIntegerParameters()).getRealPart()[0][0];
+
+ if(oldValue != newValue){
+- getParentDiagram().fireEvent(XcosEvent.OUT_EXPLICIT_VALUE_UPDATED, new mxEventObject(new Object[]{oldValue,newValue}));
++ getParentDiagram().fireEvent(new mxEventObject(XcosEvent.OUT_EXPLICIT_VALUE_UPDATED, "old", oldValue, "new", newValue));
+ }
+ }
+
+diff -ur scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/ImplicitInBlock.java scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/ImplicitInBlock.java
+--- scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/ImplicitInBlock.java 2009-12-16 08:25:20.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/ImplicitInBlock.java 2010-01-22 16:49:36.000000000 +0100
+@@ -51,7 +51,7 @@
+ double newValue = ((ScilabDouble)getIntegerParameters()).getRealPart()[0][0];
+
+ if(oldValue != newValue){
+- getParentDiagram().fireEvent(XcosEvent.IN_IMPLICIT_VALUE_UPDATED, new mxEventObject(new Object[]{oldValue,newValue}));
++ getParentDiagram().fireEvent(new mxEventObject(XcosEvent.IN_IMPLICIT_VALUE_UPDATED, "old", oldValue, "new", newValue));
+ }
+ }
+
+diff -ur scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/ImplicitOutBlock.java scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/ImplicitOutBlock.java
+--- scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/ImplicitOutBlock.java 2009-12-16 08:25:20.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/ImplicitOutBlock.java 2010-01-22 16:49:52.000000000 +0100
+@@ -51,7 +51,7 @@
+ double newValue = ((ScilabDouble)getIntegerParameters()).getRealPart()[0][0];
+
+ if(oldValue != newValue){
+- getParentDiagram().fireEvent(XcosEvent.OUT_IMPLICIT_VALUE_UPDATED, new mxEventObject(new Object[]{oldValue,newValue}));
++ getParentDiagram().fireEvent(new mxEventObject(XcosEvent.OUT_IMPLICIT_VALUE_UPDATED, "old", oldValue, "new", newValue));
+ }
+ }
+
+Seulement dans scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/: io
+diff -ur scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/SuperBlock.java scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/SuperBlock.java
+--- scilab-5.2.0.orig/modules/xcos/src/java/org/scilab/modules/xcos/block/SuperBlock.java 2009-12-16 08:25:20.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/SuperBlock.java 2010-01-22 16:46:14.000000000 +0100
+@@ -386,7 +386,7 @@
+ updateExportedExplicitOutputPort();
+ updateExportedImplicitOutputPort();
+ updateExportedEventOutputPort();
+- getParentDiagram().fireEvent(XcosEvent.SUPER_BLOCK_UPDATED, new mxEventObject(new Object[] {this}));
++ getParentDiagram().fireEvent(new mxEventObject(XcosEvent.SUPER_BLOCK_UPDATED, "block", this));
+ }
+
+
+Seulement dans scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/: SuperBlock.java.orig
+Seulement dans scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/block/: SuperBlock.java.rej
+--- scilab-5.2.0.obsolete.0.714259042478265/modules/xcos/src/java/org/scilab/modules/xcos/utils/XcosCanvas.java 2010-01-23 22:49:59.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/utils/XcosCanvas.java 2010-01-23 23:32:57.000000000 +0100
+@@ -7,6 +7,7 @@
+ import java.awt.Stroke;
+ import java.awt.geom.AffineTransform;
+ import java.util.Hashtable;
++import java.util.Map;
+
+ import com.mxgraph.swing.view.mxInteractiveCanvas;
+ import com.mxgraph.util.mxConstants;
+--- scilab-5.2.0.obsolete.0.714259042478265/modules/xcos/src/java/org/scilab/modules/xcos/palette/XcosPalette.java 2009-12-16 08:25:20.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/palette/XcosPalette.java 2010-01-24 00:01:43.000000000 +0100
+@@ -187,8 +187,9 @@
+ selectedEntry.setOpaque(true);
+ }
+
+- eventSource.fireEvent(mxEvent.SELECT, new mxEventObject(new Object[] {
+- selectedEntry, t, last }));
++
++ eventSource.fireEvent(new mxEventObject(mxEvent.SELECT, "entry",
++ selectedEntry, "transferable", t, "previous", last));
+ }
+
+
+--- scilab-5.2.0.obsolete.0.714259042478265/modules/xcos/src/java/org/scilab/modules/xcos/actions/ShowHideShadowAction.java 2010-01-23 22:49:59.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/actions/ShowHideShadowAction.java 2010-01-23 23:59:58.000000000 +0100
+@@ -13,6 +13,7 @@
+ package org.scilab.modules.xcos.actions;
+
+ import java.util.Hashtable;
++import java.util.Map;
+
+ import org.scilab.modules.graph.ScilabGraph;
+ import org.scilab.modules.graph.actions.DefaultAction;
+--- scilab-5.2.0.obsolete.0.714259042478265/modules/xcos/src/java/org/scilab/modules/xcos/graph/XcosDiagram.java 2009-12-16 08:25:20.000000000 +0100
++++ scilab-5.2.0/modules/xcos/src/java/org/scilab/modules/xcos/graph/XcosDiagram.java 2010-01-23 23:57:56.000000000 +0100
+@@ -625,7 +625,7 @@
+ public void invoke(Object source, mxEventObject evt) {
+ getModel().beginUpdate();
+ refresh();
+- BasicBlock updatedBlock = (BasicBlock) evt.getArgAt(0);
++ BasicBlock updatedBlock = (BasicBlock) evt.getProperty("block");
+ BlockPositioning.updateBlockView(updatedBlock);
+ getModel().endUpdate();
+ }
+@@ -639,7 +639,7 @@
+ */
+ private class ModelTracker implements mxIEventListener {
+ public void invoke(Object source, mxEventObject evt) {
+- List<mxUndoableChange> changes = (List<mxUndoableChange>) evt.getArgAt(0);
++ List<mxUndoableChange> changes = (List<mxUndoableChange>) evt.getProperty("changes");
+ List<Object> objects = new ArrayList<Object>();
+ getModel().beginUpdate();
+ for (int i = 0; i < changes.size(); ++i) {
+@@ -660,7 +660,8 @@
+ firedCells[j] = objects.get(j);
+ }
+ //fireEvent(XcosEvent.FORCE_CELL_RESHAPE, new mxEventObject(new Object[] {firedCells}));
+- fireEvent(XcosEvent.FORCE_CELL_VALUE_UPDATE, new mxEventObject(new Object[] {firedCells}));
++ fireEvent(new mxEventObject(XcosEvent.FORCE_CELL_VALUE_UPDATE, "cells", firedCells));
++
+ }
+ getModel().endUpdate();
+ }
+@@ -671,7 +672,7 @@
+ */
+ private class ForceCellValueUpdate implements mxIEventListener {
+ public void invoke(Object source, mxEventObject evt) {
+- Object[] cells = (Object[]) evt.getArgs()[0];
++ Object[] cells = (Object[]) evt.getProperty("cells");
+
+ getModel().beginUpdate();
+
+@@ -704,7 +705,7 @@
+ */
+ private class ForceCellReshapeTracker implements mxIEventListener {
+ public void invoke(Object source, mxEventObject evt) {
+- Object[] cells = (Object[]) evt.getArgs()[0];
++ Object[] cells = (Object[]) evt.getProperty("cells");
+ getModel().beginUpdate();
+ for (int i = 0; i < cells.length; ++i) {
+ Object cell = cells[i];
+@@ -723,16 +724,15 @@
+ */
+ private class SuperBlockUpdateTracker implements mxIEventListener {
+ public void invoke(Object source, mxEventObject evt) {
+- assert evt.getArgs()[0] instanceof SuperBlock;
+- SuperBlock updatedBlock = (SuperBlock) evt.getArgs()[0];
++ assert evt.getProperty("block") instanceof SuperBlock;
++ SuperBlock updatedBlock = (SuperBlock) evt.getProperty("block");
+ updatedBlock.setRealParameters(BlockWriter
+ .convertDiagramToMList(updatedBlock.getChild()));
+ if (updatedBlock.getParentDiagram() instanceof SuperBlockDiagram) {
+ SuperBlock parentBlock = ((SuperBlockDiagram) updatedBlock
+ .getParentDiagram()).getContainer();
+- parentBlock.getParentDiagram().fireEvent(
+- XcosEvent.SUPER_BLOCK_UPDATED,
+- new mxEventObject(new Object[] { parentBlock }));
++ parentBlock.getParentDiagram().fireEvent(new mxEventObject(XcosEvent.SUPER_BLOCK_UPDATED,"block", parentBlock));
++
+ }
+ BlockPositioning.updateBlockView(updatedBlock);
+ refresh();
+@@ -751,7 +751,7 @@
+ }
+
+ public void invoke(Object source, mxEventObject evt) {
+- Object[] cells = (Object[]) evt.getArgs()[0];
++ Object[] cells = (Object[]) evt.getProperty("cells");
+
+ diagram.getModel().beginUpdate();
+ for (int i = 0; i < cells.length; ++i) {
+@@ -782,7 +782,7 @@
+ }
+
+ public void invoke(Object source, mxEventObject evt) {
+- Object[] cells = (Object[]) evt.getArgs()[0];
++ Object[] cells = (Object[]) evt.getProperty("cells");
+ for (int i = 0; i < cells.length; i++) {
+ if (cells[i] instanceof BasicLink) {
+ BasicLink link = (BasicLink) cells[i];
+@@ -900,7 +900,7 @@
+ */
+ private class CellResizedTracker implements mxIEventListener {
+ public void invoke(Object source, mxEventObject evt) {
+- Object[] cells = (Object[]) evt.getArgs()[0];
++ Object[] cells = (Object[]) evt.getProperty("cells");
+ getModel().beginUpdate();
+ for (int i = 0; i < cells.length; ++i) {
+ if (cells[i] instanceof BasicBlock) {
+@@ -916,7 +916,7 @@
+ */
+ private class UndoUpdateTracker implements mxIEventListener {
+ public void invoke(Object source, mxEventObject evt) {
+- List<mxUndoableChange> changes = ((mxUndoableEdit) evt.getArgAt(0)).getChanges();
++ List<mxUndoableChange> changes = ((mxUndoableEdit) evt.getProperty("edit")).getChanges();
+ Object[] changedCells = getSelectionCellsForChanges(changes);
+ getModel().beginUpdate();
+ for (Object object : changedCells) {
+@@ -1712,7 +1712,7 @@
+ //getParentTab().setName((String) properties.get("title"));
+
+ // Clear all undo events in Undo Manager
+- undoManager.reset();
++ undoManager.clear();
+ setModified(false);
+ }
+
+@@ -2051,7 +2051,7 @@
+ * This function will reset the UndoManager in a stable state.
+ */
+ public void resetUndoManager() {
+- undoManager.reset();
++ undoManager.clear();
+
+ resetUndoCounter();
+
diff --git a/sci-mathematics/scilab/files/jhdf2.6.diff b/sci-mathematics/scilab/files/jhdf2.6.diff
new file mode 100644
index 000000000..034e98c93
--- /dev/null
+++ b/sci-mathematics/scilab/files/jhdf2.6.diff
@@ -0,0 +1,14 @@
+Index: scilab-5.2.0/modules/hdf5/src/java/org/scilab/modules/hdf5/read/H5Read.java
+===================================================================
+--- scilab-5.2.0.orig/modules/hdf5/src/java/org/scilab/modules/hdf5/read/H5Read.java 2010-01-23 22:51:12.000000000 +0100
++++ scilab-5.2.0/modules/hdf5/src/java/org/scilab/modules/hdf5/read/H5Read.java 2010-01-23 22:51:41.000000000 +0100
+@@ -53,7 +53,8 @@
+ int nb_objs = H5.H5Gn_members(fileId, groupName);
+ String[] allObjectsName = new String[nb_objs];
+ int[] allObjectsType = new int[nb_objs];
+- H5.H5Gget_obj_info_all(fileId, groupName, allObjectsName, allObjectsType);
++ long[] refs = new long[nb_objs];
++ H5.H5Gget_obj_info_all(fileId, groupName, allObjectsName, allObjectsType, refs);
+
+ for (int i = 0 ; i < nb_objs ; ++i) {
+ if (allObjectsType[i] == HDF5Constants.H5G_DATASET) {
diff --git a/sci-mathematics/scilab/files/librarypath.diff b/sci-mathematics/scilab/files/librarypath.diff
new file mode 100644
index 000000000..ec6f3e3a4
--- /dev/null
+++ b/sci-mathematics/scilab/files/librarypath.diff
@@ -0,0 +1,57 @@
+--- bin/scilab.orig 2009-02-13 10:12:45.000000000 +0100
++++ bin/scilab 2009-02-13 10:14:06.000000000 +0100
+@@ -439,7 +439,7 @@
+ #export PVM_ARCH
+
+ SCILIB=$SCI/bin:$SCI/lib/scilab/:$SCI/lib64/scilab/
+-LD_LIBRARY_PATH=$SCILIB${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
++#LD_LIBRARY_PATH=$SCILIB${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
+
+ case $OS in
+ *darwin* | *Darwin*) # MacOS X
+@@ -453,6 +453,7 @@
+ *)
+ esac
+
++LD_LIBRARY_PATH=/usr/lib/scilab/:/usr/lib64/scilab/:$LD_LIBRARY_PATH
+
+ if test $SCIVERBOSE -ne 0; then
+ echo "LD_LIBRARY_PATH : $LD_LIBRARY_PATH"
+--- bin/scilab-cli.orig 2009-02-13 10:12:45.000000000 +0100
++++ bin/scilab-cli 2009-02-13 10:14:06.000000000 +0100
+@@ -439,7 +439,7 @@
+ #export PVM_ARCH
+
+ SCILIB=$SCI/bin:$SCI/lib/scilab/:$SCI/lib64/scilab/
+-LD_LIBRARY_PATH=$SCILIB${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
++#LD_LIBRARY_PATH=$SCILIB${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
+
+ case $OS in
+ *darwin* | *Darwin*) # MacOS X
+@@ -453,6 +453,7 @@
+ *)
+ esac
+
++LD_LIBRARY_PATH=/usr/lib/scilab/:/usr/lib64/scilab/:$LD_LIBRARY_PATH
+
+ if test $SCIVERBOSE -ne 0; then
+ echo "LD_LIBRARY_PATH : $LD_LIBRARY_PATH"
+--- bin/scilab-adv-cli.orig 2009-02-13 10:12:45.000000000 +0100
++++ bin/scilab-adv-cli 2009-02-13 10:14:06.000000000 +0100
+@@ -439,7 +439,7 @@
+ #export PVM_ARCH
+
+ SCILIB=$SCI/bin:$SCI/lib/scilab/:$SCI/lib64/scilab/
+-LD_LIBRARY_PATH=$SCILIB${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
++#LD_LIBRARY_PATH=$SCILIB${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
+
+ case $OS in
+ *darwin* | *Darwin*) # MacOS X
+@@ -453,6 +453,7 @@
+ *)
+ esac
+
++LD_LIBRARY_PATH=/usr/lib/scilab/:/usr/lib64/scilab/:$LD_LIBRARY_PATH
+
+ if test $SCIVERBOSE -ne 0; then
+ echo "LD_LIBRARY_PATH : $LD_LIBRARY_PATH"
diff --git a/sci-mathematics/scilab/files/missingaddchapter.diff b/sci-mathematics/scilab/files/missingaddchapter.diff
new file mode 100644
index 000000000..5b9635939
--- /dev/null
+++ b/sci-mathematics/scilab/files/missingaddchapter.diff
@@ -0,0 +1,25 @@
+commit aad7b644ccc97638598c2831d550edb51bdb13f1
+Author: Sylvestre Ledru <sylvestre.ledru@scilab.org>
+Date: Mon Apr 27 15:16:20 2009 +0200
+
+ Missing addchapter.sce
+
+diff --git a/scilab/modules/call_scilab/help/en_US/addchapter.sce b/scilab/modules/call_scilab/help/en_US/addchapter.sce
+new file mode 100644
+index 0000000..29d4a54
+--- /dev/null
++++ b/scilab/modules/call_scilab/help/en_US/addchapter.sce
+@@ -0,0 +1,13 @@
++// Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
++// Copyright (C) 2007-2008 - INRIA - Allan CORNET
++// Copyright (C) 2009 - DIGITEO
++//
++// This file must be used under the terms of the CeCILL.
++// This source file is licensed as described in the file COPYING, which
++// you should have received as part of this distribution. The terms
++// are also available at
++// http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
++
++path = SCI+"/modules/call_scilab/help/en_US";
++add_help_chapter("call_scilab API",path,%T);
++clear path add_help_chapter;
diff --git a/sci-mathematics/scilab/files/modelicac-not-available.diff b/sci-mathematics/scilab/files/modelicac-not-available.diff
new file mode 100644
index 000000000..2e3bea788
--- /dev/null
+++ b/sci-mathematics/scilab/files/modelicac-not-available.diff
@@ -0,0 +1,36 @@
+diff -ur scilab-5.1.1.orig/modules/scicos/macros/scicos_scicos/build_block.sci scilab-5.1.1/modules/scicos/macros/scicos_scicos/build_block.sci
+--- scilab-5.1.1.orig/modules/scicos/macros/scicos_scicos/build_block.sci 2009-04-14 09:31:05.000000000 +0200
++++ scilab-5.1.1/modules/scicos/macros/scicos_scicos/build_block.sci 2009-04-30 11:28:37.000000000 +0200
+@@ -72,7 +72,7 @@
+ //++ Check that modelica compiler is available
+ //++ Otherwise, give some feedback and quit
+ if ~with_modelica_compiler() then
+- messagebox(sprintf(gettext("%s: Error: Modelica compiler (MODELICAC) is unavailable."), "build_block"),"modal","error");
++ messagebox(sprintf(gettext("%s: Error: Modelica compiler (MODELICAC) is unavailable.")+" This is probably due to the non support of ocamlopt on your architecture.", "build_block"),"modal","error");
+ ok = %f
+ end
+
+diff -ur scilab-5.1.1.orig/modules/scicos/macros/scicos_scicos/MODCOM.sci scilab-5.1.1/modules/scicos/macros/scicos_scicos/MODCOM.sci
+--- scilab-5.1.1.orig/modules/scicos/macros/scicos_scicos/MODCOM.sci 2009-04-14 09:31:05.000000000 +0200
++++ scilab-5.1.1/modules/scicos/macros/scicos_scicos/MODCOM.sci 2009-04-30 11:28:37.000000000 +0200
+@@ -80,7 +80,7 @@
+ //++ Check that modelica compiler is available
+ //++ Otherwise, give some feedback and quit
+ if ~with_modelica_compiler() then
+- messagebox(sprintf(gettext("%s: Error: Modelica compiler (MODELICAC) is unavailable."), "MODCOM"),"modal","error");
++ messagebox(sprintf(gettext("%s: Error: Modelica compiler (MODELICAC) is unavailable.")+" This is probably due to the non support of ocamlopt on your architecture.", "MODCOM"),"modal","error");
+ ok = %f
+ break
+ end
+diff -ur scilab-5.1.1.orig/modules/scicos/macros/scicos_scicos/genmoc.sci scilab-5.1.1/modules/scicos/macros/scicos_scicos/genmoc.sci
+--- scilab-5.1.1.orig/modules/scicos/macros/scicos_scicos/genmoc.sci 2009-11-09 15:53:03.000000000 +0100
++++ scilab-5.1.1/modules/scicos/macros/scicos_scicos/genmoc.sci 2009-11-09 15:53:37.000000000 +0100
+@@ -29,7 +29,7 @@
+ //++ Check that modelica compiler is available
+ //++ Otherwise, give some feedback and quit
+ if ~with_modelica_compiler() then
+- error(sprintf(gettext("%s: Error: Modelica compiler (MODELICAC) is unavailable."), "genmoc"))
++ error(sprintf(gettext("%s: Error: Modelica compiler (MODELICAC) is unavailable.\n")+" This is probably due to the non support of ocamlopt on your architecture.", "genmoc"))
+ return
+ end
+
diff --git a/sci-mathematics/scilab/files/s390javadetection.diff b/sci-mathematics/scilab/files/s390javadetection.diff
new file mode 100644
index 000000000..940f2299f
--- /dev/null
+++ b/sci-mathematics/scilab/files/s390javadetection.diff
@@ -0,0 +1,14 @@
+diff --git a/scilab/m4/java.m4 b/scilab/m4/java.m4
+index 294de10..52c571f 100644
+--- a/scilab/m4/java.m4
++++ b/scilab/m4/java.m4
+@@ -425,6 +425,9 @@ AC_DEFUN([AC_JAVA_JNI_LIBS], [
+ powerpc|ppc64)
+ machine=ppc
+ ;;
++ s390x) # s390 arch can also returns s390x
++ machine=s390
++ ;;
+ esac
+
+ # Check for known JDK installation layouts
diff --git a/sci-mathematics/scilab/files/scilab-5.2.0-java-heap.patch b/sci-mathematics/scilab/files/scilab-5.2.0-java-heap.patch
new file mode 100644
index 000000000..c72139d6c
--- /dev/null
+++ b/sci-mathematics/scilab/files/scilab-5.2.0-java-heap.patch
@@ -0,0 +1,13 @@
+--- etc/jvm_options.xml.in.orig 2010-02-07 03:10:09.552580163 +0100
++++ etc/jvm_options.xml.in 2010-02-07 03:10:39.474580024 +0100
+@@ -22,8 +22,8 @@
+ <!-- ENABLE Just In Time java compiler -->
+ <option value="-Djava.compiler=JIT"/>
+
+-<!-- Set Java Heap space to 256mb -->
+-<option value="-Xmx256m"/>
++<!-- Set Java Heap space to 512mb -->
++<option value="-Xmx512m"/>
+
+ <option value="-Dapple.laf.useScreenMenuBar=true" os="macosx" />
+
diff --git a/sci-mathematics/scilab/files/scilab-5.2.0-jeuclid-detect.patch b/sci-mathematics/scilab/files/scilab-5.2.0-jeuclid-detect.patch
new file mode 100644
index 000000000..3fa9b8e7d
--- /dev/null
+++ b/sci-mathematics/scilab/files/scilab-5.2.0-jeuclid-detect.patch
@@ -0,0 +1,59 @@
+commit 4c717f20ae5630557ce8dfee8bd31df0c3d80a25
+Author: Sylvestre Ledru <sylvestre.ledru@scilab.org>
+Date: Thu Feb 4 16:59:13 2010 +0100
+
+ * bug 5496 fixed - When the option --disable-build-help was enabled, the
+ check/use of jeuclid was disabled. It was causing build
+ issue since jeuclid is now necessary for graphics.
+
+diff --git a/scilab/configure.ac b/scilab/configure.ac
+index 4e53006..71c39af 100644
+--- a/scilab/configure.ac
++++ b/scilab/configure.ac
+@@ -749,6 +749,14 @@ if test "$with_javasci" != no -o "$with_gui" != no -o "$enable_build_help" != no
+ JROSETTA_ENGINE=$PACKAGE_JAR_FILE
+ AC_SUBST(JROSETTA_ENGINE)
+
++
++ # MathML rendering solution
++ # Used in both graphic & help
++ AC_JAVA_CHECK_PACKAGE([jeuclid-core],[net.sourceforge.jeuclid.LayoutContext],[MathML rendering solution (at least version 3.1.X)])
++ JEUCLID_CORE=$PACKAGE_JAR_FILE
++ AC_SUBST(JEUCLID_CORE)
++
++
+ if test $HDF5_ENABLE = yes; then
+ # HDF5 java lib
+ AC_JAVA_CHECK_PACKAGE([jhdf5],[ncsa.hdf.hdf5lib.HDF5Constants],[HDF5 Java library])
+@@ -1772,7 +1780,6 @@ if test $HELP_ENABLE = yes; then
+ echo " Batik (SVG) ............ = $BATIK"
+ echo " Saxon XSLT ............. = $SAXON"
+ echo " FOP (XML => PDF) ....... = $FOP"
+- echo " Jeuclid (MathML) ....... = $JEUCLID_CORE"
+ echo " Commons I/O ............ = $COMMONS_IO"
+ echo " XML graphics commons ... = $XMLGRAPHICS_COMMONS"
+ echo " XML commons external ... = $XML_APIS_EXT"
+@@ -1807,6 +1814,7 @@ echo " JOGL ................ = $JOGL"
+ echo " JOGL LIBS (JNI) ..... = $JOGL_LIBS"
+ echo " Gluegen ............. = $GLUEGEN_RT"
+ echo " Gluegen LIBS (JNI) .. = $GLUEGEN_RT_LIBS"
++echo " Jeuclid (MathML) .... = $JEUCLID_CORE"
+ echo " Jhall .............. = $JHALL"
+ echo " Jrosetta (API) ...... = $JROSETTA_API"
+ echo " Jrosetta (Engine) ... = $JROSETTA_ENGINE"
+diff --git a/scilab/m4/docbook.m4 b/scilab/m4/docbook.m4
+index e017774..7fbbcca 100644
+--- a/scilab/m4/docbook.m4
++++ b/scilab/m4/docbook.m4
+@@ -54,11 +54,6 @@ AC_ARG_WITH(docbook,
+ FOP=$PACKAGE_JAR_FILE
+ AC_SUBST(FOP)
+
+- # MathML rendering solution
+- AC_JAVA_CHECK_PACKAGE([jeuclid-core],[net.sourceforge.jeuclid.LayoutContext],[MathML rendering solution (at least version 3.1.X)])
+- JEUCLID_CORE=$PACKAGE_JAR_FILE
+- AC_SUBST(JEUCLID_CORE)
+-
+ # Commons I/O library
+ AC_JAVA_CHECK_PACKAGE([commons-io],[org.apache.commons.io.output.CountingOutputStream],[Commons I/O library])
+ COMMONS_IO=$PACKAGE_JAR_FILE