aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortulku <tulku@32389bae-6d03-0410-99cf-db05cde120eb>2006-04-14 23:48:58 +0000
committertulku <tulku@32389bae-6d03-0410-99cf-db05cde120eb>2006-04-14 23:48:58 +0000
commitc46fa52457e383e491bd0ac3c3cedca5dd9f2bb2 (patch)
tree53a276bafbf6f32c9714459e92bb7e48ac45af7b /sci-mathematics/wxmaxima/wxmaxima-0.6.4-r1.ebuild
parentMoved to the main portage tree. (diff)
downloadsci-c46fa52457e383e491bd0ac3c3cedca5dd9f2bb2.tar.gz
sci-c46fa52457e383e491bd0ac3c3cedca5dd9f2bb2.tar.bz2
sci-c46fa52457e383e491bd0ac3c3cedca5dd9f2bb2.zip
Fixed documentation issue
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@167 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-mathematics/wxmaxima/wxmaxima-0.6.4-r1.ebuild')
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-0.6.4-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/wxmaxima-0.6.4-r1.ebuild b/sci-mathematics/wxmaxima/wxmaxima-0.6.4-r1.ebuild
new file mode 100644
index 000000000..de57ba55b
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-0.6.4-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+MYP=wxMaxima-${PV}
+
+DESCRIPTION="A Graphical frontend to Maxima, using the wxWidgets toolkit."
+HOMEPAGE="http://wxmaxima.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static doc"
+
+DEPEND=">=dev-libs/libxml2-2.5.0
+ >=x11-libs/wxGTK-2.6"
+RDEPEND=">=sci-mathematics/maxima-5.9.2"
+
+S=${WORKDIR}/${MYP}
+
+src_unpack () {
+ unpack ${A}
+
+ sed 's|#PF#|'${PF}'|g' ${FILESDIR}/${PN}-docfiles.patch > ${PN}-docfiles.patch
+
+ epatch ${PN}-docfiles.patch
+
+ cd ${S}
+ einfo "Regenerating autotools files..."
+ automake || die "automake failed"
+}
+
+
+src_compile () {
+ econf $(use_enable static static-wx) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+ insinto /usr/share/pixmaps/
+ doins maxima-new.png
+ make_desktop_entry wxmaxima wxMaxima maxima-new
+
+ cd ${S}/data
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}"
+ doins docs.zip intro.zip
+ fi
+}