aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-11-24 01:15:20 +0000
committerSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-11-24 01:15:20 +0000
commit82d0c31fd285cab1cd0ec2503e806ab352cf5e1f (patch)
treee85d1962a394b26c9bfa06057da6e0da6fd7308f /sci-mathematics
parentsci-mathematics/frama-c-20090901: init_locals_defined.patch (diff)
downloadsci-82d0c31fd285cab1cd0ec2503e806ab352cf5e1f.tar.gz
sci-82d0c31fd285cab1cd0ec2503e806ab352cf5e1f.tar.bz2
sci-82d0c31fd285cab1cd0ec2503e806ab352cf5e1f.zip
Added an experimental octave
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog11
-rw-r--r--sci-mathematics/octave/Manifest4
-rw-r--r--sci-mathematics/octave/metadata.xml22
-rw-r--r--sci-mathematics/octave/octave-3.2.3-r1.ebuild107
4 files changed, 144 insertions, 0 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
new file mode 100644
index 000000000..d564fd9b3
--- /dev/null
+++ b/sci-mathematics/octave/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/octave
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*octave-3.2.3-r1 (24 Nov 2009)
+
+ 24 Nov 2009; SĂ©bastien Fabbro <bicatali@gentoo.org>
+ +octave-3.2.3-r1.ebuild, +metadata.xml:
+ Experimental octave ebuild. Added graphicsmagick, fltk, opengl, and
+ qrupdate support. Some cosmetics
+
diff --git a/sci-mathematics/octave/Manifest b/sci-mathematics/octave/Manifest
new file mode 100644
index 000000000..fc95b0cd8
--- /dev/null
+++ b/sci-mathematics/octave/Manifest
@@ -0,0 +1,4 @@
+DIST octave-3.2.3.tar.bz2 12085781 RMD160 30c1892544ba67054f1888758ebc2b1ede8848c0 SHA1 7a188ffd55ac1efb2f480fa2aed94e66d3596f34 SHA256 309b486825f0b576b7581344a4946bbd8c4cde75c32a2515ae0cfc09a7975fda
+EBUILD octave-3.2.3-r1.ebuild 2648 RMD160 476db1ae91e99fa4e1b2f8db7398690905c5eaf3 SHA1 44371437b391e498c597a48be686600f45b59547 SHA256 39e14cdac53c462c3e02c416c35a3de95cdc1d575841f57a531620481c224618
+MISC ChangeLog 358 RMD160 20a2ff608bcc7f6472a9b14ce0a2f514a345ea1c SHA1 afbe9585fbe97bf1ac332118691bf6bf8b054bd9 SHA256 9e6ad5b52d293e2e415074b068806548b797d37001913bbfd9030068496b5bf2
+MISC metadata.xml 1114 RMD160 845c798092cd08003a3618c2d44be40fbfbe4ed4 SHA1 8bf7a7c3218f698d18ff9c2981bed2bded459c57 SHA256 9475a5d272dcd258a18c7bd783b93cc622d2ebe4bab663e57b2e3ad89972d8be
diff --git a/sci-mathematics/octave/metadata.xml b/sci-mathematics/octave/metadata.xml
new file mode 100644
index 000000000..62a577f8e
--- /dev/null
+++ b/sci-mathematics/octave/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<longdescription lang='en'>
+ GNU Octave is a high-level language, primarily intended for
+ numerical computations. It provides a convenient command line interface for
+ solving linear and nonlinear problems numerically, and for performing
+ other numerical experiments using a language that is mostly compatible
+ with Matlab. It may also be used as a batch-oriented language. Octave
+ has extensive tools for solving common numerical linear algebra
+ problems, finding the roots of nonlinear equations, integrating
+ ordinary functions, manipulating polynomials, and integrating ordinary
+ differential and differential-algebraic equations. It is easily
+ extensible and customizable via user-defined functions written in
+ Octave's own language, or using dynamically loaded modules written in
+ C++, C, Fortran, or other languages.
+</longdescription>
+<use>
+ <flag name='sparse'>Enable enhanced support for sparse matrix algebra</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-mathematics/octave/octave-3.2.3-r1.ebuild b/sci-mathematics/octave/octave-3.2.3-r1.ebuild
new file mode 100644
index 000000000..dce6462a7
--- /dev/null
+++ b/sci-mathematics/octave/octave-3.2.3-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.3.ebuild,v 1.1 2009/11/04 11:26:39 markusle Exp $
+
+EAPI="2"
+inherit flag-o-matic xemacs-elisp-common
+
+DESCRIPTION="High-level interactive language for numerical computations"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+IUSE="curl doc emacs fltk fftw hdf5 opengl readline sparse xemacs zlib"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/libpcre
+ media-gfx/graphicsmagick[cxx]
+ media-libs/qhull
+ sci-libs/qrupdate
+ sci-mathematics/glpk
+ sci-visualization/gnuplot
+ sys-libs/ncurses
+ virtual/lapack
+ curl? ( net-misc/curl )
+ fltk? ( x11-libs/fltk[opengl] )
+ fftw? ( sci-libs/fftw:3.0 )
+ hdf5? ( sci-libs/hdf5 )
+ opengl? ( virtual/opengl media-libs/ftgl )
+ sparse? ( sci-libs/arpack
+ sci-libs/camd
+ sci-libs/ccolamd
+ sci-libs/cholmod
+ sci-libs/colamd
+ sci-libs/cxsparse
+ sci-libs/umfpack )
+ xemacs? ( app-editors/xemacs )
+ zlib? ( sys-libs/zlib )
+ !sci-mathematics/octave-forge"
+
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ sys-apps/texinfo
+ || ( dev-texlive/texlive-genericrecommended
+ app-text/ptex )
+ dev-util/gperf
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.2.0_parallel_make.patch
+ epatch "${FILESDIR}"/${PN}-3.2.0_as_needed.patch
+}
+
+src_configure() {
+ use fltk || export FLTK_CONFIG=""
+ econf \
+ --localstatedir=/var/state/octave \
+ --enable-shared \
+ --enable-qrupdate \
+ --with-blas="$(pkg-config --libs blas)" \
+ --with-lapack="$(pkg-config --libs lapack)" \
+ $(use_enable readline) \
+ $(use_with curl) \
+ $(use_with fftw) \
+ $(use_with hdf5) \
+ $(use_with opengl framework-opengl) \
+ $(use_with sparse arpack) \
+ $(use_with sparse umfpack) \
+ $(use_with sparse colamd) \
+ $(use_with sparse ccolamd) \
+ $(use_with sparse cholmod) \
+ $(use_with sparse cxsparse) \
+ $(use_with zlib)
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use xemacs; then
+ cd "${S}/emacs"
+ xemacs-elisp-comp *.el
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ if use doc; then
+ einfo "Installing documentation..."
+ insinto /usr/share/doc/${PF}
+ doins $(find doc -name \*.pdf)
+ fi
+
+ if use emacs || use xemacs; then
+ cd emacs
+ exeinto /usr/bin
+ doexe octave-tags || die "Failed to install octave-tags"
+ doman octave-tags.1 || die "Failed to install octave-tags.1"
+ if use xemacs; then
+ xemacs-elisp-install ${PN} *.el *.elc
+ fi
+ cd ..
+ fi
+
+ echo "LDPATH=/usr/$(get_libdir)/octave-${PV}" > 99octave
+ doenvd 99octave || die
+}