aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <seb@cayenne.ist.utl.pt>2010-01-22 19:42:08 +0000
committerSebastien Fabbro <seb@cayenne.ist.utl.pt>2010-01-22 19:42:08 +0000
commitf47e972cf2a1ffb685107af79488f42b7314f7b1 (patch)
treec9d9070e57fe453899457bee8e3d07a6ebcacde8 /sci-mathematics
parentFixed octave dep to libX11 (diff)
downloadsci-f47e972cf2a1ffb685107af79488f42b7314f7b1.tar.gz
sci-f47e972cf2a1ffb685107af79488f42b7314f7b1.tar.bz2
sci-f47e972cf2a1ffb685107af79488f42b7314f7b1.zip
Added open-axiom
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/open-axiom/ChangeLog10
-rw-r--r--sci-mathematics/open-axiom/Manifest3
-rw-r--r--sci-mathematics/open-axiom/metadata.xml11
-rw-r--r--sci-mathematics/open-axiom/open-axiom-1.3.0.ebuild40
4 files changed, 64 insertions, 0 deletions
diff --git a/sci-mathematics/open-axiom/ChangeLog b/sci-mathematics/open-axiom/ChangeLog
new file mode 100644
index 000000000..f8d9884d2
--- /dev/null
+++ b/sci-mathematics/open-axiom/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-mathematics/open-axiom
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*open-axiom-1.3.0 (22 Jan 2010)
+
+ 22 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +open-axiom-1.3.0.ebuild, +metadata.xml:
+ Initial experimental ebuild of open-axiom
+
diff --git a/sci-mathematics/open-axiom/Manifest b/sci-mathematics/open-axiom/Manifest
new file mode 100644
index 000000000..41e738eed
--- /dev/null
+++ b/sci-mathematics/open-axiom/Manifest
@@ -0,0 +1,3 @@
+DIST open-axiom-1.3.0.tar.bz2 11821857 RMD160 71ab5b199ae3b4331e82f4b1a549b6e3a764784a SHA1 a9e7fb441d120fe1b4cc9b12d9cc40c868f2dc8e SHA256 5c35d0c8b6da17ff2254d833c5f6694d3f5d49064e312e61719cdeb386f888c4
+EBUILD open-axiom-1.3.0.ebuild 946 RMD160 ec079d6de86c9b2c09c1adc1d61a1c26ab188845 SHA1 2fa6da3f2b202592a8dd39914afbaceab973eaa6 SHA256 ff9cf3b0912d09901e601a6ed1ac414770ad3f0d88458eafb8e0a2c954b6a548
+MISC metadata.xml 509 RMD160 e4e56ed060bee136366ac1245533dd2c4d54cfd0 SHA1 80e8b8407fac12eeb853ef5b6fae8163020a7844 SHA256 07d61b85885cd111187f9bdd5bb2bb57bae907630b09683316d929f1b98f97ff
diff --git a/sci-mathematics/open-axiom/metadata.xml b/sci-mathematics/open-axiom/metadata.xml
new file mode 100644
index 000000000..be6988b49
--- /dev/null
+++ b/sci-mathematics/open-axiom/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<longdescription lang="en">
+ OpenAxiom is an open source platform for symbolic, algebraic, and
+ numerical computations. It offers an interactive environment, an expressive
+ programming language, a compiler, a large set of mathematical libraries of
+ interest to researchers and practitioners of computational sciences.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/open-axiom/open-axiom-1.3.0.ebuild b/sci-mathematics/open-axiom/open-axiom-1.3.0.ebuild
new file mode 100644
index 000000000..b5d0257c1
--- /dev/null
+++ b/sci-mathematics/open-axiom/open-axiom-1.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+DESCRIPTION="Symbolic and algebraic computations system"
+HOMEPAGE="http://www.open-axiom.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="X"
+
+RDEPEND="X? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ app-text/noweb
+ >=dev-lisp/sbcl-1.0.22"
+
+src_configure() {
+ # There is an option to compile with other lisps. However:
+ # - gcl is getting obsolete and unmaintained and is hard masked
+ # - could not make it work with ecls
+ econf \
+ --with-lisp=sbcl \
+ $(use_with X x)
+}
+
+src_compile() {
+ # unfortunately could not track down the broken parallel build
+ # -j5 ok but -j30 sbcl stalled
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog* NEWS README AUTHORS MAINTAINERS TODO STYLES
+}