aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormarkusle <markusle@32389bae-6d03-0410-99cf-db05cde120eb>2008-04-28 13:40:39 +0000
committermarkusle <markusle@32389bae-6d03-0410-99cf-db05cde120eb>2008-04-28 13:40:39 +0000
commitf66ab76ed330551c9027b63460ae5f0bc4c0fdf0 (patch)
tree392438ca144a0a5e02f4d5407de3ecf4d153242f /sci-mathematics
parentadded phun (diff)
downloadsci-f66ab76ed330551c9027b63460ae5f0bc4c0fdf0.tar.gz
sci-f66ab76ed330551c9027b63460ae5f0bc4c0fdf0.tar.bz2
sci-f66ab76ed330551c9027b63460ae5f0bc4c0fdf0.zip
Version bump.
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1028 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/Manifest2
-rw-r--r--sci-mathematics/octave/octave-3.0.1.ebuild140
2 files changed, 142 insertions, 0 deletions
diff --git a/sci-mathematics/octave/Manifest b/sci-mathematics/octave/Manifest
index 2479c9503..b6437c749 100644
--- a/sci-mathematics/octave/Manifest
+++ b/sci-mathematics/octave/Manifest
@@ -2,6 +2,8 @@ AUX octave-2.9.18-test-fix.patch 1241 RMD160 1cac3e4cd2cce480a184a8319ce0cb2d345
AUX octave-3.0.0-pkg.patch 471 RMD160 c8d7c9fddce78ef1344e5d8c8d3b95df432956c1 SHA1 43931da426dd988c451ff852391f33d236941efa SHA256 48974218d067c8e85d7cf0d4eea3921b5db743872f53131012e4c19696feb414
DIST octave-2.9.19.tar.bz2 9807420 RMD160 c0f7d7b384f3e2f51cdb7ee0360d4ddf52e4493a SHA1 1cee64ccbcce0aca2b771175fcfbca817c9ba705 SHA256 684165a4b7f45e02761dded6ecf50d57652d55beb2295cdac3b7518ec6dc02d8
DIST octave-3.0.0.tar.bz2 9821575 RMD160 02fc58b63210ec99cfcad9dc2cee2ad1b6d11326 SHA1 874b3d40db5d882e37614ffa6cdb9fdd71e173f8 SHA256 f2351eed4f6505993275947802a35ecbc9b7e587ebbb5ee7ba72d54280de4418
+DIST octave-3.0.1.tar.bz2 9854711 RMD160 3141454b1e9a8efcac0772aed63c27aaad082861 SHA1 e4cebe74a1182df610d91e45974653227dd4b342 SHA256 310bfc622d74fd5c3727c2304ad594888f3016a89f183af7afdfef3fd5c15e6d
EBUILD octave-2.9.19.ebuild 3730 RMD160 83bede43b38adeeb947a73eab8b1a72dfd2b423c SHA1 91e0f8ca90ce245fe008f0fe1b4c19f31c6c731b SHA256 b9ed09502561add7639a7b0494b3f101583ad4cfe49f1d818d3342c39be4d42b
EBUILD octave-3.0.0.ebuild 4143 RMD160 29397d608bf4d27ea1c230a6152d20ab69e5079b SHA1 991374e1717b25034f230cfbc6963470bef7f43c SHA256 18de83949602b28e6bb48a3d1a1df79f8b1cee3ab47fa32b6d0ffc645f2af67c
+EBUILD octave-3.0.1.ebuild 4132 RMD160 2f2b2e22cb85a04ebffe24f01383e8153b480014 SHA1 865c7735e2ab490ec88b620425b0f28595cf753e SHA256 9e0f6d0fc6ed43ae2cf38adea353202bc552994381bceb559eb9f0e793aba785
MISC ChangeLog 981 RMD160 c29fa3d69f2c26d7380c4f4f200a2596a9cbbdd1 SHA1 084a94c7edec21ad69b3d8c4d42dd97f8f548ec2 SHA256 87abede80e3b255b773f38c3c999a6580ae79b098e6af146e47a9d01cf243e0a
diff --git a/sci-mathematics/octave/octave-3.0.1.ebuild b/sci-mathematics/octave/octave-3.0.1.ebuild
new file mode 100644
index 000000000..6ab53fec2
--- /dev/null
+++ b/sci-mathematics/octave/octave-3.0.1.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r1.ebuild,v 1.2 2006/11/03 15:44:39 markusle Exp $
+
+inherit flag-o-matic fortran autotools xemacs-elisp-common
+
+DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+IUSE="emacs readline zlib doc hdf5 curl fftw xemacs sparse"
+KEYWORDS="~amd64 ~x86" #~alpha ~hppa ~ppc ~ppc64 ~sparc
+
+DEPEND="dev-util/dejagnu
+ virtual/blas
+ virtual/lapack
+ dev-libs/libpcre
+ >=sys-libs/ncurses-5.2-r3
+ >=sci-visualization/gnuplot-3.7.1-r3
+ >=sci-mathematics/glpk-4.15
+ >=dev-util/gperf-2.7.2
+ >=media-libs/qhull-3.1-r1
+ virtual/latex-base
+ fftw? ( >=sci-libs/fftw-3.1.2 )
+ zlib? ( sys-libs/zlib )
+ hdf5? ( sci-libs/hdf5 )
+ curl? ( net-misc/curl )
+ xemacs? ( virtual/xemacs )
+ sparse? ( sci-libs/umfpack
+ sci-libs/colamd
+ sci-libs/ccolamd
+ sci-libs/cholmod
+ sci-libs/cxsparse )
+ !=app-text/texi2html-1.70"
+
+FORTRAN="gfortran g77 f2c"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.0.0-pkg.patch
+}
+
+src_compile() {
+ local myconf="--localstatedir=/var/state/octave --enable-rpath"
+
+ # force use of external blas, lapack, fftw
+ myconf="${myconf} --with-blas=blas --with-lapack=lapack"
+ myconf="${myconf} --enable-static --enable-shared --enable-dl"
+
+ # disable sparse matrix stuff for now
+ local sparse_conf;
+ if use sparse; then
+ sparse_conf="--with-umfpack --with-colamd --with-ccolamd"
+ sparse_conf="${sparse_conf} --with-cholmod --with-cxsparse"
+ else
+ sparse_conf="--without-umfpack --without-colamd --without-ccolamd"
+ sparse_conf="${sparse_conf} --without-cholmod --without-cxsparse"
+ fi
+ myconf="${myconf} ${sparse_conf}"
+
+ if [[ "${FORTRANC}" == "g77" ]]; then
+ myconf="${myconf} --with-f77"
+ elif [[ "${FORTRANC}" == "f2c" ]]; then
+ myconf="${myconf} --with-f2c"
+ fi
+
+ econf \
+ $(use_with hdf5) \
+ $(use_with curl) \
+ $(use_with zlib) \
+ $(use_with fftw) \
+ $(use_enable readline) \
+ ${myconf} \
+ || die "econf failed"
+
+ emake || die "emake failed"
+
+ if use xemacs; then
+ cd "${S}/emacs"
+ xemacs-elisp-comp *.el
+ fi
+}
+
+src_install() {
+ cd "${S}"
+ make install DESTDIR="${D}" || die "make install failed"
+ if use doc; then
+ octave-install-doc || die "Octave doc install failed"
+ fi
+ if use emacs || use xemacs; then
+ cd emacs
+ exeinto /usr/bin
+ doexe octave-tags || die "Failed to install octave-tags"
+ doman octave-tags.1 || die "Failed to install octave-tags.1"
+ if use xemacs; then
+ xemacs-elisp-install ${PN} *.el *.elc
+ fi
+ cd ..
+ fi
+ dodir /etc/env.d || die
+ echo "LDPATH=/usr/lib/octave-${PV}" > "${D}"/etc/env.d/99octave \
+ || die "Failed to set up env.d files"
+
+ # Fixes ls-R files to remove /var/tmp/portage references.
+ sed -i -e "s:${D}::g" "${D}"/usr/libexec/${PN}/ls-R && \
+ sed -i -e "s:${D}::g" "${D}"/usr/share/${PN}/ls-R || \
+ die "Failed to fix ls-R files."
+}
+
+pkg_postinst() {
+ echo
+ einfo "Some users have reported failures at running simple tests if"
+ einfo "octave was built with agressive optimisations. You can check if"
+ einfo "your setup is affected by this bug by running the following test"
+ einfo "(inside the octave interpreter):"
+ einfo
+ einfo "octave:1> y = [1 3 4 2 1 5 3 5 6 7 4 5 7 10 11 3];"
+ einfo "octave:2> g = [1 1 1 1 1 1 1 1 2 2 2 2 2 3 3 3];"
+ einfo "octave:3> anova(y, g)"
+ einfo
+ einfo "If these commands complete successfully with no error message,"
+ einfo "your installation should be ok. Otherwise, try recompiling"
+ einfo "octave using less agressive \"CFLAGS\" (combining \"-O3\" and"
+ einfo "\"-march=pentium4\" is known to cause problems)."
+ echo
+}
+
+octave-install-doc() {
+ echo "Installing documentation..."
+ insinto /usr/share/doc/${PF}
+ doins doc/faq/Octave-FAQ.pdf || die
+ doins doc/interpreter/octave.pdf || die
+ doins doc/liboctave/liboctave.pdf || die
+ doins doc/refcard/refcard-a4.pdf || die
+ doins doc/refcard/refcard-legal.pdf || die
+ doins doc/refcard/refcard-letter.pdf || die
+}