aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlammie Pirinen <flammie@iki.fi>2010-02-22 18:58:50 +0200
committerFlammie Pirinen <flammie@iki.fi>2010-02-22 19:29:33 +0200
commit9559a1b1cc7c8e27498761effde3260185471430 (patch)
tree226648ef1632e68fa0f729ef7c279c0ffecf8a34 /sci-misc/openfst/openfst-1.1.ebuild
parenttouch mpir to enable testing on non-x86/amd64 archs. Remove old mpir. (diff)
downloadsci-9559a1b1cc7c8e27498761effde3260185471430.tar.gz
sci-9559a1b1cc7c8e27498761effde3260185471430.tar.bz2
sci-9559a1b1cc7c8e27498761effde3260185471430.zip
Version bump.
Diffstat (limited to 'sci-misc/openfst/openfst-1.1.ebuild')
-rw-r--r--sci-misc/openfst/openfst-1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-misc/openfst/openfst-1.1.ebuild b/sci-misc/openfst/openfst-1.1.ebuild
new file mode 100644
index 000000000..c8c166cbd
--- /dev/null
+++ b/sci-misc/openfst/openfst-1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils multilib
+
+DESCRIPTION="Finite State Transducer tools by Google et al."
+HOMEPAGE="http://www.openfst.org"
+SRC_URI="http://mohri-lt.cs.nyu.edu/twiki/pub/FST/FstDownload/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS README || die "docs missing"
+}
+
+src_test() {
+ einfo "make test can take a few hours on moderately modern systems"
+ make test || die "check failed"
+}
+