aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-29 22:32:06 +0200
committerJustin Lecher <jlec@gentoo.org>2010-06-29 22:32:06 +0200
commite89459177ce623bf2044b4dde512fb9e0ab73804 (patch)
tree8eb29795c691a912fbf50f36f5a1de04f648a068 /sci-misc/salome-component/salome-component-5.1.3.ebuild
parentRemove empty lines (diff)
downloadsci-e89459177ce623bf2044b4dde512fb9e0ab73804.tar.gz
sci-e89459177ce623bf2044b4dde512fb9e0ab73804.tar.bz2
sci-e89459177ce623bf2044b4dde512fb9e0ab73804.zip
Fix for Python ABIs
(Portage version: 2.2_rc67/git/Linux x86_64, RepoMan options: --force) (Signed Manifest commit)
Diffstat (limited to 'sci-misc/salome-component/salome-component-5.1.3.ebuild')
-rw-r--r--sci-misc/salome-component/salome-component-5.1.3.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-misc/salome-component/salome-component-5.1.3.ebuild b/sci-misc/salome-component/salome-component-5.1.3.ebuild
index a9f3d4ae2..af4f224aa 100644
--- a/sci-misc/salome-component/salome-component-5.1.3.ebuild
+++ b/sci-misc/salome-component/salome-component-5.1.3.ebuild
@@ -3,6 +3,7 @@
# $Header: $
EAPI=2
+
PYTHON_DEPEND="2:2.4"
inherit eutils flag-o-matic python
@@ -16,8 +17,8 @@ KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="debug doc mpi"
-RDEPEND="mpi? ( || ( sys-cluster/openmpi[cxx]
- sys-cluster/mpich2[cxx] ) )
+RDEPEND="mpi? || ( sys-cluster/openmpi[cxx]
+ sys-cluster/mpich2[cxx] )
debug? ( dev-util/cppunit )
>=sci-misc/salome-kernel-${PV}
>=sci-misc/salome-gui-${PV}
@@ -28,7 +29,6 @@ RDEPEND="mpi? ( || ( sys-cluster/openmpi[cxx]
>=x11-libs/qwt-5.2
>=dev-python/PyQt4-4.4.3
>=sci-libs/opencascade-6.3"
-
DEPEND="${RDEPEND}
>=app-doc/doxygen-1.5.6
media-gfx/graphviz
@@ -45,6 +45,7 @@ COMPONENT_ROOT_DIR="/opt/salome-${PV}/${MODULE_NAME}"
pkg_setup() {
[[ $(python_get_version) > 2.4 ]] && \
ewarn "Python 2.4 is highly recommended for Salome..."
+ python_set_active_version 2
}
src_prepare() {