aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoroli <oli@32389bae-6d03-0410-99cf-db05cde120eb>2008-08-27 18:18:22 +0000
committeroli <oli@32389bae-6d03-0410-99cf-db05cde120eb>2008-08-27 18:18:22 +0000
commit03dfe674eb05161cab3fd76de7bf95f9eda9286e (patch)
treed27f01db745bebd9187a0b8b0874d052a9c4aee2 /sci-misc/salome-visu/salome-visu-3.2.6.ebuild
parentsci-misc/salome-superv: Removed fetch restriction, removed hardcode (diff)
downloadsci-03dfe674eb05161cab3fd76de7bf95f9eda9286e.tar.gz
sci-03dfe674eb05161cab3fd76de7bf95f9eda9286e.tar.bz2
sci-03dfe674eb05161cab3fd76de7bf95f9eda9286e.zip
sci-misc/salome-visu: Removed fetch restriction, removed hardcode
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1259 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-misc/salome-visu/salome-visu-3.2.6.ebuild')
-rw-r--r--sci-misc/salome-visu/salome-visu-3.2.6.ebuild22
1 files changed, 6 insertions, 16 deletions
diff --git a/sci-misc/salome-visu/salome-visu-3.2.6.ebuild b/sci-misc/salome-visu/salome-visu-3.2.6.ebuild
index 337d69ee0..081123b46 100644
--- a/sci-misc/salome-visu/salome-visu-3.2.6.ebuild
+++ b/sci-misc/salome-visu/salome-visu-3.2.6.ebuild
@@ -1,26 +1,26 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+# $Header: $
inherit autotools distutils eutils flag-o-matic toolchain-funcs versionator python multilib
DESCRIPTION="SALOME : The Open Source Integration Platform for Numerical Simulation. VISU Component"
HOMEPAGE="http://www.salome-platform.org"
-SRC_URI="salome-3.2.6.tar.gz"
+SRC_URI="http://files.opencascade.com/Salome${PV}/src${PV}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="doc opengl mpi debug"
-RESTRICT="fetch"
RDEPEND="opengl? ( virtual/opengl )
mpi? ( sys-cluster/mpich2 )
debug? ( dev-util/cppunit )"
DEPEND="${RDEPEND}
- >=sci-misc/salome-kernel-3.2.6
- >=sci-misc/salome-gui-3.2.6
- >=sci-misc/salome-component-3.2.6
+ >=sci-misc/salome-kernel-${PV}
+ >=sci-misc/salome-gui-${PV}
+ >=sci-misc/salome-component-${PV}
<=dev-python/omniorbpy-2.6
<=net-misc/omniORB-4.1"
@@ -32,16 +32,6 @@ INSTALL_DIR="/opt/salome-${PV}/${MODULE_NAME}"
VISU_ROOT_DIR="/opt/salome-${PV}/${MODULE_NAME}"
export OPENPBS="/usr"
-
-pkg_nofetch()
-{
- einfo "You have to download manually the source code. You can download it from :"
- einfo " http://www.salome-platform.org/download/dl326"
- einfo ""
- einfo "Put the archive in the \"/usr/portage/distfile\" directory and rename it \"salome-3.2.6.tar.gz\""
-}
-
-
src_unpack()
{
python_version
@@ -142,7 +132,7 @@ src_install()
insinto "${INSTALL_DIR}"
doins -r adm_local
if use doc ; then
- dodoc INSTALL LICENCE
+ dodoc INSTALL
fi
}