aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Denisov <pavel.a.denisov@gmail.com>2015-02-28 22:40:03 -0400
committerPavel Denisov <pavel.a.denisov@gmail.com>2015-02-28 22:40:47 -0400
commit0063c7b7e3dfa20520464d865025a83531eb6b1d (patch)
treeda114204b360fe0eb75cf64c35b66f31dde28675 /sci-misc
parentMerge pull request #377 from akreal/openfst (diff)
downloadsci-0063c7b7e3dfa20520464d865025a83531eb6b1d.tar.gz
sci-0063c7b7e3dfa20520464d865025a83531eb6b1d.tar.bz2
sci-0063c7b7e3dfa20520464d865025a83531eb6b1d.zip
sci-misc/kaldi: version bump
Package-Manager: portage-2.2.17
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/kaldi/ChangeLog7
-rw-r--r--sci-misc/kaldi/files/Makefile.patch76
-rw-r--r--sci-misc/kaldi/files/configure.patch164
-rw-r--r--sci-misc/kaldi/files/default_rules.mk.patch67
-rw-r--r--sci-misc/kaldi/kaldi-0_p20150301.ebuild (renamed from sci-misc/kaldi/kaldi-0_p20150101.ebuild)5
5 files changed, 206 insertions, 113 deletions
diff --git a/sci-misc/kaldi/ChangeLog b/sci-misc/kaldi/ChangeLog
index f7406faf9..6639e7e5a 100644
--- a/sci-misc/kaldi/ChangeLog
+++ b/sci-misc/kaldi/ChangeLog
@@ -2,6 +2,13 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*kaldi-0_p20150301 (01 Mar 2015)
+
+ 01 Mar 2015; Pavel Denisov <pavel.a.denisov@gmail.com>
+ -kaldi-0_p20150101.ebuild, +kaldi-0_p20150301.ebuild, files/Makefile.patch,
+ files/configure.patch, files/default_rules.mk.patch:
+ Version bump.
+
*kaldi-0_p20150101 (11 Jan 2015)
11 Jan 2015; Pavel Denisov <pavel.a.denisov@gmail.com> +files/Makefile.patch,
diff --git a/sci-misc/kaldi/files/Makefile.patch b/sci-misc/kaldi/files/Makefile.patch
index 07302d6d4..ef1a60640 100644
--- a/sci-misc/kaldi/files/Makefile.patch
+++ b/sci-misc/kaldi/files/Makefile.patch
@@ -1,19 +1,57 @@
---- Makefile.orig 2015-01-01 21:51:30.999356027 -0400
-+++ Makefile 2015-01-04 16:54:02.527824499 -0400
-@@ -131,6 +131,16 @@
- ext_depend: check_portaudio
- -for x in $(EXT_SUBDIRS); do $(MAKE) -C $$x depend; done
-
-+print-binfiles: $(addsuffix /print-binfiles, $(SUBDIRS))
-+
-+%/print-binfiles:
-+ @$(MAKE) --no-print-directory -C $(dir $@) print-binfiles
-+
-+print-libfiles: $(addsuffix /print-libfiles, $(SUBDIRS))
-+
-+%/print-libfiles:
-+ @$(MAKE) --no-print-directory -C $(dir $@) print-libfiles
-+
-
- .PHONY: $(SUBDIRS)
- $(SUBDIRS) : mklibdir
+*** Makefile.orig 2015-02-28 16:31:57.377401743 -0400
+--- Makefile 2015-02-28 16:48:58.153175376 -0400
+***************
+*** 30,36 ****
+
+ # Reset the default goal, so that the all target will become default
+ .DEFAULT_GOAL :=
+! all: checkversion test_dependencies kaldi.mk mklibdir $(SUBDIRS)
+ -echo Done
+
+ mklibdir:
+--- 30,36 ----
+
+ # Reset the default goal, so that the all target will become default
+ .DEFAULT_GOAL :=
+! all: checkversion kaldi.mk mklibdir $(SUBDIRS)
+ -echo Done
+
+ mklibdir:
+***************
+*** 88,103 ****
+ ext: test_dependencies ext_depend $(SUBDIRS) $(EXT_SUBDIRS)
+ -echo Done
+
+- ifndef OPENFST_VER
+- $(error Please rerun configure: OPENFST_VER is not defined, likely kaldi.mk was produced by older configure script.)
+- endif
+- # Note: OPENFST_VER is determined by configure and added to kaldi.mk
+- OPENFST_VER_NUM := $(shell echo $(OPENFST_VER) | sed 's/\./ /g' | xargs printf "%d%02d%02d")
+- test_dependencies:
+- ifeq ("$(shell expr $(OPENFST_VER_NUM) \< 10302)","1")
+- $(error OpenFst $(OPENFST_VER) is not supported. You now need OpenFst >= 1.3.2.)
+- endif
+-
+ check_portaudio:
+ @[ -d ../tools/portaudio ] || ( cd ../tools; ./install_portaudio.sh )
+
+--- 88,93 ----
+***************
+*** 131,136 ****
+--- 121,136 ----
+ ext_depend: check_portaudio
+ -for x in $(EXT_SUBDIRS); do $(MAKE) -C $$x depend; done
+
++ print-binfiles: $(addsuffix /print-binfiles, $(SUBDIRS))
++
++ %/print-binfiles:
++ @$(MAKE) --no-print-directory -C $(dir $@) print-binfiles
++
++ print-libfiles: $(addsuffix /print-libfiles, $(SUBDIRS))
++
++ %/print-libfiles:
++ @$(MAKE) --no-print-directory -C $(dir $@) print-libfiles
++
+
+ .PHONY: $(SUBDIRS)
+ $(SUBDIRS) : mklibdir
diff --git a/sci-misc/kaldi/files/configure.patch b/sci-misc/kaldi/files/configure.patch
index 07d663e93..f6086fc3c 100644
--- a/sci-misc/kaldi/files/configure.patch
+++ b/sci-misc/kaldi/files/configure.patch
@@ -1,71 +1,93 @@
---- configure.orig 2015-01-01 21:51:05.611960184 -0400
-+++ configure 2015-01-01 22:06:11.027064734 -0400
-@@ -45,15 +45,6 @@
- fi
- }
-
--
--
--## First do some checks. These verify that all the things are
--## here that should be here.
--if [ "`basename $PWD`" != "src" ]; then
-- echo 'You must run "configure" from the src/ directory.'
-- exit 1
--fi
--
- ## Default locations for FST and linear algebra libraries.
- MATHLIB='ATLAS'
- ATLASROOT=`rel2abs ../tools/ATLAS/`
-@@ -473,6 +464,23 @@
- exit_success;
- }
-
-+function linux_configure_gentoo {
-+ m=$1 # 64 or empty.
-+ ATLASLIBS="/usr/lib$m/libatlas.so.3 /usr/lib$m/libf77blas.so.3 /usr/lib$m/libatlcblas.so.3 /usr/lib$m/libatlclapack.so.3"
-+ for f in $ATLASLIBS; do
-+ [ ! -f $f ] && return 1;
-+ done
-+ libdir=$(dirname $(echo $ATLASLIBS | awk '{print $1}'))
-+ [ -z "$libdir" ] && echo "Error getting libdir in linux_configure_gentoo" && exit 1;
-+ echo ATLASINC = $ATLASROOT >> kaldi.mk
-+ echo ATLASLIBS = $ATLASLIBS -Wl,-rpath=$libdir >> kaldi.mk
-+ echo
-+ cat makefiles/linux_atlas.mk >> kaldi.mk
-+ fix_cxx_flag
-+ echo "Successfully configured for gentoo [dynamic libraries] with ATLASLIBS =$ATLASLIBS"
-+ $use_cuda && linux_configure_cuda
-+ exit_success;
-+}
-
- function linux_configure_static {
- if $threaded_atlas; then pt=pt; else pt=""; fi
-@@ -716,8 +724,8 @@
-
- echo "On Linux: Checking for linear algebra header files ..."
- if [ "$MATHLIB" == "ATLAS" ]; then
-- if [ ! -f $ATLASROOT/include/cblas.h ] || [ ! -f $ATLASROOT/include/clapack.h ] ; then
-- failure "Could not find required header files cblas.h or clapack.h in ATLAS dir '$ATLASROOT/include'"
-+ if ( [ ! -f $ATLASROOT/include/cblas.h ] || [ ! -f $ATLASROOT/include/clapack.h ] ) && ( [ ! -f $ATLASROOT/cblas.h ] || [ ! -f $ATLASROOT/clapack.h ] ) ; then
-+ failure "Could not find required header files cblas.h or clapack.h in ATLAS dirs '$ATLASROOT/include' or '$ATLASROOT'"
- fi
- echo "Using ATLAS as the linear algebra library."
-
-@@ -741,6 +749,8 @@
- linux_configure_debian7 || \
- linux_configure_redhat 64 || \
- linux_configure_redhat || \
-+ linux_configure_gentoo 64 || \
-+ linux_configure_gentoo || \
- linux_atlas_failure "Failed to configure ATLAS lbiraries";
- else
- # Prefer dynamic to static math.
-@@ -751,6 +761,8 @@
- linux_configure_debian7 || \
- linux_configure_redhat 64 || \
- linux_configure_redhat || \
-+ linux_configure_gentoo 64 || \
-+ linux_configure_gentoo || \
- linux_atlas_failure "Failed to configure ATLAS lbiraries";
- fi
-
+*** configure.orig 2015-02-28 16:31:35.568045409 -0400
+--- configure 2015-02-28 17:21:58.477634475 -0400
+***************
+*** 46,60 ****
+ fi
+ }
+
+-
+-
+- ## First do some checks. These verify that all the things are
+- ## here that should be here.
+- if [ "`basename $PWD`" != "src" ]; then
+- echo 'You must run "configure" from the src/ directory.'
+- exit 1
+- fi
+-
+ ## Default locations for FST and linear algebra libraries.
+ MATHLIB='ATLAS'
+ ATLASROOT=`rel2abs ../tools/ATLAS/`
+--- 46,51 ----
+***************
+*** 522,527 ****
+--- 513,535 ----
+ exit_success;
+ }
+
++ function linux_configure_gentoo {
++ m=$1 # 64 or empty.
++ ATLASLIBS="/usr/lib$m/libatlas.so.3 /usr/lib$m/libf77blas.so.3 /usr/lib$m/libatlcblas.so.3 /usr/lib$m/libatlclapack.so.3"
++ for f in $ATLASLIBS; do
++ [ ! -f $f ] && return 1;
++ done
++ libdir=$(dirname $(echo $ATLASLIBS | awk '{print $1}'))
++ [ -z "$libdir" ] && echo "Error getting libdir in linux_configure_gentoo" && exit 1;
++ echo ATLASINC = $ATLASROOT >> kaldi.mk
++ echo ATLASLIBS = $ATLASLIBS -Wl,-rpath=$libdir >> kaldi.mk
++ echo
++ cat makefiles/linux_atlas.mk >> kaldi.mk
++ fix_cxx_flag
++ echo "Successfully configured for gentoo [dynamic libraries] with ATLASLIBS =$ATLASLIBS"
++ $use_cuda && linux_configure_cuda
++ exit_success;
++ }
+
+ function linux_configure_static {
+ if $threaded_atlas; then pt=pt; else pt=""; fi
+***************
+*** 682,688 ****
+ echo "FSTROOT = $FSTROOT" >> kaldi.mk
+
+ # Check installed OpenFst version and add C++11 flags if OpenFst >= 1.4
+! OPENFST_VER=`grep 'PACKAGE_VERSION' $FSTROOT/Makefile | sed -e 's:.*= ::'`
+ echo "OPENFST_VER = $OPENFST_VER" >> kaldi.mk
+ OPENFST_VER_NUM=`echo $OPENFST_VER | sed 's/\./ /g' | xargs printf "%d%02d%02d"`
+ if [ $OPENFST_VER_NUM -ge 10400 ]; then
+--- 690,696 ----
+ echo "FSTROOT = $FSTROOT" >> kaldi.mk
+
+ # Check installed OpenFst version and add C++11 flags if OpenFst >= 1.4
+! OPENFST_VER="1.4.1"
+ echo "OPENFST_VER = $OPENFST_VER" >> kaldi.mk
+ OPENFST_VER_NUM=`echo $OPENFST_VER | sed 's/\./ /g' | xargs printf "%d%02d%02d"`
+ if [ $OPENFST_VER_NUM -ge 10400 ]; then
+***************
+*** 765,772 ****
+
+ echo "On Linux: Checking for linear algebra header files ..."
+ if [ "$MATHLIB" == "ATLAS" ]; then
+! if [ ! -f $ATLASROOT/include/cblas.h ] || [ ! -f $ATLASROOT/include/clapack.h ] ; then
+! failure "Could not find required header files cblas.h or clapack.h in ATLAS dir '$ATLASROOT/include'"
+ fi
+ echo "Using ATLAS as the linear algebra library."
+
+--- 773,780 ----
+
+ echo "On Linux: Checking for linear algebra header files ..."
+ if [ "$MATHLIB" == "ATLAS" ]; then
+! if ( [ ! -f $ATLASROOT/include/cblas.h ] || [ ! -f $ATLASROOT/include/clapack.h ] ) && ( [ ! -f $ATLASROOT/cblas.h ] || [ ! -f $ATLASROOT/clapack.h ] ) ; then
+! failure "Could not find required header files cblas.h or clapack.h in ATLAS dirs '$ATLASROOT/include' or '$ATLASROOT'"
+ fi
+ echo "Using ATLAS as the linear algebra library."
+
+***************
+*** 797,802 ****
+--- 805,812 ----
+ else
+ # Prefer dynamic to static math.
+ linux_configure_debian_ubuntu3 || \
++ linux_configure_gentoo 64 || \
++ linux_configure_gentoo || \
+ linux_configure_dynamic || \
+ linux_configure_static || \
+ linux_configure_debian_ubuntu 64 || \
diff --git a/sci-misc/kaldi/files/default_rules.mk.patch b/sci-misc/kaldi/files/default_rules.mk.patch
index 26c7f3616..60e34307b 100644
--- a/sci-misc/kaldi/files/default_rules.mk.patch
+++ b/sci-misc/kaldi/files/default_rules.mk.patch
@@ -1,20 +1,47 @@
---- makefiles/default_rules.mk.orig 2015-01-10 19:56:03.918751769 -0400
-+++ makefiles/default_rules.mk 2015-01-11 13:34:14.596055674 -0400
-@@ -14,7 +14,7 @@
- LIBFILE = lib$(LIBNAME).so
- #LDLIBS += -l$(LIBNAME)
- endif
-- LDFLAGS += -Wl,-rpath=$(shell readlink -f $(KALDILIBDIR)) -L.
-+ LDFLAGS += -L.
- LDFLAGS += $(foreach dep,$(ADDLIBS), -L$(dir $(dep)) )
- XDEPENDS = $(foreach dep,$(ADDLIBS), $(dir $(dep))/lib$(notdir $(basename $(dep))).so )
- else # Platform not supported
-@@ -84,3 +84,8 @@
- #.depend.mk: depend
- -include .depend.mk
-
-+print-binfiles:
-+ @echo $(addprefix $(shell pwd)/, $(BINFILES))
-+
-+print-libfiles:
-+ @echo $(addsuffix .so, $(addprefix $(shell pwd)/lib, $(LIBNAME)))
+*** makefiles/default_rules.mk.orig 2015-02-28 16:32:00.830458169 -0400
+--- makefiles/default_rules.mk 2015-02-28 19:10:50.692172138 -0400
+***************
+*** 14,20 ****
+ LIBFILE = lib$(LIBNAME).so
+ #LDLIBS += -l$(LIBNAME)
+ endif
+! LDFLAGS += -Wl,-rpath=$(shell readlink -f $(KALDILIBDIR)) -L.
+ LDFLAGS += $(foreach dep,$(ADDLIBS), -L$(dir $(dep)) )
+ XDEPENDS = $(foreach dep,$(ADDLIBS), $(dir $(dep))/lib$(notdir $(basename $(dep))).so )
+ else # Platform not supported
+--- 14,20 ----
+ LIBFILE = lib$(LIBNAME).so
+ #LDLIBS += -l$(LIBNAME)
+ endif
+! LDFLAGS += -L.
+ LDFLAGS += $(foreach dep,$(ADDLIBS), -L$(dir $(dep)) )
+ XDEPENDS = $(foreach dep,$(ADDLIBS), $(dir $(dep))/lib$(notdir $(basename $(dep))).so )
+ else # Platform not supported
+***************
+*** 72,78 ****
+ test_compile: $(TESTFILES)
+
+ test: test_compile
+! @result=0; for x in $(TESTFILES); do printf "Running $$x ..."; ./$$x >/dev/null 2>&1; if [ $$? -ne 0 ]; then echo "... FAIL $$x"; result=1; else echo "... SUCCESS"; fi; done; exit $$result
+
+ .valgrind: $(BINFILES) $(TESTFILES)
+
+--- 72,78 ----
+ test_compile: $(TESTFILES)
+
+ test: test_compile
+! @result=0; for x in $(TESTFILES); do printf "Running $$x ..."; LD_LIBRARY_PATH=$(KALDILIBDIR):${LD_LIBRARY_PATH} ./$$x >/dev/null 2>&1; if [ $$? -ne 0 ]; then echo "... FAIL $$x"; result=1; else echo "... SUCCESS"; fi; done; exit $$result
+
+ .valgrind: $(BINFILES) $(TESTFILES)
+
+***************
+*** 84,86 ****
+--- 84,91 ----
+ #.depend.mk: depend
+ -include .depend.mk
+
++ print-binfiles:
++ @echo $(addprefix $(shell pwd)/, $(BINFILES))
++
++ print-libfiles:
++ @echo $(addsuffix .so, $(addprefix $(shell pwd)/lib, $(LIBNAME)))
diff --git a/sci-misc/kaldi/kaldi-0_p20150101.ebuild b/sci-misc/kaldi/kaldi-0_p20150301.ebuild
index 9ef57039e..8ba100db8 100644
--- a/sci-misc/kaldi/kaldi-0_p20150101.ebuild
+++ b/sci-misc/kaldi/kaldi-0_p20150301.ebuild
@@ -8,7 +8,7 @@ inherit eutils flag-o-matic subversion
DESCRIPTION="A toolkit for speech recognition"
HOMEPAGE="http://kaldi.sourceforge.net/"
-ESVN_REPO_URI="https://svn.code.sf.net/p/kaldi/code/trunk/src@4735"
+ESVN_REPO_URI="https://svn.code.sf.net/p/kaldi/code/trunk/src@4927"
LICENSE="Apache-2.0"
SLOT="0"
@@ -18,7 +18,7 @@ KEYWORDS=""
RDEPEND="
media-libs/speex
sci-libs/atlas[lapack,threads=]
- ~sci-misc/openfst-1.3.4"
+ >=sci-misc/openfst-1.4.1"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
@@ -41,7 +41,6 @@ src_configure() {
use test || append-cxxflags -DNDEBUG
sed -i \
- -e 's/OPENFST_VER =/OPENFST_VER = 1.3.4#/' \
-e "s:-g :-DHAVE_SPEEX ${CXXFLAGS} :" \
-e "s:-lm -lpthread -ldl:-lm -lpthread -ldl -lspeex ${LDFLAGS}:" \
kaldi.mk || die "sed unix/kaldi.mk failed"