aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2013-09-26 11:41:12 +0200
committerHonza Macháček <Hloupy.Honza@centrum.cz>2013-09-26 11:41:12 +0200
commit57e910123f7b13b8db2cdb6d48db0fa8e4798953 (patch)
treec2006a73d6b6049845729f9de987f16cd4be7599 /sci-physics/abinit/abinit-7.4.2.ebuild
parentThere is apparently something wrong happenning with my commits. Trying to go ... (diff)
downloadsci-57e910123f7b13b8db2cdb6d48db0fa8e4798953.tar.gz
sci-57e910123f7b13b8db2cdb6d48db0fa8e4798953.tar.bz2
sci-57e910123f7b13b8db2cdb6d48db0fa8e4798953.zip
sci-physics/abinit-7.4.2 finally made to actually build and install (tests have to be configured for their Makefile to be where it is looked for during the installation). Testing scripts, written for Python 2, made to run in an environment with Python 3 selected as the main interpreter.
Package-Manager: portage-2.2.6
Diffstat (limited to 'sci-physics/abinit/abinit-7.4.2.ebuild')
-rw-r--r--sci-physics/abinit/abinit-7.4.2.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/sci-physics/abinit/abinit-7.4.2.ebuild b/sci-physics/abinit/abinit-7.4.2.ebuild
index 41441a68f..d46593ff2 100644
--- a/sci-physics/abinit/abinit-7.4.2.ebuild
+++ b/sci-physics/abinit/abinit-7.4.2.ebuild
@@ -182,6 +182,7 @@ src_prepare() {
"${FILESDIR}"/7.4.2-syntax.patch
eautoreconf
sed -e"s/\(grep '\^-\)\(\[LloW\]\)'/\1\\\(\2\\\|pthread\\\)'/g" -i configure
+ python_fix_shebang "${S}"/tests
}
src_configure() {
@@ -234,6 +235,7 @@ src_configure() {
local myeconfargs=(
--enable-clib
--enable-exports
+ --enable-pkg-check
$(use_enable debug debug enhanced)
$(use_enable mpi)
$(use_enable mpi mpi-io)
@@ -263,7 +265,7 @@ src_configure() {
"$(use bigdft && echo "--with-bigdft-incs=${modules}")"
"$(use bigdft && echo "--with-bigdft-libs=$($(tc-getPKG_CONFIG) --libs bigdft)")"
"$(use libxc && echo "--with-libxc-incs=${modules}")"
- "$(use libxc && echo "--with-libxc-libs=-lxc")"
+ "$(use libxc && echo "--with-libxc-libs=$($(tc-getPKG_CONFIG) --libs libxc)")"
"$(use wannier && echo "--with-wannier90-bins=/usr/bin")"
"$(use wannier && echo "--with-wannier90-incs=${modules}")"
"$(use wannier && echo "--with-wannier90-libs=-lwannier $($(tc-getPKG_CONFIG) --libs lapack)")"
@@ -293,17 +295,8 @@ src_compile() {
src_test() {
einfo "The tests take quite a while, easily several hours or even days"
- # autotools-utils_src_test() expanded
- _check_build_dir
- pushd "${AUTOTOOLS_BUILD_DIR}" > /dev/null
- # again something the autotools-utils function cannot be called to do
- # now quite a lot of work actually
- mkdir -p tests
-
- python2 "${S}"/tests/runtests.py -w tests/ -b "${AUTOTOOLS_BUILD_DIR}"
-
- popd > /dev/null
+ autotools-utils_src_test
}
src_install() {