aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2011-12-17 09:50:49 +0100
committerHonza Macháček <Hloupy.Honza@centrum.cz>2011-12-17 09:50:49 +0100
commit01198d336a4e6e68e375a095e2f4b3d64be96403 (patch)
tree5745914d1b2b64ad95f82168b23a4280f4518cf4 /sci-physics/atompaw2abinit/atompaw2abinit-3.3.0-r1.ebuild
parentmedia-gfx/brlcad: use system libraries for svn version (diff)
downloadsci-01198d336a4e6e68e375a095e2f4b3d64be96403.tar.gz
sci-01198d336a4e6e68e375a095e2f4b3d64be96403.tar.bz2
sci-01198d336a4e6e68e375a095e2f4b3d64be96403.zip
sci-physics/atompaw2abinit-3.3.0-r1.ebuild reflects the new structure of the abinit web
Diffstat (limited to 'sci-physics/atompaw2abinit/atompaw2abinit-3.3.0-r1.ebuild')
-rw-r--r--sci-physics/atompaw2abinit/atompaw2abinit-3.3.0-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-physics/atompaw2abinit/atompaw2abinit-3.3.0-r1.ebuild b/sci-physics/atompaw2abinit/atompaw2abinit-3.3.0-r1.ebuild
new file mode 100644
index 000000000..d27516b1f
--- /dev/null
+++ b/sci-physics/atompaw2abinit/atompaw2abinit-3.3.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit eutils fortran-2 multilib toolchain-funcs
+
+DESCRIPTION="Abinit AtomPAW atomic data convertor"
+HOMEPAGE="http://www.abinit.org/downloads/PAW2/AtomPAW2Abinit-Manual-html/Old-AtomPAW2Abinit-Manual-html/AtomPAW2Abinit2.htm"
+SRC_URI="http://www.abinit.org/downloads/PAW2/AtomPAW2Abinit-Manual-html/Old-AtomPAW2Abinit-Manual-html/Atompaw2Abinit.tgz -> ${P}.tgz"
+
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/lapack
+ virtual/blas
+ sci-physics/atompaw"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/Atompaw2Abinit.v${PV}
+
+pkg_nofetch() {
+ elog "If there is a digest mismatch, please file a bug"
+ elog "at https://bugs.gentoo.org/ -- a version bump"
+ elog "is probably required."
+}
+
+src_configure() {
+ head -n 6 Makefile >Makefile.1
+ tail -n +6 Makefile >Makefile.2
+ cp Makefile.1 Makefile
+ echo FC = $(tc-getFC) >>Makefile
+ echo FFLAGS = ${FCFLAGS:- ${FFLAGS:- -O2}} >>Makefile
+ echo -n FFLAGS_LIBS= >>Makefile
+ pkg-config --libs lapack >>Makefile
+ echo >>Makefile
+ sed -e's/^\(FC *=\)/#\1/' -e's/^\(FFLAGS *=\)/#\1/' \
+ -e's/^\(FFLAGS_LIBS *=\)/#\1/' Makefile.2 >>Makefile
+}
+
+src_compile() {
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ dobin atompaw2abinit
+}