aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <news@jonasstein.de>2014-06-30 23:16:36 +0200
committerJonas Stein <news@jonasstein.de>2014-06-30 23:16:36 +0200
commit45e8119858d048e0c022b6ff4eef2ca667e4ab83 (patch)
treeb5641a07e889426897551bdae414a8bb4a5f03dc /sci-physics/clip
parentsci-chemistry/coot: Fix sandbox violation (diff)
downloadsci-45e8119858d048e0c022b6ff4eef2ca667e4ab83.tar.gz
sci-45e8119858d048e0c022b6ff4eef2ca667e4ab83.tar.bz2
sci-45e8119858d048e0c022b6ff4eef2ca667e4ab83.zip
add Clip4, the Cologne Laue Indexiation Program
Diffstat (limited to 'sci-physics/clip')
-rw-r--r--sci-physics/clip/Manifest4
-rw-r--r--sci-physics/clip/clip-4.0.0_beta2.ebuild39
-rw-r--r--sci-physics/clip/metadata.xml9
3 files changed, 52 insertions, 0 deletions
diff --git a/sci-physics/clip/Manifest b/sci-physics/clip/Manifest
new file mode 100644
index 000000000..fbd8f3a5c
--- /dev/null
+++ b/sci-physics/clip/Manifest
@@ -0,0 +1,4 @@
+DIST Clip4_beta2_source.zip 4478967 SHA256 551f8a157a5a38487c8d6bb97530fa2d279ff3c2e65226ed2b258a8c6e23463e SHA512 2771fc15ccab5427673ce2e98613ae416e7f1c06ae6d2b1c7b0ac23d2b42c962a705e58342a271d9de4ee6be8f88c1768349a792ae39bff2ef03010db753b756 WHIRLPOOL 6d4717e2febd9e37443f688f66b62241fdf280aaa64315160329ac2077e304befe952699158100f31726f9b23092ee06550d67719e429b61024cf8b42cf99656
+EBUILD clip-4.0.0_beta2.ebuild 745 SHA256 31981b7cce53fe44723984a597a1c4ecaedf809392f05025993ad86e12f9e5fb SHA512 0ef4e9eff8b7aa2223818f8f581e5fab35dd4cf7a16ee8198f087eb8494a009d5a6e86189389e38c71f4002879a84b8f73ccab1e2b5cf9b5a9680be058dcdd12 WHIRLPOOL 67a401ac73cf4a19b3141ea87028b8cd9e43ac35f2bb27d837eb74d63964d02555a6575f72c77ccc8a1212d81cd9d17e459b40e906e8dc2ba6a0f9cc9b76e2cd
+EBUILD clip-9999.ebuild 720 SHA256 4585cd9fe85ac91cc2d29b36f612b5f108c72965faecf1af694c10ce3baf5458 SHA512 2f95b08a510d67f1cd0fa1729f97887b1a55ed9d915555718f8ea3a2ec0629879ed04760acaca719431480c092a243f91435bb7f802e8bc62c3df347d017f801 WHIRLPOOL 5c070e62f5c94058f11d01722940f5a12b2397e4555050039ec211a4be682818b2569cb3d5df576a7168031920cc61a0d9b5335ff7592ea801afd4aef182081f
+MISC metadata.xml 480 SHA256 f4a974f57acb8c899a2f5d0607597207526d7568c93e4e55504af0eb8cc420c0 SHA512 8e3e256ffcf3bf82fda13d417be31b99e0d6aef3eaec4b16829778513810c44f3fcd9588269f7a289304d8a2195897d65009dc80d93b463af2676e7531a7c9c4 WHIRLPOOL 56ec6f919d027f22135c9bcc9c73020021b6d04d5b705333245cffb1c6bcea5e3b7baaebf5c371ba3b640ddce4dee77563de09692b3147ae26f806ca663addff
diff --git a/sci-physics/clip/clip-4.0.0_beta2.ebuild b/sci-physics/clip/clip-4.0.0_beta2.ebuild
new file mode 100644
index 000000000..b0ac76ec2
--- /dev/null
+++ b/sci-physics/clip/clip-4.0.0_beta2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit qt4-r2 versionator
+
+MY_P="Clip4_$(get_version_component_range 4)_source"
+
+DESCRIPTION="Interactive program for evaluation of Laue diffraction patterns"
+HOMEPAGE="http://clip4.sf.net/"
+SRC_URI="mirror://sourceforge/clip4/${MY_P}.zip"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-qt/qtcore
+ dev-qt/qtsvg
+ dev-qt/qtgui
+ dev-qt/qtwebkit
+ dev-qt/qtopengl
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare()
+{
+ sed -i -e 's|../eigen|/usr/include/eigen3|' \
+ -e 's|shell hg|shell true|g' Clip4.pro || die "sed failed"
+}
+
+src_install()
+{
+ dobin Clip
+ dodoc README.txt
+}
diff --git a/sci-physics/clip/metadata.xml b/sci-physics/clip/metadata.xml
new file mode 100644
index 000000000..8a9f75597
--- /dev/null
+++ b/sci-physics/clip/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ The Cologne Laue Indexation Program, or short CLIP, is a software for the analysis of Laue patterns.
+
+Clip can simulate Laue patterns for arbitrary settings of crystal and detection plane. Moreover it allows to determine the crystal orientation from spots and zones marked on a Laue photograph.
+ </longdescription>
+</pkgmetadata>