aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-04-26 23:23:06 +0200
committerChristoph Junghans <ottxor@gentoo.org>2011-04-26 23:23:26 +0200
commit380b480785c38e8ec3e82cb3ece9b8cac62cbcd7 (patch)
tree6a8a8df13c7953f8d87941ef784d8e054ea2e446 /sci-physics/espresso/espresso-9999.ebuild
parentsci-physics/abinit: version bump to 6.6.2 (diff)
downloadsci-380b480785c38e8ec3e82cb3ece9b8cac62cbcd7.tar.gz
sci-380b480785c38e8ec3e82cb3ece9b8cac62cbcd7.tar.bz2
sci-380b480785c38e8ec3e82cb3ece9b8cac62cbcd7.zip
[sci-physics/espresso] live ebuild update
(Portage version: 2.1.9.42/git/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-physics/espresso/espresso-9999.ebuild')
-rw-r--r--sci-physics/espresso/espresso-9999.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/sci-physics/espresso/espresso-9999.ebuild b/sci-physics/espresso/espresso-9999.ebuild
index caaf8546c..55908dd46 100644
--- a/sci-physics/espresso/espresso-9999.ebuild
+++ b/sci-physics/espresso/espresso-9999.ebuild
@@ -4,19 +4,26 @@
EAPI="4"
-inherit autotools-utils git savedconfig
+inherit autotools-utils savedconfig
DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
HOMEPAGE="http://www.espressomd.org"
-SRC_URI=""
-EGIT_REPO_URI="git://git.savannah.nongnu.org/espressomd.git"
-EGIT_BRANCH="master"
+if [ "${PV%9999}" != "${PV}" ]; then
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/espressomd.git"
+ EGIT_BRANCH="master"
+ inherit git
+else
+ SRC_URI="mirror://nongnu/${PN}md/${P}.tar.gz"
+fi
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~x86"
IUSE="X doc examples fftw mpi packages test -tk"
+REQUIRED_USE="tk? ( X )"
+
+RESTRICT="tk? ( test )"
RDEPEND="dev-lang/tcl
X? ( x11-libs/libX11 )
@@ -62,9 +69,11 @@ src_install() {
save_config ${AUTOTOOLS_BUILD_DIR}/src/myconfig-final.h
if use doc; then
- newdoc ${AUTOTOOLS_BUILD_DIR}/doc/ug/ug.pdf user_guide.pdf
+ local where="."
+ [ "${PV%9999}" != "${PV}" ] && where="${AUTOTOOLS_BUILD_DIR}"
+ newdoc ${where}/doc/ug/ug.pdf user_guide.pdf
dohtml -r ${AUTOTOOLS_BUILD_DIR}/doc/dg/html/*
- newdoc ${AUTOTOOLS_BUILD_DIR}/doc/tutorials/tut2/tut2.pdf tutorial.pdf
+ newdoc ${where}/doc/tutorials/tut2/tut2.pdf tutorial.pdf
fi
if use examples; then