aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-08-11 15:36:12 -0600
committerChristoph Junghans <ottxor@gentoo.org>2014-08-11 15:36:12 -0600
commit0c431c684afc39867f6749a9caf8a839efb97e67 (patch)
treec69dac5ebe742fa20daa5ea0ad26fceccf45fa08 /sci-physics/espresso
parentsci-chemistry/curvefit: Fix missing libs on prefix (diff)
downloadsci-0c431c684afc39867f6749a9caf8a839efb97e67.tar.gz
sci-0c431c684afc39867f6749a9caf8a839efb97e67.tar.bz2
sci-0c431c684afc39867f6749a9caf8a839efb97e67.zip
sync with gx86
Package-Manager: portage-2.2.8-r1
Diffstat (limited to 'sci-physics/espresso')
-rw-r--r--sci-physics/espresso/ChangeLog6
-rw-r--r--sci-physics/espresso/espresso-9999.ebuild40
-rw-r--r--sci-physics/espresso/metadata.xml1
3 files changed, 35 insertions, 12 deletions
diff --git a/sci-physics/espresso/ChangeLog b/sci-physics/espresso/ChangeLog
index 08d45c23e..c1deada33 100644
--- a/sci-physics/espresso/ChangeLog
+++ b/sci-physics/espresso/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-physics/espresso
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 11 Aug 2014; Christoph Junghans <ottxor@gentoo.org> espresso-9999.ebuild,
+ metadata.xml:
+ sync with gx86
+
11 Dec 2013; Justin Lecher <jlec@gentoo.org> espresso-9999.ebuild:
fix python handling
diff --git a/sci-physics/espresso/espresso-9999.ebuild b/sci-physics/espresso/espresso-9999.ebuild
index a00ef76ed..78cdf623c 100644
--- a/sci-physics/espresso/espresso-9999.ebuild
+++ b/sci-physics/espresso/espresso-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/espresso-3.3.0.ebuild,v 1.1 2014/08/11 21:33:08 ottxor Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python2_7 )
-inherit autotools-utils python-any-r1 savedconfig
+inherit autotools-utils python-single-r1 savedconfig
DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
HOMEPAGE="http://www.espressomd.org"
@@ -16,23 +16,30 @@ if [[ ${PV} = 9999 ]]; then
EGIT_BRANCH="master"
AUTOTOOLS_AUTORECONF=1
inherit git-r3
+ KEYWORDS=""
else
SRC_URI="mirror://nongnu/${PN}md/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
fi
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
-IUSE="X doc examples fftw mpi packages test -tk"
+IUSE="X cuda doc examples +fftw mpi packages python test -tk"
REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
+ python? ( ${PYTHON_REQUIRED_USE} )
tk? ( X )"
RESTRICT="tk? ( test )"
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
dev-lang/tcl
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
fftw? ( sci-libs/fftw:3.0 )
mpi? ( virtual/mpi )
packages? ( dev-tcltk/tcllib )
@@ -47,15 +54,26 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS NEWS README ChangeLog )
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ use cuda && cuda_src_prepare
+ autotools-utils_src_prepare
+}
+
src_configure() {
myeconfargs=(
$(use_with fftw) \
+ $(use_with cuda) \
+ $(use_with python python-interface) \
$(use_with mpi) \
$(use_with tk) \
$(use_with X x)
)
- autotools-utils_src_configure
- restore_config myconfig.h
+ CXX=$(usex mpi "mpic++" "$(tc-getCXX)") autotools-utils_src_configure
+ restore_config myconfig.hpp
}
src_compile() {
@@ -70,9 +88,9 @@ src_install() {
autotools-utils_src_install
insinto /usr/share/${PN}
- doins ${AUTOTOOLS_BUILD_DIR}/myconfig-sample.h
+ doins ${AUTOTOOLS_BUILD_DIR}/myconfig-sample.hpp
- save_config ${AUTOTOOLS_BUILD_DIR}/src/myconfig-final.h
+ save_config ${AUTOTOOLS_BUILD_DIR}/src/core/myconfig-final.hpp
if use doc; then
if [[ ${PV} = 9999 ]] ; then
diff --git a/sci-physics/espresso/metadata.xml b/sci-physics/espresso/metadata.xml
index ff82a5800..64d8bf115 100644
--- a/sci-physics/espresso/metadata.xml
+++ b/sci-physics/espresso/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>sci-physics</herd>
<use>
+ <flag name="cuda">Enable cuda support</flag>
<flag name="examples">Installs the examples</flag>
<flag name="packages">Installs extra subpackages</flag>
</use>