aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2013-01-18 15:37:31 -0800
committerSébastien Fabbro <bicatali@gentoo.org>2013-01-18 15:37:31 -0800
commiteb05685486aacd967f30d4e77f908dd9ad13c26c (patch)
tree4950ac067c5fe2a4c5baafcc0596e80fefe6315a /sci-physics/geant-vmc
parentMerge branch 'master' of git://git.overlays.gentoo.org/proj/sci (diff)
downloadsci-eb05685486aacd967f30d4e77f908dd9ad13c26c.tar.gz
sci-eb05685486aacd967f30d4e77f908dd9ad13c26c.tar.bz2
sci-eb05685486aacd967f30d4e77f908dd9ad13c26c.zip
sci-physics/geant-vmc: Initial import
Package-Manager: portage-2.2.01.21580-prefix
Diffstat (limited to 'sci-physics/geant-vmc')
-rw-r--r--sci-physics/geant-vmc/ChangeLog10
-rw-r--r--sci-physics/geant-vmc/Manifest2
-rw-r--r--sci-physics/geant-vmc/geant-vmc-3.1.14.ebuild39
-rw-r--r--sci-physics/geant-vmc/geant-vmc-4.2.14.ebuild59
-rw-r--r--sci-physics/geant-vmc/metadata.xml19
5 files changed, 129 insertions, 0 deletions
diff --git a/sci-physics/geant-vmc/ChangeLog b/sci-physics/geant-vmc/ChangeLog
new file mode 100644
index 000000000..94581775f
--- /dev/null
+++ b/sci-physics/geant-vmc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-physics/geant-vmc
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*geant-vmc-3.1.14 (18 Jan 2013)
+*geant-vmc-4.2.14 (18 Jan 2013)
+
+ 18 Jan 2013; Sébastien Fabbro <bicatali@gentoo.org> +geant-vmc-3.1.14.ebuild,
+ +geant-vmc-4.2.14.ebuild, +metadata.xml:
+ sci-physics/geant-vmc: Initial import
diff --git a/sci-physics/geant-vmc/Manifest b/sci-physics/geant-vmc/Manifest
new file mode 100644
index 000000000..52cbd209a
--- /dev/null
+++ b/sci-physics/geant-vmc/Manifest
@@ -0,0 +1,2 @@
+DIST geant321+_vmc.1.14.tar.gz 11291981 SHA256 042e99058ae7ead3e443708e7febd53d78000e8b220f537eb8a79ff72cc51aa8 SHA512 6e4bba5781a33289c3b69ce2149136c3be7159bbc2c0794d4729b7a6f1a4ad88647da38a187c64a62cefcb8be0246e65604153a513561bdac833d5fcb67e5793 WHIRLPOOL ddaae245efb7c43752dffd02bb4802d0a6980651038d1a8031d8573f21a9a1c9517f4568c693e86053ae0925feb1adce0c85902108a45b2fb1dd52c1ba0a2d67
+DIST geant4_vmc.2.14.tar.gz 640425 SHA256 0ce12b500217c34315b05f937ccf896036a8eacb3a435fd150b423bf988aeed5 SHA512 abc3ac31d636d599dfe5c8bb2aac24d5a1ece6d53bbb43fa373335e73a03bf1eb6c10fb54f217d807d0395d79e982cee0cea3563e5276dbc3d037551bf97b6f5 WHIRLPOOL df7182522f1658b2a6e136c962a2b16f8e97047ad4cad9012a7e3c5bf6881b3269792e65ffad85cc60a4f54038f6da0576b8966a6c9a56b91b43433e3c4d615e
diff --git a/sci-physics/geant-vmc/geant-vmc-3.1.14.ebuild b/sci-physics/geant-vmc/geant-vmc-3.1.14.ebuild
new file mode 100644
index 000000000..24615b32d
--- /dev/null
+++ b/sci-physics/geant-vmc/geant-vmc-3.1.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit fortran-2 versionator
+
+MPV=$(get_version_component_range 2-)
+
+DESCRIPTION="Virtual Monte Carlo Geant3 implementation"
+HOMEPAGE="http://root.cern.ch/root/vmc/VirtualMC.html"
+SRC_URI="ftp://root.cern.ch/root/vmc/geant321+_vmc.${MPV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ sci-physics/root[pythia6]
+ !sci-physics/geant:3"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/geant3"
+
+src_install() {
+ dolib.so lib/*/*.so
+ insinto /usr/include/TGeant3
+ doins TGeant3/TGeant3.h
+ insinto /usr/include/geant321
+ doins geant321/*.inc
+
+ if use examples; then
+ insinto /usr/shared/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-physics/geant-vmc/geant-vmc-4.2.14.ebuild b/sci-physics/geant-vmc/geant-vmc-4.2.14.ebuild
new file mode 100644
index 000000000..bd8c303c8
--- /dev/null
+++ b/sci-physics/geant-vmc/geant-vmc-4.2.14.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit versionator
+
+MPV=$(get_version_component_range 2-)
+
+DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
+HOMEPAGE="http://root.cern.ch/root/vmc/VirtualMC.html"
+SRC_URI="ftp://root.cern.ch/root/vmc/geant4_vmc.${MPV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples vgm"
+
+RDEPEND="
+ sci-physics/root
+ sci-physics/geant:4[opengl,geant3,examples?]
+ vgm? ( sci-physics/vgm )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/geant4_vmc"
+
+src_compile() {
+ use vgm && export USE_VGM=1
+ local dirs="g4root source"
+ use examples && dirs+=" examples"
+ local d
+ for d in ${dirs}; do
+ pushd ${d} > /dev/null
+ emake
+ use doc && doxygen
+ popd > /dev/null
+ done
+}
+
+src_test() {
+ cd examples
+ emake
+ ./run_suite.sh || die
+ use examples || emake clean
+}
+
+src_install() {
+ dolib.so lib/tgt_*/{libg4root,libgeant4vmc}.so
+ insinto /usr
+ doins -r include
+ dodoc README history version_number
+ use doc && dohtml -r Geant4VMC.html doc/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-physics/geant-vmc/metadata.xml b/sci-physics/geant-vmc/metadata.xml
new file mode 100644
index 000000000..a5a0c847a
--- /dev/null
+++ b/sci-physics/geant-vmc/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ The Virtual Monte Carlo (VMC) allows to run different simulation
+ Monte Carlo without changing the user code and therefore the input
+ and output format as well as the geometry and detector response
+ definition.
+ The core of the VMC is the category of classes vmc in ROOT. It
+ provides a set of interfaces which completely decouple the
+ dependencies between the user code and the concrete Monte Carlo.
+ Geant3 VMC (C++) is provided within a single package together with
+ GEANT3 (Fortran) - geant3.
+</longdescription>
+<use>
+ <flag name="vgm">Enable the Virtual Geometry Model (<pkg>sci-physics/vgm</pkg>)</flag>
+</use>
+</pkgmetadata>