aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2014-03-25 11:59:47 +0100
committerOliver Freyermuth <o.freyermuth@googlemail.com>2014-03-25 12:02:27 +0100
commit73c2198c584032651087016c3560a70c7225178d (patch)
tree7a3a0616a06b050565ecd359082a40d85c7d2704 /sci-physics/genfit
parentsci-libs/mkl: Version Bump (diff)
downloadsci-73c2198c584032651087016c3560a70c7225178d.tar.gz
sci-73c2198c584032651087016c3560a70c7225178d.tar.bz2
sci-73c2198c584032651087016c3560a70c7225178d.zip
Add live-ebuild, add subslot-dependency on sci-physics/root (depends on #505358 to become effective) and dev-libs/boost .
Diffstat (limited to 'sci-physics/genfit')
-rw-r--r--sci-physics/genfit/ChangeLog7
-rw-r--r--sci-physics/genfit/genfit-02.00.00.ebuild22
-rw-r--r--sci-physics/genfit/genfit-9999.ebuild56
3 files changed, 75 insertions, 10 deletions
diff --git a/sci-physics/genfit/ChangeLog b/sci-physics/genfit/ChangeLog
index f074dc78a..99d6f82d6 100644
--- a/sci-physics/genfit/ChangeLog
+++ b/sci-physics/genfit/ChangeLog
@@ -2,6 +2,13 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*genfit-9999 (25 Mar 2014)
+
+ 25 Mar 2014; Oliver Freyermuth <o.freyermuth@googlemail.com>
+ genfit-02.00.00.ebuild, +genfit-9999.ebuild:
+ Add live-ebuild, add subslot-dependency on sci-physics/root (depends on
+ #505358 to become effective) and dev-libs/boost .
+
22 Mar 2014; <o.freyermuth@googlemail.com> genfit-02.00.00.ebuild:
Fix incorrect working directory (adapt to zipped file)
diff --git a/sci-physics/genfit/genfit-02.00.00.ebuild b/sci-physics/genfit/genfit-02.00.00.ebuild
index 596f3e9e1..375e35579 100644
--- a/sci-physics/genfit/genfit-02.00.00.ebuild
+++ b/sci-physics/genfit/genfit-02.00.00.ebuild
@@ -5,28 +5,30 @@
EAPI=5
inherit cmake-utils versionator
-
-#ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/tags/v$(replace_all_version_separators '-')"
-#ESVN_PROJECT="${PN}.${PV}"
-
-TAG_VER=${PN}-code-1688-tags-v$(replace_all_version_separators '-')
+if [[ ${PV} == *9999* ]]; then
+ inherit subversion
+ ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/trunk"
+ ESVN_PROJECT="${PN}.${PV}"
+else
+ TAG_VER=${PN}-code-1688-tags-v$(replace_all_version_separators '-')
+ SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/${TAG_VER}.zip"
+fi
DESCRIPTION="a generic toolkit for track reconstruction for experiments in particle and nuclear physics"
HOMEPAGE="http://genfit.sourceforge.net/Main.html"
-SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/${TAG_VER}.zip"
LICENSE="LGPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+[[ ${PV} == *9999* ]] || KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples"
RDEPEND="
- sci-physics/root
- dev-libs/boost"
+ sci-physics/root:=
+ dev-libs/boost:="
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )"
-S=${WORKDIR}/${TAG_VER}
+[[ ${PV} == *9999* ]] || S=${WORKDIR}/${TAG_VER}
src_compile() {
cmake-utils_src_compile
diff --git a/sci-physics/genfit/genfit-9999.ebuild b/sci-physics/genfit/genfit-9999.ebuild
new file mode 100644
index 000000000..375e35579
--- /dev/null
+++ b/sci-physics/genfit/genfit-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils versionator
+if [[ ${PV} == *9999* ]]; then
+ inherit subversion
+ ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/trunk"
+ ESVN_PROJECT="${PN}.${PV}"
+else
+ TAG_VER=${PN}-code-1688-tags-v$(replace_all_version_separators '-')
+ SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/${TAG_VER}.zip"
+fi
+
+DESCRIPTION="a generic toolkit for track reconstruction for experiments in particle and nuclear physics"
+HOMEPAGE="http://genfit.sourceforge.net/Main.html"
+
+LICENSE="LGPL-3"
+SLOT="0"
+[[ ${PV} == *9999* ]] || KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ sci-physics/root:=
+ dev-libs/boost:="
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+[[ ${PV} == *9999* ]] || S=${WORKDIR}/${TAG_VER}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && cmake-utils_src_compile doc
+ use examples && cmake-utils_src_compile tests
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r "${BUILD_DIR}/bin"
+ doins "${S}/test/makeGeom.C"
+ doins "${S}/test/README"
+ fi
+ cd doc || die
+ use doc && dohtml -r "${S}/doc/html/"*
+ echo
+ elog "Note that there is no support in this ebuild for RAVE yet,"
+ elog "which is also not in portage."
+ elog "It should be possible to use a local installation of RAVE"
+ elog "and set:"
+ elog " export RAVEPATH=<yourRaveDirectory>"
+ echo
+}