aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2014-03-28 01:24:57 +0100
committerOliver Freyermuth <o.freyermuth@googlemail.com>2014-03-28 01:24:57 +0100
commitfb9e842d8deb636246306feb8d30b1996dbbbc74 (patch)
treeaf5c5712fbbb24ac87cfb66550ecebf531723527 /sci-physics/genfit
parentAdd live-ebuild, add subslot-dependency on sci-physics/root (depends on #5053... (diff)
downloadsci-fb9e842d8deb636246306feb8d30b1996dbbbc74.tar.gz
sci-fb9e842d8deb636246306feb8d30b1996dbbbc74.tar.bz2
sci-fb9e842d8deb636246306feb8d30b1996dbbbc74.zip
Unify the specialties between live and non-live ebuild so only one if-clause is needed, fixes code duplication.
Diffstat (limited to 'sci-physics/genfit')
-rw-r--r--sci-physics/genfit/ChangeLog5
-rw-r--r--sci-physics/genfit/genfit-02.00.00.ebuild6
-rw-r--r--sci-physics/genfit/genfit-9999.ebuild6
3 files changed, 11 insertions, 6 deletions
diff --git a/sci-physics/genfit/ChangeLog b/sci-physics/genfit/ChangeLog
index 99d6f82d6..deeb279ac 100644
--- a/sci-physics/genfit/ChangeLog
+++ b/sci-physics/genfit/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 28 Mar 2014; Oliver Freyermuth <o.freyermuth@googlemail.com>
+ genfit-02.00.00.ebuild, genfit-9999.ebuild:
+ Unify the specialties between live and non-live ebuild so only one if-clause
+ is needed.
+
*genfit-9999 (25 Mar 2014)
25 Mar 2014; Oliver Freyermuth <o.freyermuth@googlemail.com>
diff --git a/sci-physics/genfit/genfit-02.00.00.ebuild b/sci-physics/genfit/genfit-02.00.00.ebuild
index 375e35579..963de559e 100644
--- a/sci-physics/genfit/genfit-02.00.00.ebuild
+++ b/sci-physics/genfit/genfit-02.00.00.ebuild
@@ -5,6 +5,7 @@
EAPI=5
inherit cmake-utils versionator
+
if [[ ${PV} == *9999* ]]; then
inherit subversion
ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/trunk"
@@ -12,6 +13,8 @@ if [[ ${PV} == *9999* ]]; then
else
TAG_VER=${PN}-code-1688-tags-v$(replace_all_version_separators '-')
SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/${TAG_VER}.zip"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ S=${WORKDIR}/${TAG_VER}
fi
DESCRIPTION="a generic toolkit for track reconstruction for experiments in particle and nuclear physics"
@@ -19,7 +22,6 @@ HOMEPAGE="http://genfit.sourceforge.net/Main.html"
LICENSE="LGPL-3"
SLOT="0"
-[[ ${PV} == *9999* ]] || KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples"
RDEPEND="
@@ -28,8 +30,6 @@ RDEPEND="
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )"
-[[ ${PV} == *9999* ]] || S=${WORKDIR}/${TAG_VER}
-
src_compile() {
cmake-utils_src_compile
use doc && cmake-utils_src_compile doc
diff --git a/sci-physics/genfit/genfit-9999.ebuild b/sci-physics/genfit/genfit-9999.ebuild
index 375e35579..963de559e 100644
--- a/sci-physics/genfit/genfit-9999.ebuild
+++ b/sci-physics/genfit/genfit-9999.ebuild
@@ -5,6 +5,7 @@
EAPI=5
inherit cmake-utils versionator
+
if [[ ${PV} == *9999* ]]; then
inherit subversion
ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/trunk"
@@ -12,6 +13,8 @@ if [[ ${PV} == *9999* ]]; then
else
TAG_VER=${PN}-code-1688-tags-v$(replace_all_version_separators '-')
SRC_URI="http://sourceforge.net/code-snapshots/svn/g/ge/genfit/code/${TAG_VER}.zip"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ S=${WORKDIR}/${TAG_VER}
fi
DESCRIPTION="a generic toolkit for track reconstruction for experiments in particle and nuclear physics"
@@ -19,7 +22,6 @@ HOMEPAGE="http://genfit.sourceforge.net/Main.html"
LICENSE="LGPL-3"
SLOT="0"
-[[ ${PV} == *9999* ]] || KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples"
RDEPEND="
@@ -28,8 +30,6 @@ RDEPEND="
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )"
-[[ ${PV} == *9999* ]] || S=${WORKDIR}/${TAG_VER}
-
src_compile() {
cmake-utils_src_compile
use doc && cmake-utils_src_compile doc