aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-04-27 19:30:28 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-04-27 19:30:28 +0000
commitc31a61882f17af9ab7df89bb894643eec3059596 (patch)
tree723c405e23326de36550d6ca46ec710c4a14e8f7 /sci-physics/phun/phun-3.5.ebuild
parentplplot: more use flags dep checking (diff)
downloadsci-c31a61882f17af9ab7df89bb894643eec3059596.tar.gz
sci-c31a61882f17af9ab7df89bb894643eec3059596.tar.bz2
sci-c31a61882f17af9ab7df89bb894643eec3059596.zip
added phun
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1027 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-physics/phun/phun-3.5.ebuild')
-rw-r--r--sci-physics/phun/phun-3.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-physics/phun/phun-3.5.ebuild b/sci-physics/phun/phun-3.5.ebuild
new file mode 100644
index 000000000..4edac9081
--- /dev/null
+++ b/sci-physics/phun/phun-3.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator eutils
+
+MY_P="Phun_beta_$(get_major_version)_$(get_after_major_version)_linux"
+DESCRIPTION="Phun is a physics simulator such as gravity, friction, and so on"
+HOMEPAGE="http://www.phun.at/"
+SRC_URI="x86? ( http://ftp.acc.umu.se/mirror/phun/${MY_P}32.tar.bz2 )
+ amd64? ( http://phun.cs.umu.se/files/${MY_P}64.tar.bz2 )"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="virtual/opengl
+ media-libs/sdl-image
+ dev-libs/boost
+ >=media-libs/glew-1.5"
+DEPEND=""
+RESTRICT="strip"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /opt
+ doins -r Phun/
+ exeinto /opt/Phun
+ doexe Phun/phun.bin
+ make_desktop_entry phun Phun /opt/Phun/Phun.bmp
+ make_wrapper phun /opt/Phun/phun.bin /opt/Phun .
+}