aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-07-11 15:45:53 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-07-11 15:45:53 +0000
commit25c388f0baa31f952d1853b3283d5fee1d079acb (patch)
treeadc13d9a38c9ed2ce93cff28e586fbd9f4b78e37 /sci-physics/pythia/pythia-8.1.08.ebuild
parentgap-4.4.10: sysinfo.gap now installed (diff)
downloadsci-25c388f0baa31f952d1853b3283d5fee1d079acb.tar.gz
sci-25c388f0baa31f952d1853b3283d5fee1d079acb.tar.bz2
sci-25c388f0baa31f952d1853b3283d5fee1d079acb.zip
Added pythia (6 and 8)
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1215 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-physics/pythia/pythia-8.1.08.ebuild')
-rw-r--r--sci-physics/pythia/pythia-8.1.08.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sci-physics/pythia/pythia-8.1.08.ebuild b/sci-physics/pythia/pythia-8.1.08.ebuild
new file mode 100644
index 000000000..ead318b8d
--- /dev/null
+++ b/sci-physics/pythia/pythia-8.1.08.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator multilib toolchain-funcs
+
+MV=$(get_major_version)
+MY_P=${PN}$(replace_all_version_separators "" ${PV})
+
+DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
+HOMEPAGE="http://home.thep.lu.se/~torbjorn/Pythia.html"
+SRC_URI="http://home.thep.lu.se/~torbjorn/${PN}${MV}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="8"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ # evil hand-rolled stuff (no autoconf)
+ ./configure \
+ --enable-shared \
+ || die "configure failed"
+ # add user's flags TODO can this be done better?
+ echo CXXFLAGS+="${CXXFLAGS}" >> config.mk
+ emake CXX=$(tc-getCXX) || die "emake failed"
+}
+
+src_test() {
+ cd "${S}"/examples
+ ./configure \
+ --enable-shared \
+ || die "configure for examples failed"
+ echo CXXFLAGS+=${CXXFLAGS} >> config.mk
+ emake CXX=$(tc-getCXX) || die "emake examples failed"
+ ./runmains || die "test of examples failed"
+}
+
+src_install() {
+ dolib.so lib/*so || die "shared lib install failed"
+ dolib.a lib/archive/* || die "static lib install failed"
+
+ insinto /usr/include/${PN}
+ doins include/* || die "headers install failed"
+
+ insinto /usr/share/doc/${PF}
+ dodoc GUIDELINES AUTHORS README
+ if use doc; then
+ doins -r worksheet.pdf examples htmldoc || die "doc install failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "pythia-8 ebuild is still under development."
+ elog "Help us improve the ebuild in:"
+ elog "http://bugs.gentoo.org/show_bug.cgi?id=231484"
+}