aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2006-08-11 20:20:18 +0000
committergrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2006-08-11 20:20:18 +0000
commitd9d36c94a982408aec47c740f1ec6adfc4132f2d (patch)
treecea0ca6d0d86e4d383ee16a55a6a190ce2fdf767 /sci-physics/qcl/qcl-0.6.2.ebuild
parentnew version: texmacs-1.0.6.5 (diff)
downloadsci-d9d36c94a982408aec47c740f1ec6adfc4132f2d.tar.gz
sci-d9d36c94a982408aec47c740f1ec6adfc4132f2d.tar.bz2
sci-d9d36c94a982408aec47c740f1ec6adfc4132f2d.zip
added qcl-0.6.2
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@267 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-physics/qcl/qcl-0.6.2.ebuild')
-rw-r--r--sci-physics/qcl/qcl-0.6.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-physics/qcl/qcl-0.6.2.ebuild b/sci-physics/qcl/qcl-0.6.2.ebuild
new file mode 100644
index 000000000..b50b5c93e
--- /dev/null
+++ b/sci-physics/qcl/qcl-0.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Quantum Computation Language with an emulator of a quantum computer"
+HOMEPAGE="http://tph.tuwien.ac.at/~oemer/qcl.html"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="doc"
+RESTRICT="nomirror"
+SRC_URI="http://tph.tuwien.ac.at/~oemer/tgz/qcl-0.6.2.tgz
+ doc? ( http://tph.tuwien.ac.at/~oemer/doc/structquprog.pdf
+ http://tph.tuwien.ac.at/~oemer/doc/qcldoc.pdf
+ http://tph.tuwien.ac.at/~oemer/doc/quprog.pdf )"
+DEPENDS="media-libs/plotutils"
+
+src_compile() {
+ emake QCLDIR="/usr/share/${PN}" || die "emake failed"
+}
+
+src_install() {
+ make QCLDIR="${D}/usr/share/${PN}" QCLBIN="${D}/usr/bin" install \
+ || die "install failed"
+ dodoc README CHANGES
+ if use doc ; then
+ insinto "/usr/share/doc/${PF}"
+ cd "${DISTDIR}"
+ doins structquprog.pdf qcldoc.pdf quprog.pdf
+ fi
+}