aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2010-05-26 18:28:40 +0100
committerSébastien Fabbro <bicatali@gentoo.org>2010-05-26 18:28:40 +0100
commitb550d9d22ef18ed36809c00990bb84e5fc8c0b0e (patch)
tree022c519316a8754ae7b97df3a43c252dd130b616 /sci-physics/qcl/qcl-0.6.3-r1.ebuild
parentcoot missing link lib patch (diff)
downloadsci-b550d9d22ef18ed36809c00990bb84e5fc8c0b0e.tar.gz
sci-b550d9d22ef18ed36809c00990bb84e5fc8c0b0e.tar.bz2
sci-b550d9d22ef18ed36809c00990bb84e5fc8c0b0e.zip
qcl fixes for gcc and deps
Diffstat (limited to 'sci-physics/qcl/qcl-0.6.3-r1.ebuild')
-rw-r--r--sci-physics/qcl/qcl-0.6.3-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-physics/qcl/qcl-0.6.3-r1.ebuild b/sci-physics/qcl/qcl-0.6.3-r1.ebuild
new file mode 100644
index 000000000..e101fae5a
--- /dev/null
+++ b/sci-physics/qcl/qcl-0.6.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit flag-o-matic eutils
+
+DESCRIPTION="Quantum Computation Language with an emulator of a quantum computer"
+HOMEPAGE="http://tph.tuwien.ac.at/~oemer/qcl.html"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+
+SRC_URI="http://tph.tuwien.ac.at/~oemer/tgz/${P}.tgz
+ doc? ( http://tph.tuwien.ac.at/~oemer/doc/structquprog.pdf
+ http://tph.tuwien.ac.at/~oemer/doc/qcldoc.pdf
+ http://tph.tuwien.ac.at/~oemer/doc/quprog.pdf )"
+DEPEND="media-libs/plotutils
+ sys-libs/ncurses
+ sys-libs/readline"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_install() {
+ emake \
+ QCLDIR="${D}/usr/share/${PN}" \
+ QCLBIN="${D}/usr/bin" install \
+ || die "emake install failed"
+ dodoc README CHANGES
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/{structquprog,qcldoc,quprog}.pdf || die
+ fi
+}