aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gmail.com>2012-07-01 10:58:08 +0400
committerAndrew Savchenko <bircoph@gmail.com>2012-07-01 10:58:08 +0400
commit24c15d7d99615871d6fb2d36b17509f1d4af49cc (patch)
tree27a1ffd387e6fe1dc875ef2eb84f68e2a664cb81 /sci-physics/root/root-9999.ebuild
parentapp-doc/root-docs: backport fixes from portage (diff)
downloadsci-24c15d7d99615871d6fb2d36b17509f1d4af49cc.tar.gz
sci-24c15d7d99615871d6fb2d36b17509f1d4af49cc.tar.bz2
sci-24c15d7d99615871d6fb2d36b17509f1d4af49cc.zip
sci-physics/root: backport fixes from the portage
and remove old data
Diffstat (limited to 'sci-physics/root/root-9999.ebuild')
-rw-r--r--sci-physics/root/root-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index e9b547650..689046eff 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -16,7 +16,7 @@ else
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
-inherit elisp-common eutils fdo-mime fortran-2 multilib python toolchain-funcs user ${_SVN}
+inherit elisp-common eutils fdo-mime fortran-2 multilib python ${_SVN} toolchain-funcs user versionator
ROOFIT_DOC_PV=2.91-33
TMVA_DOC_PV=4.03
@@ -37,7 +37,7 @@ SRC_URI="${SRC_URI}
SLOT="0"
LICENSE="LGPL-2.1"
-IUSE="+X afs avahi c++0x clarens doc emacs examples fits fftw graphviz htmldoc
+IUSE="+X afs avahi -c++0x clarens doc emacs examples fits fftw graphviz htmldoc
kerberos ldap llvm +math mpi mysql odbc +opengl openmp oracle postgres prefix
pythia6 pythia8 python qt4 +reflex ruby ssl xft xinetd xml xrootd"
@@ -75,7 +75,6 @@ CDEPEND="
)
afs? ( net-fs/openafs )
avahi? ( net-dns/avahi )
- c++0x? ( >=sys-devel/gcc-4.7.0 )
clarens? ( dev-libs/xmlrpc-c[curl] )
emacs? ( virtual/emacs )
fits? ( sci-libs/cfitsio )
@@ -132,8 +131,8 @@ pkg_setup() {
if use math; then
if use openmp; then
- if [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
- ewarn "You are using a gcc without OpenMP capabilities"
+ if [[ $(tc-getCXX)$ == *g++* ]] && ! tc-has-openmp; then
+ ewarn "You are using a g++ without OpenMP capabilities"
die "Need an OpenMP capable compiler"
else
export USE_OPENMP=1 USE_PARALLEL_MINUIT2=1
@@ -142,6 +141,11 @@ pkg_setup() {
export USE_MPI=1 USE_PARALLEL_MINUIT2=1
fi
fi
+ if use c++0x && [[ $(tc-getCXX) == *g++* ]] && \
+ ! version_is_at_least "4.7" "$(gcc-version)"; then
+ eerror "You are using a g++ without C++0x capabilities"
+ die "Need an C++0x capable compiler"
+ fi
}
src_prepare() {